RPI4 + Hifiberry not persistent in KODI

  • Hi


    My hifiberry dac+ works fine except that the kodi sound output always fallback to HDMI when rebooting

    How to make the output persistent to the hifiberry sound-card in Kodi ?


    Libreelec release 9.2.2 on RPI4

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Note: Full logs only. No partial or modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.

    -----------------------------


    Also output of /flash/config.txt

  • HI


    Log is here


    Also config.txt below :


  • Which version of the dac+ do you have? Light/standard/pro? If NOT the "light", try removing the "dtoverlay=hifiberry-dacplus" from confix.txt.


    Also you have a LOT of addons installed - can you try a fresh install on a separate SD card and see if you have the same issues.

  • Your hifiberry card seems to be detected fine.


    However you have a lot of pulseaudio errors in your log and seem to be using the librespot addon. Please try with the librespot addon removed, if that fixes audio device in kodi it's best to ask in the librespot thread.


    so long,


    Hias

  • Code
    1. 2020-04-12 06:47:51.414 T:2320466800 NOTICE: ADDON: service.bluetooth-audio v9.2.0.102 installed

    Bluetooth Audio Device Changer is setting the defined default audio device when starting. Change the addon setting.

  • Code
    1. 2020-04-12 06:47:51.414 T:2320466800 NOTICE: ADDON: service.bluetooth-audio v9.2.0.102 installed

    Bluetooth Audio Device Changer is setting the defined default audio device when starting. Change the addon setting.

    Well spotted, this is most certainly the culprit.


    forget my comment regarding librespot, that addon is probably fine.


    so long,


    Hias

  • My experience with a similar issue with the Khadas Tone board turned out to be a persistent settings issue which was resolved ultimately by doing a fresh install. Hidden logic is the cause of the issue. Its unlikely that a real fix will be found since this is a corner case which will only effect a few instances.

    I also had success by setting the default sink in the ALSA settings file, but other people found this caused its own issues which resulted in a bootloop.

    Shoog

  • Code
    1. 2020-04-12 06:47:51.414 T:2320466800 NOTICE: ADDON: service.bluetooth-audio v9.2.0.102 installed

    Bluetooth Audio Device Changer is setting the defined default audio device when starting. Change the addon setting.

    This indeed resolved the problem, thanks a lot !

    I shall also clean a little bite all the other unused add-on

    Edited once, last by bierre2000 ().