Rpi4 + LE + Samsung 7300

  • [Sorry for all the edits. I'm not allowed to post more often that 2bazillian seconds, so the only thing I can do is edit my original post. No one can see the post yet anyway.... *sigh* When I'm done and everything's resolved, I'll add a bit at the end to summarize.]


    I'll start a new thread, as I've abused someone else's thread long enough (my apologies.)


    So I started out with upgrading my Rpi3 to a 4 and of course getting LE 9.2.1.


    Things are running ok in 1080p, but I'm having a couple of problems with the new panel.


    1) No sound. I've tried eliminating the Pioneer video receiver -- so the HDMI cable is plugged directly into the TV's HDMI1 input. (more on the receiver in a moment) I've checked Kodi's audio settings and reset them all to default. The tv doesn't have much to say here, just a choice of speaker or optical out or bluetooth: I have it set to internal speakers. The TV seems to work ok at other audio tasks. Not sure what else I can check here, but my next stop is to google troubleshooting sound on Kodi.


    Well that turned out to be a simple fix: I used the other HDMI port on the Pi and the sound came back. After shutting down the Pi, I unplugged the power, moved the HDMI cable to the port closest to the power port, then started things up again. *poof* I had sound. I suppose that second port can't do sound. I didn't read the directions. :) Now to find that S/PDIF cable and see if that will work.


    2) 1080p movies play just fine (no sound). I've whitelisted: 3840x2160p 30/29.97/25/24/23.98 and 1080p 60/59.94/50 (curious: there are two 1920x1080p 60 settings... I whitelisted them both.) My test movie (2001 ASO), still has the hesitation issues, but otherwise plays ok. A couple of movies that report 3840x1616 23.976fps are playing, but with weird artifacts. I suspect a mismatch issue that my cpu can't handle. Hm. Actually the second of those is 3840x1608 instead of 1616... meh. I guess those movies are probably just not going to work here. Curiously, a movie that is formatted 3840x2160 23.976 seems to play fine for a while, but then goes black for some reason. Update: I changed the default gui display to 4k and now the movie is playing mostly ok. There's an occasional jerk on long, slow pan shots, but it's a better experience than the 2001 movie. The 2001 movie is also 3840x2160 23.976. I wonder if it might be defective. I just don't have another source to verify.


    Anyway... back to the task at hand.


    Side note: when I was checking out the 3840x2160 movie that went black, I had the gui set to 1080p. I suspect I was trying to use the OSD to check out the video format when it went black. When I tried to leave the movie running and use the gui, the whole box hung and I had to reset it. That's when I decided to change the gui to 4k and that cleared up the simultaneous gui+movie-in-the-background issues.


    Another side note: I couldn't get any 4k resolutions to appear in the gui when connected through my (ancient) Pioneer video receiver. I suspected that the old hardware can't handle 4k and thus always reports the attached panel as 1080p. Eliminating the old hardware fixed that issue. I think I can get the old S/PDIF optical audio cable from the tv to the receiver and do that instead. Later.


    Insofar as the 4k issue is concerned: I seem to have proven for myself what chewitt told us over in the other thread: matching video formats work, mismatches not so much, except 1080p->4k.


    Anyway, I just wanted to share how things were progressing. I'm off to see what I can do with the sound situation. But 4k is not quite all there, it would seem


    I will try putting the hdmi_enable_4kp60=1 back in the config.txt and reboot... maybe that will help with the hesitation issues?

    Edited once, last by fbicknel ().

  • Ok... things have settled down a bit.


    The 2001 ASO movie continued to give me hesitation issues, so I decided to switch media to a smaller file of roughly the same resolution.


    This one is apparently 3840x1744 23.976. The hesitation is still there, although subjectively milder.


    I discovered a few new tools to use, so here's a screenshot or three....



    These two show an increase in drop and skip values. Unfortunately, I soon learned that these only occurred when I took a screenshot. As I watched the movie with these statistics running, I never saw either of these go up spontaneously. So the hesitations are not due to drops or skips, imho.


    Here are some more facts about the movie:

    I had to crop this one a bit to fit the 1MB requirement here.


    Kodi debug log while 4k movie is running - Pastebin.com <- the log


    On other fronts, 1080p is very good. I have the sound issues at bay: it's not perfect, but it's very good. Passing the sound through the TV seems to remove the surround information from the stream, which seems perfectly logical. The receiver adds some of it back in, so at least it doesn't seem to all come from the front. But TV viewing is very nice even if movies are slightly less enjoyable on the sound front. I suppose my next venture is a 4k-capable receiver through which I can pass the signal.


    I did put the hdmi_enable_4kp60=1 directive back and it seems to make no difference.

  • The board will likely be more stable without hdmi_enable_4kp60=1 but mostly it only enables 4K modes you don't need.


    Can you create a sample file .. 100MB or so of the movie from a scene where you see skipping? - we are always on the search for bad media and/or things that stress playback for the Pi Foundation developers to look at.

  • Terribly sorry for not replying, chewitt .


    I decided to give up on it until I had the display all straightened out.


    Got a new Pioneer receiver that's 4K capable and have it all set up now. It's been working pretty well for a few weeks, now.


    Unfortunately, some 4K movies still show artifacts at the top of the frame which "bleed" down into the picture. The stuttering and hesitations are gone, now. Thankfully.


    This happens on several 4K movies (Stream #0:0(eng): Video: hevc (libx265), yuv420p10le, 3840x1608 [SAR 1:1 DAR 160:67], q=2-31, 23.98 fps, 1k tbn, 23.98 tbc (default), if that's helpful).


    They play ok on my laptop... but it has a GPU, and I suspect that could be key here.


    I've attached a screenshot of the offensive artifacts. The more action, the more of them there are. I had to severely cut it down, as there's apparently a 1MB file size limit.


    Oh, wow: STILL? "Newly created posts will remain inaccessible for others until approved by a moderator."