[8.0.2e] LibreELEC 8.0 for S905/S905X


  • It should be working without suspend.
    CEC( LG Sslimplink) works me too, and I am able to control my KII Pro by simplink(cec) on LG remote control
    When I turned on my box then LG TV turned automatically on and switched to the input source of my box,
    When I turned off LG TV then my box turned automatically off ,too.

  • Hi everyone. I got the sunvell t95x (2g/8g version) and I tried to install Libreelec (I am new to this so I hope I did nothing wrong), but I cannot seem to find any wifi networks. When I go to settings-->Libreelec, there is nothing next to the connection tab.
    I tried both gxl_p212_2g.dtb and gxl_p212_2g_nand.dtb
    but none of them changed anything.
    Can someone help me?
    I cannot boot to android as I changed the bootvideo and a line in the build.prop file in the folder system/etc and since then I just get a yellow flickering screen when it tries to boot to android, so Libreelec is my final solution before sending sunvell t95x to the garbage .


  • If for some reason the internal WiFi isn't supported - rather than bin the box, a cheap external WiFi dongle that IS supported would be a way out...

  • s2117
    I had this to do you have a backup of build prop Android first rule make a backup you should know how your box called then you can recover it.
    I changed build prop to install another Rom device Name should it be


  • Sunvell T95X Amlogic S905X Android TV Box - 2GB + 8GB - FreakTab.com


    might help you get android back


    try this link instead


    [Firmware] T95X AMLOGIC S905X 4K KODI 16.1 PREINSTALED ANDROID 6.0 TV BOX FIRMWARE 20160921 - FreakTab.com

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

    Edited once, last by bubblegum57 ().


  • I have the same box!! For me it works with the gxl_p212_2g_nand.dtb!!

  • Amlogic Nougat kernel code is now public so I tried to use it for my LE builds but unfortunately it had some ugly bugs and you'd had to update your device trees so I though I can try porting the most important changes to our current kernel.


    A result of this is a new build with Frankenstein kernel to test in OP: 8.0.1b. Please report any regressions in video playback that you observe (known bugs are known!). It's always safe to "update" to 8.0.1a if 8.0.1b does not work well for you, you won't loose your data.

  • Yeah, it worked for me as well, but the difference is it doesn't shut down at all no matter what I set so it would be useful for me to know how to bring it back.



    the only way to have suspend function back is to revert this commit:


    f855c2a ("Revert "projects/S905: configure systemd to disallow suspend and hibernation"", 2017-03-16)


    here's 8.0.1a with "no suspend/hyb reverted" :


    MEGA

    Edited once, last by stormrev ().

  • Wrong thread sorry.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().

  • Regression in 8.0.1b: Force RGB no longer works.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • curious: what linux version is Amlogic Nougat kernel code? Is it the 4.9.4 from buildroot-openlinux-20170310?

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Thanks, as always!


    BTW: Was anything changed with black levels? I seem to have a slightly darker picture (actually looks better than before). Or is this because of the YCbCr instead of RGB mode?

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • It's still 3.14.29.


    Kernel 4.9 is not fully functional and when ready will probably need to have hw decoding in Kodi reworked (again).


    mmpp It looks like Amlogic fixed something in HDR/black level handling.

    Edited once, last by kszaq ().

  • Hi, 8.0.1b test:
    I have problem with some H264 videos.
    For example favorite test video "Samsung.Demo.Oceanic.Life.x264.1080p.40Mbps.mkv" or some my camera files (Mvi_2930.mkv,...) ...
    8.0.1a version both plays perfectly, but on 8.0.1b files are unplayable :-(
    You can download and test here:
    Samsung.Demo.Oceanic.Life.x264.1080p.40Mbps.mkv - Google Drive
    Mvi_2930.mkv - Google Drive


    Thank you for your perfect work!

    Sunvell T95Z Max (S912) 2G/16G 1Gbit LAN, MXV+ (S905) 1G/8B 1Gbit LAN , NAS D-Link 320L, TV LG 65UK6500MLA, Receiver Yamaha RX-V475

    Edited once, last by Whitesak ().

  • Hallelujah!!! Brightness and Contrast are working properly for the first time ever on my s905x box. You can actually lower the brightness below 50 now without the weird inverted picture. I have seen several others reporting the same thing recently. Major, major improvement in picture quality. I'm gonna have to reset the TV controls back to sane settings now.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME