[8.0.2e] LibreELEC 8.0 for S905/S905X

  • The only thing that I can after that message is unplug the Hub. Every time i boot from SD card i get the same message.

    Edited once, last by kszaq ().

  • Few versions back when I turned off my tv so did my player but now it doesn't work. No matter if I set it to turn off or sleep it stays on. Any ideas?

  • It will delete the android system.
    He stated to install to SD card not to nand.

    Get your IP address from Kodi System Information on your Box
    Log In to the box in SSH with Putty from PC Computer
    user: root
    Password: libreelec
    Type installtointernal

  • I wanna aml timing version... It was great to me I have Beelink Mini MX S905 and Sunvell T95X S905X both works great to kszaq's build I miss super speedy switching channel

  • My best understanding is that OTG is is "On The Go" USB. When you jump 2 pins it turns the NAND into a USB drive when connected to PC and you can write to it directly.

    Channel switching is really slow on this build. To be clear, I'm using IPTV so I'm not sure if that is expected. To comapre, I was at 1 second with the last build and now I'm at 3 seconds.

    I sent you $20 for all the good work, thanks!

    Raspberry Pi 4, Harmony Remote, GPIO IR

  • I really don't see the channel switching issues reported by others, but I am using a mythtv backend for livetv. I get about 1-2 seconds which is fine with me. I rarely got that performance using mythfrontend.

    The only real improvement was with enabling demuxing in the mythpvr addon settings, but this breaks seeking. It's a known issue and the author (Janbar) has removed that feature. Apparently it was a hack for older versions of Kodi that are no longer needed. Hopefully LE will update the myth plugin soon as there are other fixes/enhancements as well.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-
    MythTV Backend w/HDhomerun PRIME

  • I have the Beelink MiniMXIII II (ram 2GB, 16GB rom, 10/100 ethernet).

    I had no difficulty installing multiple versions of libreelec-s905.arm- with the tree gxl_p212_2g.dtb with everything working perfect.

    Already in this last version 8.0.1a (I have not tried the previous 8 ...) apparently the installation runs well but I do not step from the screen "Libreelec Just enough OS for KODI"!

    I tried several times and with several reboots and the result is always the same.

    Thank you

  • Have you tried the latest device tree? Index of /s905/device_trees/ last update was from 26th Feb

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • Edited once, last by frem ().

  • Kodi-agile is a "preview" for Kodi v18. I may start providing that kind of builds at some point in the future.

    Some point in the future might be when v18 will come along or earlier?

    Beelink MiniMXIII II 2GB, 32GB always running latest Libreelec from SD card. No issues so far(except for the ones already known or posted by me).

    Mecool m8s Pro+ which with widevine level 1, Android runs a hacked version of android TV.

  • kszaq, is there an easy way to enable the Suspend feature through the autostart.sh?

    I saw you disabled the Suspend recently and I understand the reason why you did that. But for me, the Suspend (via CEC) works perfectly and I need it since my box has a bright power light, it bothers me while I'm sleeping in the bedroom after turn off the TV but the box no longer goes to 'Sleep'.

    I know I can change the CEC settings to let the box to 'Shutdown' and it did. The problem is the startup takes longer time, and TV no longer turns on during the box startup.

    Seems I couldn't find a way to edit the configure file /usr/lib/systemd/sleep.conf.d/sleep.conf.


    Beelink Mini MX 2G/16G - 02b, LE on SD, SPDIF Passthrough
    MXQ S85 1G/8G, LE 7.90 beta2 Nand

  • Yeah, it worked for me as well, but the difference is it doesn't shut down at all no matter what I set so it would be useful for me to know how to bring it back.

  • Greetings

    First things first thanks to kszaq for sorting libreelec on this platform, you're a legend lol :D

    I have a Nexbox 2gb/16gb and had the previous version of Libreeelec 8.0.0d installed. When it came time to install 8.0.1a i have downloaded the appropriate device tree (renamed it to dtb.img) and also the update (.tar file). I then tried the toothpick method but am getting a message failed to sideload from E:/ and therefore cannot do an update at all. I have tried multiple SD cards but the same result. My Pi is running smoothly and easily done but this one is doing my nut in :@ :huh: .

    Any help would be appreciated :huh:


    Edited once, last by sa1time ().