[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Hello...


    I still have the issue with AC-3 passthrough.


    I have a Tanix TX5 Pro with S05X chip and i have interruptions when i play AC-3 content. Just as a note DTS is working fine.


    I have tried the following:


    Update to the latest version 7.95.beta6 version with or without temp sensor disabled with or without the default device tree file.


    I have disabled CEC, Refresh rate setting, all audio options (one by one) without any result.


    What is strange is that at first audio is alright for a few minutes and after a random period if time, but always less than 10 minutes, audio stream shows interruptions.


    In Jarvis when i used ta have a Mini MS II device everything worked fine in audio..


    Doi you have any idea why this is happening?


    Best regards.


  • And this also sets back the version?


    Backup / Restore does not include LE build version (you need TWRP or similar for that), only kodi configuration
    [hr]
    Akir4d Wifi seems to be working fine with Beelink MiniMX III II here

    Edited once, last by Poida ().

  • Sorry folks, NO PASSTHROUGH WITH LIVETV on Krypton. It's by design. The devs are aware that people are upset, they claim it will not be added going forward.


    I suggest you take up passthrough issues on the Kodi forums.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME


  • @jd17 I will take a look at PQ. Now that fractional frame rates are fixed this would be the next thing to look at. :)


    Sounds great, thank you so much! :)


    Maybe there even is a way to improve upon the Jarvis performance (all Bicubic/Bilinear and less banding), that would be bliss. :cool:
    [hr]


    As far as I followed the development, the kernel is the same for both versions. So presumably, somewhere in the code, the video decoder might be initialized slightly differently.


    I would still like to know if this is a S905X-specific issue or if S905 is affected as well....

    Mini M8S II 2G/16G (S905X)

    Edited once, last by jd17 ().


  • Sorry folks, NO PASSTHROUGH WITH LIVETV on Krypton. It's by design. The devs are aware that people are upset, they claim it will not be added going forward.


    My box is a strange beast then. Passthrough works with Beta6 (didn't work with Beta5) :)

    [hr]


    Has anyone noticed a considerably brighter picture with Beta6? I think black levels changed somehow.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)


  • Sorry folks, NO PASSTHROUGH WITH LIVETV on Krypton. It's by design. The devs are aware that people are upset, they claim it will not be added going forward.


    I suggest you take up passthrough issues on the Kodi forums.


    Hello...


    I do not use Live TV, this is hapening with regular movies and tv shows i have saved in my NAS...


    DTS is alright, AC3 is not...


    As i said, with AC3, playback starts alright and after a few minutes interruptions are starting to come.

  • My box is a strange beast then. Passthrough works with Beta6 (didn't work with Beta5) :)


    In that case I think I'll have to give beta6 a try then! Who fiddled with the kodi code I wonder?

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • Yes, go to LibreELEC Settings -> System -> Backup -> Create System and Kodi Backup. Then there'll be a zip file with date and time stamped in the 'Backup' folder. Copy the file to your PC or somewhere using Samba share (e.g. Window Explorer on a PC).


    Next do whatever you need to do to create your SD card, after the first boot is finished, copy the zip file back to the 'Backup' folder. Then go to LibreELEC Settings -> System again but click on 'Restore Backup' this time. It will show the name of the zip file you want to restore, click OK. After a while (depends on how big is your file), it will ask whether you want to reboot to restore the settings, click 'Yes'.


    I had problem with this feature. If you'd have the same just do the SSH method with few commands, that proved.


  • In that case I think I'll have to give beta6 a try then! Who fiddled with the kodi code I wonder?


    Our friend who is an DVB expert :)




    Changelog:

    • experimental: allow audio passthrough for live TV (thanks afl1 for the patch!)

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • I would still like to know if this is a S905X-specific issue or if S905 is affected as well....


    I only own S905 devices (see signature), so the chroma upscaling issue is present on both 905 and 905X.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • Can someone give me the answer?

  • As far as I know, the procedure you describe wipes everything in the internal storage so it'll be a new, clean install


    Read here: thread-3588.html

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)


  • I had problem with this feature. If you'd have the same just do the SSH method with few commands, that proved.


    I've tried a BACKUP -> RESTORE procedure and can confirm is not working (TAR file is copied to .restore directory, but nothing is restored after auto reboot).


    I've done SSH procedure (more or less), and now I don't have SSH, says connection refused.
    How can I get SSH back again?

    JP

    Lisbon, PORTUGAL

    Sunvell T95X 1G/8G (S905X) -> HDMI -> YAMAHA RX-V775 receiver -> EPSON EH-TW6600 projector

    (CoreELEC 8.90)

  • Fractional frame rates are only a memories . I can definitely stay with Krypton. Kszaq you are the only one in the world. Thanks.

    Edited once, last by Leonxy69 ().


  • I've done SSH procedure (more or less), and now I don't have SSH, says connection refused.
    How can I get SSH back again?


    Check the SSH status in the Libreelec settings>Services.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)