[8.0.2e] LibreELEC 8.0 for S905/S905X


  • SPo For Odroid-C2 you need to use Raybuntu's build: thread-4248.html
    [hr]
    OP updated with 7.90.beta4 with Kodi 17.0rc4.


    Addon updates and more detailed changelog coming soon.


    Are you not going to support the Odroid-C2 officially?


    Will the Odroid C2 builds be only supported by the community vs LibreELEC directly?

  • Hi guys,


    I am new to libreELEC :)


    I have a mxq pro 4k 1G 8GB


    Model is : MXQ-S905-D16 Ver:1.0 DATE: 151021


    The WIFI chip is Realtek 8189 ETV


    Android build is: P201-userdebug 5.1.1


    Which Device Tree should I use to have everything working?


    Is it gxbb_p201.dtb ?


    Thanks ! :D


  • Are you not going to support the Odroid-C2 officially?


    Will the Odroid C2 builds be only supported by the community vs LibreELEC directly?


    You realize you are posting this question in the *Community* forum for Amlogic Community builds?

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • Seems like boot issues due to temperature sensor became history. Can't wait to try the new beta4 build on my MX64 (S905 2G/16G) boxes, boot right away and read the processor temperature without problem. Cold and warm boot couple of times and never missed one! Not tried on my M18 (also S905 2G/16G) box yet as it's now occupied by other family members.


    It seems kszaq did something in the kernel to circumvent the u-boot bug. A temperature sensor disable build is no longer need. Thanks so much for your hard work.


  • Which Device Tree should I use to have everything working?


    From O.P. of this thread . . .


    For installation instructions refer to 7.0 builds, e.g. thread-3588.html


    Your answer is on O.P. of that thread ;)
    [hr]
    kszaq, There is no temp-sensor-disabled build of beta4. Does that mean we don't need it, or is it just not ready yet?

    Edited once, last by Poida ().


  • Cold and warm boot couple of times and never missed one!


    It seems kszaq did something in the kernel to circumvent the u-boot bug. A temperature sensor disable build is no longer need. Thanks so much for your hard work.


    I'd be checking more than a couple of times, it can take 50 boots or more to surface ;)

  • I'd be checking more than a couple of times, it can take 50 boots or more to surface ;)


    In the past, I only got 1 out of 5 boots was successful with my MX64 and M18, that's a huge improvement! Now I updated both with non- temperature sensor disabled build and they both work so far so good. Other than these two boxes, my other boxes, e.g. Mini MX didn't have boot issues in the past.


  • I'd be checking more than a couple of times, it can take 50 boots or more to surface


    We've all fallen for that reoccurring devil bug appearing. I mistakenly flashed non temp disabled on my MiniMx 2g/16g and didn't realise for 2 days until it froze on bootup. ;)
    This was on 7.0.3.012c build.
    I have updated to 7.0.3.012f and it wont freeze. #541

    Edited once, last by kostaman ().


  • Other than these two boxes, my other boxes, e.g. Mini MX didn't have boot issues in the past.


    That's what makes it so elusive. Of my two Mini MXs, one fails regularly within half a dozen boots, the other rarely (but still occasionally).
    Having said that, I am also monitoring the non-crippled build on these boxes as, so far they have booted fine each time (and seem to boot a little faster). You never know, maybe if some boot procedures have been re-arranged somewhere along the line, we might not have an issue now. Can only hope ;)

  • Tried to update latest, ie beta4 on a miniM8s s905.
    Seems like it's bricked.
    Did the update through smb in the update folder.
    I think it's bricked because even the android boot doesn't work, ie without sdcard. I never did an internal flash install to keep the android system in case of problem.


    I tried the reset button method, flat eeg...
    Nothing reacts.
    Usually, the screen reacts almost instantly at boot, with or without sdcard, reset button pressed or not.
    Here there's really no reaction at all.
    I'm out for some hours, will investigate later, probably 5 to 6 hours from now.

    Edited once, last by Tidav7578 ().

  • kszaq, it does begin to look like the boot freeze issue may have been a bug in the kodi code. This new build with kodi 17.0rc4, so far, has not caused a boot problem on the boxes that were frequently freezing with earlier kodi builds. :cool:

    Edited once, last by Poida ().

  • I've just tested RC4 on my Ferguson box WITH temp sensor ENABLED. So far 4 reboots successful in one row. I will report if I will face any problems later, for now I would say that temp sensor is not a problem anymore.


    But lets wait a little bit longer for feedback from the rest of the community.


    Thank you!

    Ferguson FBOX 4K (S905-B, 8GB NAND, 1GB RAM, 100MB NET, Android 5.1.1 with hacky Kodi 16.0 OOTB)

  • Hello,


    In my Beelink MiniMX III works well the NO temp version, I reboot 10 tines and all OK.


    I will try now in the M8S II.


    Thanks for your great help.


    Regards.


  • Do you get any issues with playback been to big for the screen i.e. Only showing the top left of the picture?

  • Do you get any issues with playback been to big for the screen i.e. Only showing the top left of the picture?


    No,


    I just playback LiveTV from Tvheadend client. Which content do you try?


    Regards.