[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Beta1: Bug rendering ass subtitles


    Rendering "heavy" ASS subtitles (which include movement and large fonts) while software decoding 720p hi10p h264 video crashes the wetek hub; picture is frozen, gui does not respond and ssh login is no longer possible. One of my files can be used to reproduce this and I will do further testing to see if this also happens with hardware decoding.


    I will try to create a smaller test files that trigger this bug and upload them.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Hi, all my test clips (mostly focused on audio codes) plays just fine (including enigma2 PVR plugin) , even better then on 12c...great, it's my default Kodi now! Thank you!


    Agnes_de_Venice_-_Christos_Anesti_Mar2013_24bit_96kHz.flac
    Astra.SES.Demo.HEVC.ts
    BigBuckBunny_2000hevc.mp4
    bird90.mkv
    birds_1080p_24fps_h265.mkv
    burosch1.mpg
    burosch2.mpg
    ChID-BLITS-EBU.mp4
    dolby_amaze_lossless-DWEU.m2ts
    dolby_digital_plus_channel_check_lossless-DWEU.mkv
    dolby_truehd_channel_check_lossless-DWEU.mkv
    Dredd – DTS Sound Check DTS-HD MA 7.1.m2ts
    dts_orchestra_short_lossless-DWEU.mkv
    DTSX_Demo_2016.m2ts
    H.265 HVEC Test 2.mkv
    Jellyfish-140-Mbps-2160p-hevc-10bit.mkv
    Jellyfish-90-Mbps-1080p-hevc-10bit.mkv
    Philips_UHD_supershopdemo_1.mp4
    POCAWE_Sample.mkv
    Safari_ Dolby_Digital_Plus.m2ts
    Samsung Demo Oceanic Life [1080p a 40 Mbps].mkv
    Samsung_UHD_Dubai.ts
    sr002-01-24192.wav
    Tears_400_x265.mp4
    tos-4096x1720-tiles.mkv


    My setup is Beelink MiniMX 1/8GB + Samsung 4K TV and Yamaha 5.1 receiver, using audio passhrough over optical Toslink cable.

    Edited once, last by stillka ().


  • . . .video crashes the wetek hub. . .


    Please excuse my ignorance, but I thought Wetek had it's own forum? Oh, maybe that's for Android FW.

    Edited once, last by Poida ().

  • Poida: I run kszaq's libreelec on several boxes (see signature), but currently run the beta only on the wetek hub. If possible, I will provide a file later so we can check if the bug also happens on different hardware :)

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • I m currently using libreelec [Beta] LlibreELEC 8.0 builds I have strange error in my nexbox plz help...strange issue: skipping backwards/reverse "behind" 0:00 makes the video stop/freeze..


  • I m currently using libreelec [Beta] LlibreELEC 8.0 builds I have strange error in my nexbox plz help...strange issue: skipping backwards/reverse "behind" 0:00 makes the video stop/freeze..


    I reported that too, will post a log tomorrow hopefully.


    I found that it's only on certain files though, most don't have that problem. it's also independent of hardware acceleration, who would've guessed.

    Nexbox A95x (S905X) running kszaq's LE 8.1.10 build

  • I reported that too, will post a log tomorrow hopefully.


    I found that it's only on certain files though, most don't have that problem. it's also independent of hardware acceleration, who would've guessed.


    Yes u r right whenever I am playing 720p spark(encoder) movies file which is around 5.5gb 720p rip then nexbox becomes freeze in delay...

  • Dear community,


    I am new I am not sure if this is the right section if I can post here but I am left with few Q/A and hope few of you can help me.
    I am from the Netherlands and using this box based on Andriod basicly I only use Kodi on it.
    Now I heard about LibreElec on my job today and was looking for some more assistance if you guys can help me install it.
    I am a beta tester trough my Google Account and using Kodi 17 and I would like to prefer using that aswell with LibreElec


    So I bought my box at: 9200000058373841



    And I hope that someone can help me now I did read some posts I need to buy a SD-card format it and burn the img.gz with a program such as SD-card formatter or Rufus.


    But I am left with this question if I go to device tree it's kind of unclear which version I need to pick: device_trees


    I my self did think
    gxbb_p200_1G_1Gbit.dtb
    gxbb_p200_1G_1Gbit_RealtekWiFi.dtb


    But I am not sure what is the difference between these two and to move on I got one more question Once I burn the Image with Rufus or the other program how I need to burn the .dtb file or can I burn multiple files?


    Right now my Box is just running on Android 5.1.1 and kodi 17


    I hope someone can answer my questions because this program looks great and Android it self it's eating ram by the way my box is connected with a Cat 5e Cable I prefer using Cable but I would love to have always WiFi as alternative.


    Thanks in advance,


    Mir.

  • The .dtb file is copied to the sd card after you wrote the image with rufus and needs to be renamed to dtb.img (see first post). You can try a dtb, and if it does not work, remove the card from your box, put it back into your pc and copy another dtb file instead.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

    Edited once, last by mmpp ().


  • The .dtb file is copied to the sd card after you wrote the image with rufus and needs to be renamed to dtb.img (see first post). You can try a dtb, and if it does not work, remove the card from your box, put it back into your pc and copy another dtb file instead.


    So basicly if I Burn the iso it extracts on the SD card I will get a standard dtb.img but I need to rename or to replace ((because you can click on the file on device tree and it iwll start downloading )) it with the one which fits for my Box


    Aswell can you please tell me which .dtb I need for my box.


    I copied this from the webshop where I bought it:


    Specificaties:
    - Model: MXQ Pro
    - OS: Android Lollipop, Android 5.1
    - CPU: Amlogic S905 Quad-core 64-bit ARM Cortex-A53
    - GPU: Penta-core ARM Mali-450
    - Werkgeheugen: 1GB DDR3
    - Opslag: 8GB eMMC Flash
    - Verbinding: LAN: Gigabit LAN 10/100/1000Mbit
    - Wi-Fi: 802.11 b/g/n 2.4GHz met ingebouwde antenne
    - Bluetooth: Nee
    - IR: Ja, voor infrarood afstandsbediening
    - Afspelen: Video: Full HD 1080p / H.265 HEVC / ondersteunt 4K
    - Video Codecs: RM , PMP , AVC , FLV , VOB , MPG , DAT , MPEG , H.264 , MPEG1 , MPEG2 , RMVB , MPEG4 , WMV , AVI , DIVX , MKV , MOV , HDMOV , MP4 , M4V
    - Audio: Digitale audiopoort SPDIF aanwezig
    - Audio Codecs: MP3 , WMA , APE , FLAC , OGG , AC3 , DTS , AAC
    - Aansluitingen:
    - HDMI: 1x HDMI 2.0
    - USB: 4x USB 2.0
    - SD: 1x Micro SD aansluiting
    - Audio: 1x SPDIF audio aansluiting
    - AV: 1x AV poort
    - Ethernet/LAN: 1x Gigabit Ethernet 10/100/1000 Mbit
    - Voeding: 1x 5V/2A


    Kind Regards,


    Mir


  • So basicly if I Burn the iso it extracts on the SD card I will get a standard dtb.img but I need to rename or to replace ((because you can click on the file on device tree and it iwll start downloading )) it with the one which fits for my Box


    Aswell can you please tell me which .dtb I need for my box.


    You better read the #1
    These MXQ Pro's are having lots of issues.
    You must use Temp-Sensor-Disabled versions of LE as S905 Chips are causing Freezes on Bootup

  • You better read the #1
    These MXQ Pro's are having lots of issues.
    You must use Temp-Sensor-Disabled versions of LE as S905 Chips are causing Freezes on Bootup



    so If I flash with the Android box with this program I can just import the Image of Libreelec and it will work?


    Btw and it's still unclear for me which of the devices from devicelist are my device can you help me please.

    Edited once, last by Mir64za ().


  • Btw and it's still unclear for me which of the devices from devicelist are my device can you help me please.


    You are better off using the #1  
    Build as this here is LE Beta.
    You need to read the posts from link.
    Start there as you have to overcome some hurdles related to your box.
    SD Card LE before you even think about internal install.

  • [Moved from 7.0.3.012c build for S905/S905X]


    kszaq
    I am now testing the 7.90beta1 build. I seem to have lost some functionality with my remote (a few keys which have been working fine, are no longer acknowledged by kodi). Any ideas why?


    The 7.90b1 build is not dealing with key presses the same as the previous builds.
    In the new build, LIRC seems to be detecting the key presses but kodi no longer actions the event whereas, in the earlier builds, there is no LIRC entries in the logs


    Three logs attached 7.0.3.012, Krypton dev and 7.90b1


    In each build, using the same remote.conf in /storage/.config and gen.xml in /storage/.kodi/userdata/keymaps, I was repeatedly pressing the 'info' key on my remote, which is mapped to the i key /key ID 61513


    forum.libreelec.tv/core/attachment/859/
    forum.libreelec.tv/core/attachment/860/
    forum.libreelec.tv/core/attachment/861/

    Edited once, last by Poida ().

  • Poida, you're great. While I was preparing the log for 'HOME' and 'INFO' key, you already submitted log for different Kodi versions, using the same remote.conf. Yeah, not only 'HOME' key, but also 'INFO' key is not working with the latest Krypton beta build. It was working before and is working on Jarvis build 7.0.3.012.


    'HOME' and 'INFO' key using Android Yatse App are working with the Krypton beta build so it should be issue of remote control button mapping.


  • 'HOME' and 'INFO' key using Android Yatse App are working with the Krypton beta build


    The Home button is detected with builds 7.0.x.x and LibreELEC-S905.arm-8.0-7.90.beta1 but is actioned as previous menu, but with LibreELEC-S905.arm-8.0-devel-20161223194610-r25062-g308adcf build, although the log shows OnKey: home (0xf088) pressed, action is FirstPage nothing happens :huh:


    The Yatse App does not send IR codes, so I'm not sure that it's relevant that the App can send these commands.


    EDIT: 'STOP' button not working either

    Edited once, last by Poida ().

  • The fix for remote buttons is ready for the next build. Meanwhile you can temporarily fix it by running systemctl stop eventlircd.


  • So basicly if I Burn the iso it extracts on the SD card I will get a standard dtb.img but I need to rename or to replace ((because you can click on the file on device tree and it iwll start downloading )) it with the one which fits for my Box


    Yes, simply delete the dtb.img from the sdcard, move another one there and rename it to dtb.img

    Quote


    Aswell can you please tell me which .dtb I need for my box.


    The two dtb files you mentioned in your first post seem to be right. Depending on your WLAN chipset, but this is not mentioned in you seller's specs. Try one, and if WLAN does not work, try the other.


    Do not worry too much. As long as you use the sdcard installation, you cannot brake your box. Just go ahead and try :)

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test