[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Successfully instaled 7.90 alpha on X96 2GB 16GB but with device tree gxl-p212-1g, version gxl-p212-2g does't pass. Result is that box display only 1GB RAM.

    This are SS from android with CPU-Z.
    Which device tree is for this box?
    Thanks


  • I will test later, but gxl_p212_2g.dtb should work just fine.


  • kszaq I found that if i apply [C++] AML-Clock timing adjust - Pastebin.com (a backport of AML clock timing adjustments by peak3d · Pull Request #10887 · xbmc/xbmc · GitHub) and remove le-017-add-aspect-ratio-detection-for-amcodec-h264.patch live tv works smoother


    Thanks to @peak3d I discovered what I was doing wrong during my testing. I can now confirm that with his patches almost all videos are very smooth. There is only one exception: very high bitrate videos but this is not a show stopper. I will post some builds in the next few days.
    [hr]


    Not working..
    Any ideas?


    Try creating SD card image without replacing a device tree. Your box's bootloader should pick the S905X tree itself. Then you'll see how much RAM it "chooses".

    Edited once, last by kszaq ().

  • [/quote]


    Try creating SD card image without replacing a device tree. Your box's bootloader should pick the S905X tree itself. Then you'll see how much RAM it "chooses".
    [/quote]


    Already try, box have 1gb without device tree..


  • Already try, box have 1gb without device tree..


    This means that the bootloader chooses 1GB because:

    • you have a wrong firmware (bootloader) or
    • your box fakes RAM amount in Android.
  • This means that the bootloader chooses 1GB because:

    • you have a wrong firmware (bootloader) or
    • your box fakes RAM amount in Android.


    I was check with CPU-Z, any other method to check?

    Edited once, last by pizzonia ().

  • kszaq Just wanted to say thank you :) Installed your build from 24th on my Hub and I have to say its is just great :)


    Thanks a lot for all your work and all the effort you put into this :)

  • Hi all,
    I'm having the problem that in Kodi the video resolution is fixed to 720p and in the settings it's greyed out (I can't change the resolution to anything else). Between my box and the AVR is a HDMI splitter, so I'm thinking that maybe Kodi is unable to get EDID information or something. I want to force the output to 1080p. I tried following methods and all failed. Any tips to send me in the right direction?


    1) U-boot is already set to 1080p. So I'm thinking that can't be the problem.

    Code
    1. kodi2:~ # fw_printenv hdmimode
    2. hdmimode=1080p60hz
    3. kodi2:~ # fw_printenv outputmode
    4. outputmode=1080p60hz


    2) I found this Github commit EDID overriding for aarch64 by egandt · Pull Request #841 · LibreELEC/LibreELEC.tv · GitHub and so I checked for /storage/.config/disp_cap and /sys/class/amhdmitx/amhdmitx0/disp_cap. The latter one existed and interestingly it was set to 720p60. So I copied that file to /storage/.config/disp_cap and /sys/class/amhdmitx/amhdmitx0/disp_cap and changed the 720p to 1080p. Rebooted the box... Kodi still set to 720p :-(. Maybe this doesn't work because I'm using the 32-bit build instead of aarch64 (just guessing...).


    3) I noticed many people force EDID with this tutorial: Configuring a Custom xorg.conf - OpenELEC . But many files referred to in those tutorials seem to be missing on my box.


    4) This forces the output to 1080p, but Kodi does not scale accordingly. So I have Kodi in the upper left of the screen at 720p, and then the 1080p image is generated by filling the rest of the pixels with black.

    Code
    1. echo 1080p60hz > /sys/class/display/mode



    Specs:
    Mini M8S II (s905x)
    using the 32bit build on USB drive.


  • Hi all,
    I'm having the problem that in Kodi the video resolution is fixed to 720p and in the settings it's greyed out (I can't change the resolution to anything else). Between my box and the AVR is a HDMI splitter, so I'm thinking that maybe Kodi is unable to get EDID information or something. I want to force the output to 1080p. I tried following methods and all failed. Any tips to send me in the right direction?


    LibreELEC


    kszaq it is possible to fix BD3D in libreelec 7.90 ???
    In jarvis was no problem with 3d.


    At this point I have no plans to work on 3D support for several reasons: there are more important issues to solve, it needs to be implemented in Kodi - no 3D support for Amlogic, in Jarvis I used some patches from SPMC that would need to be ported - and I don't have 3D material nor 3D TV. Maybe at some point in the future.

  • Im having a whole slew of problems with this latest build, i can only get a minimx to boot on screen successfully maybe 30% of the time, LE is running because i can see it via SSH but i get no video output on my display, when i do get output, most bluray video is totally unwatchable with a slight judder, all UHD content suffers immensely and is unwatchable with passthrough audio out of sync and extreme choppiness. Do logs help you out?


    im coming from Kerbers 16.1 builds which dont seem to suffer from any issues other than being outdated

  • i know this might be a pain but if you turn off hardware acceleration when watching twitch it's fine then just turn it back on when you want to watch tv, this is what i've been doing until it's sorted out. Also it's not just twitch the NBC sports extra addon has the same issue


    Excellent thanks!


    It's a bit annoying but it's better than not being able to use it.

  • kszaq, thank you for your great work.


    I was able to install this build on new Plater MX86 (Amlogic S905, 2GB RAM, 8GM FLASH, 1000MB LAN, 1 USB OTG).


    What works:


    - normal audio 7.1 passthrough thru hdmi, tested: dolby, dolby pro, dolby truehd, dts, dts-ma (awesome)
    - normal audio 5.1 passthrough thru spdif: dolby, dts
    - [email protected] :-)
    - hardware decoder works well, [email protected] playback eats 15% of ram and around 50% (from 400%) of cpu
    - network
    - usb
    - wifi (at least it could see available networks)
    - spdif
    - hdmi 2.0 and hdmi 1.4 output
    - ssh
    - very smooth playback


    What doesn't work:


    - boots successfully only with 10-30% chance
    - power off button and restart doesn't work well (both on box and on remote) (looks like it goes to sleep, but there is no way to wake it)
    - infrared remote doesn't work (no /dev/lirc0)
    - some keys on remote (Plater) doesn't work
    - it could be perfect to have /opt blank directory on squash image to use entware/optware for installation of extra soft (should be easy to fix)
    - available resolutions for kodi detected only once on first boot, so if reboot with 4k tv attached - you will see 4k, if reboot with 1080p tv, then 4k will be not available even if you will switch on the fly connected tv
    - resolution auto detect (may be a kodi issue)
    - refresh rate auto set - it is buggy, for 60 fps 4k rip it could switch to 24hz, but anyway - playback is very smooth even with disabled refresh rate auto set


    I would say that main blockers for me are low success boot chance, then lirc, then /opt


    dmesg full log here: [ [email protected]] Initializing cgroup subsys cpu [ [email protected]] Linux version - Pastebin.com


    there is stack trace in video driver - search in log for "cut here"

    Edited once, last by art.sormy ().


  • Note that this builds have know issues, see there and there


    The boot issue is under investigation.
    For /dev/lirc0 check this if your original remote not works, post the original remote.conf file from android to check what happens.


    About the /opt if you need extra software not available on existing repositories you must compile a new package or try the docker containers.

    Edited once, last by CGarces ().