[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Kszaq I replied a week ro so ago about the auto 3D function which I can say now that it is working with V 8.0.2e running on my Beelink S905x box, and indeed when running 3D content it now auto switches my 5 year old Samsung Series 7 into the correct 3D mode (usually SBS or sometiems TB) and theg KODI bottom of screen controls and subtitels all display correctly in 3D (very nice).


    However, I now install to my Beelink, together with the correct S905X new device tree, your new test version 8.2.-8.1.0 and can advise that the 3D feature no longer works and usually crashes my box when I llaunch 3D content leaving me in a black screen and requiring a reboot. Although the remote powere button does still switch the box off okay so it cannot be totally crashed btu no display and no sound. I did at one point get the 3D picture up (same content so dont know why it worked this once) but when I closed the video the same problem occurred with a blank black screen and had to shut the box down and reboot. With the reboot needed I cannot see how I can get a log or even if it would be relevant anyway with this issue.


    So thought you would like the feedback to advise you that the auto 3D seems flawed in the new 8.2 test build. Have now reverted back to 8.0.2e which is a superb build albeit only the MM kernel. So as always Kszaq, mega thanks for all your great work. Will be more coffee coming your way, just as soon as I get some new stock in :-)

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

  • I have a MXQ Pro 4K box with a S905X (p212, 1GB, 1.5Ghz & Android 6.0.1). I'm running libreelec 8.1.1 off an SD card with the gxl_p212_1g.dtb device tree file in the root renamed to dtb.img. Everythings works, except for the wifi. Wifi is not detected, so I can only run through a wired connection.

    I tried other device tree files (gxbb_p200_1G_mxq_pro_4k.dtb for example from the S905 folder), but without success.


    Same with the 8.1.1 and 8.0.2e versions btw


    Any idea's?

    MXQ Pro 4K - S905x, 1GB, P212, 1.5GHz

    MXQ - S805 - 1GB, 1.5Ghz

  • The addon is starting before your network connection is ready. Had the same problen. Somewhere is an option like "wait for starting the addon until network is ready".


    Or disable the addon, reboot, wait until network is ready and start the addon manually

    Wait for network option resolved my problem with vu+/enigma2 addon. Thanks

  • kszaq


    Thanks for the awesome work and constant updates. Could please explain the difference between the p200 and p201 device trees you provide?


    Installed 8.0.1j with device tree p201 and it works fine. However my device is a MXQ PRO 4K S905 with 1GB RAM and 100MBit ethernet port, so was wondering if i need to use the p200_1G_100M or ..._mxq pro 4k? And if I do end up getting it wrong, will the code you posted on the 8.1.1 thread with


    Code
    dd if=/flash/dtb.img of=/dev/dtb bs=256k

    work for this build too? Will i have to perform a clea install and lose my data and configurations?


    Edited

  • Could please explain the difference between the p200 and p201 device trees you provide?

    The difference is purely cosmetic and you can use either. If you want to change a device tree, there is no need for a clean install or wiping data.

  • The difference is purely cosmetic and you can use either. If you want to change a device tree, there is no need for a clean install or wiping data.

    thanks for the quick reply.


    I tried the p200_mxq_pro_4k dtb, didn't boot. But the code you provided in the 8.1.1 thread, worked like a charm. Managed to change the dtb to p201 with LIRC support. It boots fine now and haven't noticed any issues with the hardware.


    Just trying to configure the IR remote but while following the guides online (mostly an OE guide), I get a warning that it "cannot open /etc/lirc/lirc_options.conf" and after going through the intial process, it either freezes at the end of second line of the random-recording of the remote's signal or outputs a "Segmentation fault (core dumped)" message. I don't know if the OE guide is outdated or different, but is there a guide for LE or your build? I would provide a debuglog but not sure how to.

  • Just trying to configure the IR remote but while following the guides online (mostly an OE guide), I get a warning that it "cannot open /etc/lirc/lirc_options.conf" and after going through the intial process, it either freezes at the end of second line of the random-recording of the remote's signal or outputs a "Segmentation fault (core dumped)" message. I don't know if the OE guide is outdated or different, but is there a guide for LE or your build? I would provide a debuglog but not sure how to.

    Unfortunately in 8.0.2e LIRC is broken due to broken drivers in media_build package. It should work in 8.1.x builds but I have to amend device trees for it. ;)

  • Unfortunately in 8.0.2e LIRC is broken due to broken drivers in media_build package. It should work in 8.1.x builds but I have to amend device trees for it. ;)

    Alright.


    Will be waiting... patiently :) . Thanks once again for the support, work and updates.

  • I'm not the author, I only included it. :D


    Please note that it stopped working in 8.1.0 build, should you want to update... I will try to fix this.

  • I'm not the author, I only included it. :D


    Please note that it stopped working in 8.1.0 build, should you want to update... I will try to fix this.

    That would be very good. 3D Autoswitch is important :-)

  • Hi there,


    i have a Beelink M18 (S905 with 2GB) and used the DTB gxbb_p200_2GB_1Gbit.dtb, but I cant see my Ethernet connection.

    Libreelec runs OK, WIFI is recognized.


    In dmesg it says: no eth0 found.

    I thought that only wifi chips are complicated. Did I something wrong?

    Edited once, last by tavoc ().

  • gxbb_p200_2G_1Gbit_OTG_Port.dtb


    Give this a go. I have a similar box with OTG and i vaguely recall that is the device tree for m18 as well.