9.2.0 RPi4 Wi-Fi 5GHz Drops Connection

  • Clean install, no addons. RPi4 4Gb, original power supply, connects to a network, works for 1min, then connection drops and RP4 is not able to reconnect anymore.


    The log


    Router (ZyXEL Keenetic Ultra II, no 2.4Ghz enabled, only 5GHz) log:


    Code
    Фев 12 14:03:15 wmond
    WifiMaster1/AccessPoint0: (MT76x2) STA(dc:a6:32:30:19:0a) had associated successfully.
    Фев 12 14:03:16 wmond
    WifiMaster1/AccessPoint0: (MT76x2) STA(dc:a6:32:30:19:0a) set key done in WPA2/WPA2PSK.
    Фев 12 14:04:16 wmond
    WifiMaster1/AccessPoint0: (MT76x2) STA(dc:a6:32:30:19:0a) had disassociated by STA (reason: STA is leaving or has left BSS)
  • Are you using the RPi internal wifi or an external wifi?


    If internal, can you try another wifi - say a USB wifi adapter.


    Also can you try ethernet and see if you still get issues.


    As a test can you try Raspbian and see if that is stable.

  • He came from this thread where he said it's OK on Raspbian Buster. I think it's about internal WiFi, because he didn't mentioned an adapter.

    Flexin' vinyl, jammin' break beats. 8)

  • Code
    echo "options cfg80211 ieee80211_regdom=DE” > /storage/.config/modprobe.d/cfg80211.conf

    ^ swap "DE" for UK, FR, RU, etc. as required, and see if that makes a difference.

  • After changing country code to US or DE, RPi still drops connecting every one minute, but then it's able to reconnect and obtain an IP, so there is some progress here, thanks :)


    It's all about onboard WiFi. I also have a Tenda U12 dongle (rtl8812au chipset, 2604:0012) which I use with my PRi2 running Raspbian. I would even prefer to use it instead of the onboard wlan, but unfortunately I did not succeed in making it work with LibreElec, despite it detects the adapter:


    Code
    [ 239.208563] usb 1-1.3: new high-speed USB device number 5 using xhci_hcd
    [ 239.299361] usb 1-1.3: New USB device found, idVendor=2604, idProduct=0012, bcdDevice= 0.00
    [ 239.299383] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 239.299399] usb 1-1.3: Product: 802.11n NIC
    [ 239.299414] usb 1-1.3: Manufacturer: Realtek
    [ 239.299429] usb 1-1.3: SerialNumber: 123456


    ...and no wlan1, only onboard wlan0


    Tried


    Code
    LibreELEC:/sys/bus/usb/drivers/rtsx_usb # echo 2604 0012 >new_id


    with no results

    Edited 2 times, last by Zewkin ().

  • Try This


    first install -> Libreelec Addons/Program Addons/Network Tools


    reboot


    logon via ssh and test -> iwconfig


    wlan0 shows up like -> Power Management:on


    then -> nano /storage/.config/autostart.sh


    add -> iw wlan0 set power_save off


    -> save and exit

    -> reboot


    logon via ssh and test -> iwconfig


    wlan0 shows up like -> Power Management:off

  • Is your router configured for US or DE, or another country? .. the country setting should be matched to the router.

  • My router's country code was UA, and RPi WiFi completely died after I set UA as PRi country code. It saw no networks, nothing.

    Then I got wired and set PL as country code for both router and RPi, and it finally worked! 11n, 40MHz only, 1x1, but it works! Thanks a lot!


    Anyway the fact LibreELEC does not support WiFi in Ukraine is weird :)