Can't play DVD with no region code

  • Hello :)

    I can't play some DVD-VIDEO : when i insert the disk, go to "disk" main menu and "play" : sometimes i can see the DVD menu then i can't start the title nothing happen. Sometimes LibreElec crash and reboot as soon i use the "play" action.

    All the no working DVD are "Live's music" DVD and i think it is something related to dvd region code because i tried and compared with movies disks :

    All my live's music DVD are "PAL all region code zone" and can't be played.

    My tested DVD movies working well are all with region zone code "2" (europe).

    I tried to change Settings\Player\DVD : force the use of zone "2" and/or "try to skip intro before menu : no changes.

    I checked the region code of my drive on Windows (live windows) : it is region "2" with 4 changes remaining.

    I'm on a PC with CPU AMD E1-1200 with integrated GPU AMD Radeon HD 7310.

    LibreElec version is 9.2.0

    Debug logs when trying to play a live music DVD with nothing happening after pressing "play" on the DVD menu :

    dmesg :


  • Try disabling VAAPI MPEG2 acceleration, you may have to increase the settings level to "Expert" to be able to do this.

  • La

    I'm on LibreElec 9.2.0. I can't play my DVDs, like operas, concerts. On the advice of a friend, I disabled the VAAPI/mpeg2 acceleration but nothing helps. My other classic DVD movies are very successful, so I don't use the internal DVD menu.

    When I insert a DVD, it loads into the menu and if I choose one of the menu items, there is a blockage. Nothing's going on.

    It's the same with my classic DVDs, they load well in the menu, and then there's blocking

    Please help me

  • I have a related problem:

    When play a DVD into a usb drive, Kodi resets itself (I use LIBREELEC) in logami I came across "CSS ERROR".

    I did some experiments and if the drive is connected via the SATA connector on the motherboard, there is no problem but if I insert it into the usb adapter, the problem is.

    I tested on two usb adapters.

    I tested on three different drives.

    I tested on two computers.

    Region settings did not help.

    I have a DVD with regions 0 and 2 (I live in Europe).

    Ideas, suggestions?

    I set up my own thread but there was no response and now it has disappeared from the list.

    (Translated by Google)

    I forgot to add that I'm using the x86 version