Unstable Wifi

  • I'm using an old PC with LibreElec. I admittedly haven't turned it on in a while but I did the other day and saw:

    "[Failed] Failed to start Wait on network."

    When the system finished booting up I was not connected to wifi. I tried to connect manually but it seems to connect and disconnect intermittently. I increased the wait on network to 30 seconds but that didn't help. I updated to the latest beta version but that didn't help. I'm guessing there is a driver issue with my ac wifi dongle but the only error I see in dmesg is related to bluetooth. How do I troubleshoot this? Thanks!

  • Not so old that the system wasn't working perfectly fine a few months ago but I've attached output on my hardware. Thanks for your help!

    Files

    • hardware.txt

      (45.51 kB, downloaded 55 times, last: )
  • Do you have auto update enabled? If so, it looks like your unit has automatically upgraded to the latest release. Your Edimax wifi is using a realtek chip which *might* be no longer supported.


    Because of the driver issues with realtek chips support has been limited and the preferred option is to use a Wifi bridge to ethernet.


    If you can remember the previous release, it might be possible to downgrade (Make a backup first)


    More Info

  • An Intel(R) Core(TM)2 Duo CPU E7300 @ 2.66GHz...


    My 11-yr old laptop has such a chipset. Kodi still runs via Ubuntu 16.04 on it, but it is on its last legs.

  • I've just tried an old Edimax wifi adapter and it works fine on RPi4


    lsusb

    Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter


    So if you get something similar, then it is probably something else.


    Yes: A wifi bridge converts wifi to ethernet

  • I looked back at my original attachment where I had run lsusb -v and found:

    Bus 001 Device 003: ID 7392:a811 Edimax Technology Co., Ltd

    Interestingly the verbose output also shows

    iManufacturer 1 Realtek

    iProduct 2 802.11n WLAN Adapter

    though this is an ac adaptor.

    Do you think its using the wrong driver and this is causing the problem?

  • Look at the output of ifconfig to see whether you have multiple WLAN adapters active. If you have a wlan0 and wlan1 on the output, you can deactivate one of them with ifconfig wlan<your_number> down.


    There are different ways to deactivate an unneeded WLAN adapter permanently. Read here.

    Flexin' vinyl, jammin' break beats. 8)

  • Only 1 wifi (wlan0). I bet its a driver issue.


    "Your Edimax wifi is using a realtek chip which *might* be no longer supported."


    How do i confirm if my wifi adapter is supported and anyway to add support if it is not?

  • How do i confirm if my wifi adapter is supported and anyway to add support if it is not?

    A complete compatibility list does not exist (you have to watch LE's Linux kernel for that).

    When the product descriptions says Linux compatible, and it's not from Realtek, then give it a try.

    Here is an incomplete list for OpenELEC on RPi, just to give a small overview: RPi USB Wi-Fi Adapters

    Hint: An adapter with an antenna works better.

    Flexin' vinyl, jammin' break beats. 8)

  • Hi, i have same problem on Libreelec for PI3 and PI4, on few boot the Wifi connection could work automatically or not. I use only the wifi on the PI. I thinks there is an unstable wifi connection protocol on libreelec. When i used OSMC on PI3 with a wifi configurated on wpa_supplicant, the wifi was worked everytime with not unstable behavior like that. But there is no wpa_supplicant possibility on librelec or i didn't find how.

  • It's hard to find the cause of unstable WiFi connections. If you don't want to take care about ANY WiFi driver issues, then try this idea from Iridium.

    Flexin' vinyl, jammin' break beats. 8)