Fresh install raspberry pi 4 5ghz wifi not working

  • Hi everyone, I'm looking for a bit of help with a new install. I just upgraded to a RPi 4 4Gb and for some odd reason the 5Ghz wifi is not working in Libreelec. I booted raspbian on the pi and I was able to see and connect to my 5Ghz network through raspbian, so I know that the hardware is not defective. Any help that you can offer would be great. Please let me know what info would be useful for troubleshooting.


    TYIA

  • When you say "the 5Ghz wifi is not working" can you see the network SSID but cannot connect or you cannot see the SSID?


    I've just tested on a new RPi4 with LE 9.1.501 and it can see my 5Ghz N/W and connect without issue.


    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Note: Full logs only. No partial or modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.
  • How do you do this when it won't connect to wifi? I have the same problem only it'll sometimes connect to 2.4ghz

  • I have the same issue. It doesn't see 5GHz SSID at all. It does see 2.4 GHz and connects to it. But even with 2.4GHz connection is not stable. It disconnects often with 2.4GHz SSID disappearing for some time.

    Wi-Fi router is ASUS RT-AC88U. Control channels set to auto for both bands.

    Everything else at home works with both bands perfectly fine.

    LibreElec 9.1.501

    Edited once, last by Serg675 ().

  • I'm having similar problems with DHCP failure over 5GHz wifi. Wired is fine and 2.4GHz wifi is fine.


    kodi log http://ix.io/20c1

    dmesg log http://ix.io/20c2

    I know that 5GHz is preferred if you live in a high density WLAN area, where most users take a 2.4GHz channel.

    I don't see any WiFi related errors at your logs. My conclusion is that the 5GHz signal of the RPi is too weak to establish a stable connection.


    The higher the frequency, the higher the need of energy to generate that frequency.

    You could try a stronger PSU, which maybe results in a stronger 5GHz signal. I'm sure it's not a software issue.

    Flexin' vinyl, jammin' break beats.:thumbup:

  • As @Da Flex mentioned. I don't think it's a S/W issue as I have had no issues connecting 2.4 nor 5GHz (Mind you my RPi is ~2M from my router)


    As an addition. Try moving your RPi closer to the router. Also, don't use any cases - especially aluminium heatsink cases that cover the whole RPi as this will definitely interfere with the reception of the internal wifi chip.


    For the *best* reception, it's better to use an external antenna rather than the internal one - actually it's better not to use the internal wifi at all with LE unless you have a really good reception.

  • I'm not sure how far the updates are on our sources, but there is a recent (=yesterday) Ubuntu Server/Desktop image for the RPi4 which claims to have:

    - 5 GHz WiFi channel support

    - Working Bluetooth and WiFi


    I don't have a 5 GHz Router so I cannot test it.

    Github page here.

  • I use network cable connection, but I tested the 5G wifi and it works.

    If you use Band steering and you get both 2.4G / 5G networks with the same name, you have to make both connections and then Pi4 chooses 5G.

    Raspberry Pi4 2GB LibreELEC

  • I'm having the same problem. The strange part is that I can access my 5ghz fine when I load Raspbian instead of Libreelec. So, I do believe this is a software issue and not a hardware issue. I have different SSIDs for my 5ghz and 2.4 ghz networks and I am only able to see my 2.4 ghz SSID. Also, I can't see any of my neighbor's 5 ghz networks either (there is one other that I usually see on my phone).


    FYI: I found this on the RPi forum. Evidently there's a RPi4 version available for Raspbian. I have it installed and am getting great performance with my RPi4 2gig. So far, able to connect with 5ghz no problem. So, I maintain...it's a software problem.

    Edited once, last by ryan780 ().

  • The strange part is that I can access my 5ghz fine when I load Raspbian instead of Libreelec.

    Good point. Provide a log file.


    It could be an energy management problem, which differs LE and Raspbian.

    See my post above to understand the relation between energy and 5GHz.

    When I'm right, then the log file will look fine, because it will not show shortage of energy for 5GHz.

    Flexin' vinyl, jammin' break beats.:thumbup:

  • It could be an energy management problem, which differs LE and Raspbian.

    See my post above to understand the relation between energy and 5GHz.

    When I'm right, then the log file will look fine, because it will not show shortage of energy for 5GHz.

    I'm sorry, I don't understand. How would I fix this? I didn't enable any energy saving settings in LibreElec. And if others did not either, then why would I not be able to connect to 5gHz? And how does the absence of something in a log prove that this is the problem? As i said, I cannot pull a log file since I cannot keep the SSH server running either. Every time I back out of that window, it turns itself back off.

  • For kicks .. force the wireless regulatory domain to the same as the router as "5GHz" is only one of 20+ radio properties, e.g.

    Code
    1. echo "options cfg80211 ieee80211_regdom=US” > /storage/.config/modprobe.d/cfg80211.conf

    and reboot to effect the change

  • I got the 18.5 installed via Raspbian, and I'm able to access my 5ghz there. So I'm all set at this point.


    But just FYI...how can I do that if i can't SSH into my RPi? I can't get command line from within LibreElec, as far as I'm aware. Maybe when I have some free time I'll try re-flashing my SD and trying LibreElec again. something might have gotten screwed up when I first booted.

  • You can enable SSH and login, same as any other distro, although most of the filesystem is read-only once you're in.

  • Video playback on Raspbian is not as smooth as LibreELEC. So I would like to get 5GHz working on LE. But like the previous posters, 5GHz works in Raspbian but not LE. I agree that it must be a software problem. I hope the devs are looking into this.