"No signal" on TV with Raspberry Pi 4, after LibreELEC logo.

  • I just installed the OS several times, on my own and via NOOBS, always with the same result.


    After the LibreELEC logo, my TV says "NO SIGNAL", and nothing happens.

    Can't access SSH.


    What's going on? Is it a bad Kodi config?

    And yes, I have the HDMI cable plugged on HDMI 0 (near the USB-C port)


    [edit] I just manged to open an SSH on the machine, it seems to be working, but it isn't displaying anything. What do I do at this point and why did this happen?


    [edit 2] tvservice reposrts this:

    state 0xa [HDMI CUSTOM RGB full unknown AR], 1920x1200 @ 59.00Hz, progressive


    Clearly my display does not support 1920x1200, but why is this set at this resolution when I never configured it to be this way, and how can I change this via terminal or some other way? I need it to be 1080P


    [edit 3] I added hdmi_force=1 to the config.txt file, tvservice -m CEA says only mode 16 is enabled, and none for DMT, and still, the system boots and then goes into 1920x1200 @ 59Hz mode!! edid.dat follows:

    Edited 4 times, last by kdrone ().

  • I don't understand why Kodi was set to display its GUI at 1900x1200 but I also couldn't find how to change it on guisettings.xml

    What I did is


    - SSH into the Raspberry Pi

    - type tvservice -m CEA to find a supported mode

    - type tvservice --explicit "CEA 16 HDMI"


    This made Kodi display and then I had to go to system settings and change resolution to 1080P. Problem solved, but I just wasted a whole day trying to figure all of this out :/

  • Try to edit guisettings.xml


    ssh

    Code
    systemctl stop kodi.service

    edit line 321 in /storage/.kodi/userdata/guisettings.xml to [email protected]

    Code
    <setting id="videoscreen.screenmode">0192001080060.00000pstd</setting>

    ssh

    Code
    systemctl start kodi.service

    Not tested but should work....take a guisettings.xml backup just in case.

  • I have 2 rasp pi 4's. 2GB and 4GB

    The 4gb one has issues with the same micro hdmi cable I have used to setup both of them.

    The color test screen will come up, but then if it's moved slightly the main OS doesn't load with it's default resolution, as if the cable has been unplugged while it was loading.

    I don't get this connection issue with the 2GB model, I can also move it around without any connection issues.

    The OS's I am using are libreelec pi 4 build and raspbian, and it all seems like a hardware disconnection and not a software one. Because if I can get it into a good position I can use the device just fine.

    I am afraid that I may have accidentally broken something when I've treated this device in particular with great care because it was the first one I got.

    Your issue seems on the surface much like mine where the hdmi is not detecting the cable being plugged in. If you move it around do you get any artifacts or images, you might have to do what I am planning on doing and looking into other micro hdmi adaptors

  • Try to edit guisettings.xml

    Code
    <setting id="videoscreen.screenmode">0192001080060.00000pstd</setting>

    Thanks that would have been helpful when I was trying to access that file, videoscreen.screenmode was empty. T%hat should be another way to do it.

    My way though gives an immediate image on Kodi so you can then use the GUI to change settings.

    For some reason the RPi 4 was detecting my display as 1920x1200 capable, I now excluded that resolution from the whitelist just to be safe. I think this board still needs some bugs ironed out.

    Your issue seems on the surface much like mine where the hdmi is not detecting the cable being plugged in. If you move it around do you get any artifacts or images, you might have to do what I am planning on doing and looking into other micro hdmi adaptors

    No it was a software issue, the screen was going off after Kodi was launched, as I explained.


    I get no artifacts or anything, and if I was you I wouldn't be wiggling that around, you probably did damage the port.

  • Thank you so much for this. I spent hours screwing around with this and what you wrote here fixed my problem. Thanks.