No Audio on Raspberry Pi 4B

  • Although I have used KODI for a few years on Android devices, this is my first attempt to run KODI on the Raspberry 4B. I installed yesterday using LibreELEC version 9.1.501 with KODI 18.4 . Everything works well except for audio. I get no audio at all. I started with your default settings and then trying changing them to other settings and nothing seemed to work. I have verified that volume on the Raspberry and the television is on high. I also started up the motherboard using the Raspbian operating system and audio worked fine on a video over the internet. I have the Raspberry Pi connected to the TV with the official Raspberry Pi HDMI cable. Any suggestions for getting this resolved?

  • Can you check in System/Audio if you can change to PI HDMI or something ?

    If it's greyed and only pulseaudio is possible with bluetooth, then you need to wait a fix from Libreelec team.

  • Actually not. I moved to port one and sound is working fine now. Thanks for your suggestion.


    Kent Shaw.

  • Are you using the hdmi port next to the raspberry pi's power jack ?

    hi, blueribb


    I was having same problem, and found this post with your suggested solution. My audio is now working OK !



    Just wanted to say, many thanks for you tip.

  • I have the same problem ! there is no sound from the hdmi port! I already changed the settings and it doesn't work! only through the analog or Bluetooth port. i have a rpi 4b

  • I also have no audio on Raspberry Pi4 and I'm using the HDMI port closest to the USB C power port.


    It shows a red cross speaker icon on the top right underneath the time.


    I get audio to the tv when using Raspbian.

  • The red icon with a speaker and a cross indicates that sound is muted. To get sound again you need to press the mute button (F8 on keyboard) to toggle sound back on.

  • Turn the volume up and it will un-mute. Worst case, SSH into the devices and type "kodi-remote" for a simple keyboard remote.