7.0.2.008 build for S905/S905X


  • Most S905X Boxes don't require Device Tree added during flash. If you have an issue on boot then choose device tree from the version of LE.


    So i got a kingstone 8gb microsd HC and bought an adapter, 008 with the dtb.img and it works perfectly fine, rebooted like 15 times just to see if it will come with that error and nothing.
    MY only issue now is that the remote that came with the box, the Return button doesnt work, I have a T3 remote that i bought and it does work just fine. is there a way to fix the original remote tho?
    LibreELEC boots extremely fast now compared to the USB drive, so i guess putting it on the eMMc will boot even faster?
    How can i access the folders on the box with LibreELEC? the Android/data folder for example

  • So i got a kingstone 8gb microsd HC and bought an adapter, 008 with the dtb.img and it works perfectly fine, rebooted like 15 times just to see if it will come with that error and nothing.
    MY only issue now is that the remote that came with the box, the Return button doesnt work, I have a T3 remote that i bought and it does work just fine. is there a way to fix the original remote tho?
    LibreELEC boots extremely fast now compared to the USB drive, so i guess putting it on the eMMc will boot even faster?
    How can i access the folders on the box with LibreELEC? the Android/data folder for example


    Can you please update to #1  
    Report back.

  • The reason i posted here is because 009 did that error from day 1, while 008 was fine for about 2 weeks until the error came.
    Just afraid now the update will ruin it all again, Also to update will I have to clean install it? because thats just not worth it lol spent all day recovering all the addons for my parants
    Where is that Update folder btw? how can I put the files there If im using libre from SD card


    Can i do it in the file manager? one side have a USB drive with the img and on right side find that Update folder?


    Too bad it cant update like OpenELEC could by just clicking a button in kodi lol

    Edited once, last by vitalero ().


  • Do a Backup of your LE. From LE Settings create a system backup. Onto a USB.
    Now just put the .009 into Update folder (Yes you can use File Manager) and reboot.
    It will update to .009

  • Do a Backup of your LE. From LE Settings create a system backup. Onto a USB.
    Now just put the .009 into Update folder (Yes you can use File Manager) and reboot.
    It will update to .009


    Ok thx ill give it a try, I understand i need the device tree dtb again?


  • Ok thx ill give it a try, I understand i need the device tree dtb again?


    device_trees


    Device tree from above link. You don't have to rename the device tree any more
    Just drop both files into update folder.

  • Cant seem to find the Update folder in the File Manager, and I even connected with Putty and i dont find the Update folder, what is the exact location? and maybe i need to make a new folder name it Update and then put it? if so where



    I think its in the main one, because cd .update worked
    File manager inside the libreelec shows me special://home and special://profile

    Edited once, last by vitalero ().


  • Cant seem to find the Update folder in the File Manager, and I even connected with Putty and i dont find the Update folder, what is the exact location? and maybe i need to make a new folder name it Update and then put it? if so where


    Weird.
    Do a hard reset from LE Settings.
    Then look for it. It should be there . /storage/.update
    You should see .smb then .ssh followed by .update

  • Weird.
    Do a hard reset from LE Settings.
    Then look for it. It should be there . /storage/.update
    You should see .smb then .ssh followed by .update


    Hard reset will remove everything i dont think its worth it, and the backup is of 008 so I cant restore it anyway i think, is this really the only option?
    In putty i can find cd .ssh and also cd .update, so maybe use it that way? Cant do cd .smb tho


    I am thinking that im Already in the Storage folder in putty, thats why it shows me "backup" "lost+found" "music" etc, and the "update" "ssh" "kodi" are hidden folders?


    Command "pwd" shows that im in /Storage location



    Command ls-a shows me that there is a .update folder , also folders like .kodi .cache .config .ssh .swfinfo, so yeah i guess im in the correct folder, can i copy it just with Putty?
    [hr]
    So i used Putty, updated it now its 009, Back button the remote is working!
    Thank you very much bro, hopefully this 009 will be stable. enjoyed playing in Putty for a while, even edited some xml files while in it for stuff that the Skin i use added on startup.


    Cheers

    Edited once, last by vitalero ().

  • Hi, I'm new here, and I don't know that's good place to leave this message.
    Yesterday I receive my new tv box -X96 2GB/16GB. But when I receive it, it wasn't boot correctly.Just only black screen and blue led flashing. Today I made a android update that I downloaded from the net, but when device boot up, I saw that I have only 4 GB internal storage and 2 GB Ram (thats ok). Can anyone advice me some solution how to recover missing 12 GB of internal flash?
    I found two firmwares - for 1GB/8GB version and mine, but I think that I flashed wrong version and now I cant repartition my box by flashing correct update file. Maybe it's related to dtb.img? How and from I can obtain it?
    Please help :huh:


  • Hi, I'm new here, and I don't know that's good place to leave this message.
    Yesterday I receive my new tv box -X96 2GB/16GB. But when I receive it, it wasn't boot correctly.Just only black screen and blue led flashing. Today I made a android update that I downloaded from the net, but when device boot up, I saw that I have only 4 GB internal storage and 2 GB Ram (thats ok). Can anyone advice me some solution how to recover missing 12 GB of internal flash?
    I found two firmwares - for 1GB/8GB version and mine, but I think that I flashed wrong version and now I cant repartition my box by flashing correct update file. Maybe it's related to dtb.img? How and from I can obtain it?
    Please help :huh:


    I have the same box as you. I used kszaq's gxl_p212_2g.dtb as my dtb.img. Follow kszaq's instructions on the original post for SD card/USB drive installation and you should be good. Once you've confirmed everything works use the installation instructions for Internal memory (NAND/eMMC)


  • Which Micro SD cards are the best for Libreelec and what max card size is supported?


    If my old s805 mxq LE box run flawlessly with a S*msung 64GB microSD card (UHS-1 speed) with a normal SD card adapter, then your s905/s905x box should working at least 64GB cards without any problems.
    The overall speed is excellent, much better than stock Android firmware with Kodi from eMMC, for example if you max out you download speed with streaming content it isnt slow down anything (i had always problems and freezes with torrent streaming on Android).

    Edited once, last by hungi ().


  • I successfuly boot the latest build on V88 PRO with S905x chip.
    Will try later to install to internal memory.


    Thanks for the support.


    How did you boot it? I wrote an image to the SD card using Rufus and then inserted it into the SD card slot and booted.
    It booted the stock Android 6.01 firmware instead.
    I put the SD card into a USB card reader and tried again with all four USB ports.
    Every time it boots the stock firmware. :huh:


    I have V88 Pro S905x 1G/8G.


    Thanks!

    Scishion V88 Pro S905X 1G/8G, 100MBit/s LAN w/ LE 9.0 (adamg-1.0.4.1), Onkyo TX-NR609 AV receiver, Mitsubishi HC5500 projector

    Edited once, last by Inesca ().


  • I wrote an image to the SD card using Rufus and then inserted it into the SD card slot and booted.
    It booted the stock Android 6.01 firmware instead.


    Did you insert a Toothpick into recovery switch port of your box and pressed to hear a click ?
    Whilst holding toothpick down, then power box on by inserting power cable into box.

  • I just installed the not temp sensor on MXQ Pro 4K and using it from the SD card. The box is with CPU amlogic s905x and 1G RAM, 8G internal.
    The only problem that I'm facing is that the PVR simple client is taking between 3 and 15 minutes to load the channel.


    Any idea how to fix it?


    Thanks.
    [hr]


    go to this url Yandex.Disk and download the two file into the root of your sd card. Then boot the device into Android and find app Update it should be installed on your device. after that y ou should be able to boot the libreelec from sd card.
    [hr]
    I just installed the not temp sensor on MXQ Pro 4K and using it from the SD card. The box is with CPU amlogic s905x and 1G RAM, 8G internal.
    The only problem that I'm facing is that the PVR simple client is taking between 3 and 15 minutes to load the channel.


    Any idea how to fix it?


    Thanks.

    Edited once, last by Kastoraky ().

  • Been awhile since I have had a reason to check this forum. I have been using my MK808B Plus for a couple of years as my tvheadend server and it has been working well. Today, thought I would retire my old server and install tvheadend on my Beelink Mini MX 3 (Amlogic S905), and everything installed well. The only problem I am having is do to the cec aspect. Every time I turn off my system (AVR and TV), my Beelink turns off.


    I am running LibreELEC version 7.0.2.007. I have turned off the CEC by going into system -> input devices -> peripherals, and changed different settings in the CEC adapter configuration screen, but nothing helps.


    Any ideas on what I can do to keep my Beelink from turning off?? Since I am using it as a DVR, it has to be running 24/7.


    My Beelink feeds into my Denon AVR and from the AVR to my newer Samsung TV. I have the CEC disabled in both the TV and AVR.


    Thanks in advance.