LibreELEC (Leia) 9.1.002 ALPHA

  • Hi,

    I'm still missing full HBR audio support for RPi4. DTS HD MA is detected just like DTS and in option of Kodi there is no option to turn on DTS HD MA. On S905X box it worked just fine. But I think that this is because of old kernel, I'm right?

    In new version I see smoother UI and Kodi itself, that's good.

  • I'm still missing full HBR audio support for RPi4. DTS HD MA is detected just like DTS and in option of Kodi there is no option to turn on DTS HD MA.

    HBR audio isn't implemented yet for the RPi4. It's in the queue but will take a bit (probably months, not weeks).

    so long,


  • Hi,

    I have stuttering problem with some VC-1 full HD movies on PI 4 (1080p 23.976 fps 22.2 Mbps TrueHD 5.1). Player debug info reports several dropped frames, and one cpu core has 98-100% load. It can be reproduced with the VC-1 sample file on KODI Samples page: VC-1 1080i/29.970 (MKV w/DTS-HD MA 5.1 audio). Interestingly the other sample VC-1 file plays smoothly.

    9.1.002 ALPHA is installed on PI 4, 'Adjust display refresh rate' is set to Always, there is no thermal throttling (arm_freq is 1500).

    I understand, that PI 4 has no HW decode, so I can't by a licence. It seems to me, that the software decode uses only one core, and maybe it's too much work for it.

    Does anybody has the same experience?


  • Thanks for feedback AG. I had to set SMB1 (previously 2). Not sure what 's up here ...

  • I understand, that PI 4 has no HW decode, so I can't by a licence.

    MPEG 2 patent status has now expired globally, and so have over half of the VC-1 patents. Although patents and licences are two different things, there isn't much point in offering them for the RPi4 now.

  • With .001 I only used ethernet, but now with .002 I’ve only used 5 GHz wi-fi because I’m at a different location (same ambient temp, no case, no heat sink, no fan) and idle temp has increased quite a lot, about 8 degrees C. Is this to be expected?

  • As soon as I updated to 9.1.002 all live youtube streams stopped working, my movie collection stored locally starting buffering or freezing every 30 sec then loads and continue playing .. seems to be a decoder problem, addon movies like work perfectly no buffering... later I installed youtube alpha addon and live streams worked! but local movies reproduction got worst...

    cpu: intel E5600

    ram: 4 GB

    video: Radeon HD4350 1Gb DDR2

  • Hi,

    I have tested more VC-1 movies on my PI 4, and I think that if one cpu core is powerful enough to decode the movie (decoder cpu core utilization < 95%), then the playback is smooth (no frame drop), and if one the decoder core utilization is higher than 95% VC-1 playback stutters, there are frame drops.


  • Hello,

    I have found that on my RPi 4 4GB even though I have the memory cache set to 3GB it is only using 768MB. In .001 I had it set to 0 so that it would cache to the internal storage and that worked properly...except for the fact that reading/writing to the MicroSD card resulted in video stuttering but the cache setting were being followed. Is this a known issue?

    Also, how big of a donation would be required to get HBR audio moved up the queue? :S LOL



  • My raspberry 4 with two connected HDMI cables does not start, for my configuration, I need to use an hdmi cable for the TV and view the video on this and another cable only for the audio to be connected to my receiver, it is possible this configuration.

  • Scanning new video with The TVDB crashes to a black screen with a tiny curser like spot in the middle of the screen

    this lasts for a few seconds, the screen then returns to home

    I changed scraper in TV Info/content to TMDB TV show Scraper and all's okay

    intel i3-7100 / Gigabyte H270M-D3H / GTX1050 / STX Essence

  • Thanks for that, I'll leave it on TMDB TV show Scraper .. BTW this anyone getting Chinese instead of English on this forum?

    intel i3-7100 / Gigabyte H270M-D3H / GTX1050 / STX Essence

  • Hi,

    I've run into a strange problem. I've been using 9.1.002 Alpha without problems for a few days (including Library Updates)
    Now since yesterday LibreeElec first freezes, then crashes when I am updating my library.
    It happens when the scan reaches 100% for TV is (Movies work without a problem) and I end up with this screen (see attachment).
    The only solution form here on ist to cut the power and restart the RPi.
    Does anybody have any idea what is causing this?

  • See two posts above you