Nightly images for A64, H3, H5, H6 and R40 boards

  • That addon is not supported by Allwinner images because it would overwrite Cedrus improvements. You can only use DVB devices supported in mainline kernel. All DVB drivers should be enabled.

  • When I tried nightly images last time there was no Russian localization. Today I decided to try newer nightlies, but quickly found that two latest published builds does not boot on NanoPi M1 - just black screen, green lid just lights up, blue one does not blink as it supposed to during boot up.


    1. I extracted gz archive before writing it to microSD.

    2. I tried several microSD (by Transcend, Kingstone, couple of Samsung EVO Plus and one SanDisk Ultra)

    3. Armbian boot on same board just fine from same microSD I tested for LibreELEC.


    I wonder if published NanoPi M1 images is broken or I been missing something? By the way, is there support for onboard IR receiver or HDMI-CEC in these images?

  • When will a new image be available?


    Changes are applied in next nightly image after PR gets merged, but I don't know when it will be merged.

    There is no stable version for OPi Lite 2, only "develop" or "nightly". So I'm trying to install every new build that appears on the page "https://test.libreelec.tv/" (in the hope that it will be better than the previous version).

    But now it makes no sense, the last functional version for me was "nightly-20200418-34ae240".


    Please, is there a way to know that the PVTV IPTV Simple Client will work again without having to install a new build

    (all versions, where the PVR IPTV Simple Client does not work, are worthless to me) ?

  • When I try to update the system on Orange Pi PC Plus:

    to the newest build, for example, 1st or 2nd May ones, the system unpack them and then writes

    Quote

    The compressed Image is corrupt/invalid!


    Also I noticed that images for Orange Pi PC Plus are smaller than others, is it right?

  • Please, is there a way to know that the PVTV IPTV Simple Client will work again without having to install a new build

    You don't need to update image, you have to wait for addons update. They will probably be updated soon but I can't tell you when exactly.

  • The Kodi v19 with Pylon 3.0 would not work with addons with Pylon 2.1.0. So new Kodi users want the old addons can not use Libreelec any more. Should there be a place for the final version of the last Kodi version (eg: version 18) for download? If not, do any one have the latest Kodi 18 for Orange Pi (PC, Lite, One-Plus) and Banana Pi A20 that I can download? Thank you. (There was a big debate on Pylon 3.0 with or without 2.1.1 on Kodi v19 release last month, but at this moment, the without wins.)

  • Should there be a place for the final version of the last Kodi version (eg: version 18) for download?

    There is no images with Kodi 18 for Allwinner that you can download from LE website. Maybe someone will provide them on forum as community images.

  • I finally managed to prepare proof of concept (not yet bug free) support for HW deinterlacing. Currently, it's only for H3. You can test this with following update: LibreELEC-H3.arm-9.80-devel-20200202224107-87919a4-deint.tar

    I tested this with DVB-S Mpeg2 stream on an Banana Pi BPI-M2-Plus H3. But here i get only a red picture. It looks like not all planes available on the screen. I tested with Kodi and my own v4l2 code. Both with same result.


    Edit: Today I tested h264 1080i from DVB-S stream with same result. Only a red picture.

    Edited once, last by zillevdr ().

  • Kodi was recently updated in master branch, so addons will have to be updated. Not sure when that will be.


    levitsky86 Old nightly images are deleted from server.

    Dear Jernej,


    Please explain me how should I check for that add-on update? I mean, if I install the newest nightly update, should I check in Kodi for PVR update and it has to update it to the newest version if its already released?

    Or, would I have to recompile the whole Kodi image in Linux and then the PVR add-on too? Thanks for your help!

  • Addons should be updated now.

    Thanks fot the heads up!


    I managed to update quite a few add ons but many failed with the dependency xbmc.python


    Is that a problem with a missing add on, or are the failing add ons just not migrated to python 3?


    Is there a way to update all add ons at once? Like with an apg-get update / dist-upgrade? Or do I need to go through all with the remote?

  • Just saw they expect python2


    Other than that all is now perfect again.


    Btw. whats the status with mali and deinterlacing on H3? Are both active now?