Nightly images for A64, H3, H5, H6 and R40 boards

  • Gatuno I tried using your instruction for moving libreelec from sd to emmc on a Orange pi 3 h6. It didn't work. After removal of the sd card the opi 3 just boots into its chinese default system. Do you have some advice on how to move it correctly?

    Gatuno sorry i missed the bootloader thing. where do i get the u-boot-sunxi-with-spl.bin if i don't compile libreelec myself?


  • prabuselva thanks for working on this, but you'll have to rebase your work on current master branch. New features, like supporting new board, are accepted only there. Please describe your issues with 1080p HDMI in more detail and append any relevant data, like dmesg output and clk_summary content.

    jernej, Okay I will rebase on master branch.. and try the dts patch with 5.3.x kernel again..

    Regarding the issues for OPI Lite2 with master branch kernel, the following issues were faced

    - Instead of 1080p Display, I only get 1024x768p Display
    - No sound via HDMI

    - Booting is successful only in 1 out 5 attempts..(May be still due to HDMI issues)
    - VIdeo playback causes higher CPU usage..

    I will recompile with 5.3.x and provide the logs for debugging.. It should be mostly coz of elements mismatch in my DTS patch between 5.1 and 5.3 kernel

    Good news is that I can see device is reasonably stable with 9.2 branch with 5.1.x kernel which means that the device can be easily added and fixed for minor issues with almost 90% features working :)

  • That means that EDID was not read correctly. Do you have ddc-en-gpios = <&pio 7 2 GPIO_ACTIVE_HIGH>; /* PH2 */ in your HDMI connector node?

    I think I didn't have those..I will confirm it soon..

    How did you determined that? what are the numbers before/after? That code didn't change much in a long time.

    Basically, In master branch, I was checking the codec information while playing youtube videos, for 720p h264 video, I was getting like 40% usage and cpu was also very hot and freeze...But the same video in libreelec-9.2 branch, I was able to get 3-5% only even for 1080p h264..

    Also to note that.. I was using Bluetooth headphones for audio in master branch as HDMI sound was not available..

    But let me repeat the same test with your HDMI fix with master branch so that I get my HDMI resolution and HDMI audio issued solved...

  • That means that EDID was not read correctly. Do you have ddc-en-gpios = <&pio 7 2 GPIO_ACTIVE_HIGH>; /* PH2 */ in your HDMI connector node?

    This was it.. Now The DTS patch works great for Orangepi lite2 with master branch kernel 5.3.5 as well..

    Regarding Video performance issues, It was my bad since I enabled debug logs during one of my tests to debug HDMI sound issue which could have increased CPU usage during video playback

    Finally... I got almost same results as Libreelec 9.2 branch with regards to performance


    - WIFI,

    - Bluetooth with headphones,

    - 1080p HDMI Display,

    - H264 upto 1080p 30fps,

    - H264 4K 30fps

    - Youtube Addon H264 upto 1080p,

    - HEVC upto 4K 60fps (8bit)

    - USB2 & USB3 (in USB2 mode)

    Not Working

    - WIFI doesn't auto connect on bootup (sometimes)

    - bluetooth doesn't auto pairing upon bootup (sometimes)

    - Frequent freezes due to CPU running at 1.8Ghz at idle state (Changing to schedutil governor helped a little better compared to performance governor)

    Not Tested

    - 10 Bit HEVC Videos

    - 4K TV output (Only 1080p and 4K downscaled to 1080p tested)

    - IR remote

    - Lots more...

    The compiled image for Orangepi lite2 with Kodi 19 is available for testing


    Note: If first bootup fails, Please try to power cycle the board atleast 3-4 times.. It will eventually boot and come into startup screen

    I had to fix Libreelec settings package to python3 issue as well from the latest commit..

    I hope after someone else test the above image, you can include Orangepi lite2 board in your supported board lists if the patch seems okay to you..Please let me know how can I send PR request to you or the LE team..

    BTW.. Thanks for your support to the open community :)

  • Jernej, I tired your patches on linux 5.3.7 and now the hdmi sound works. Seems something was broken in 5.3.6.


    I discovered what gives me the isue with the HDMI sound on the pine64-plus.. It's the rtl8723bs module. As I tried building a kernel to use the wifi and BT module I compiled the rtl8723bs module from staging. I enabled both hdmi_sound and wifi in the dts and discovered that the sound was completely messed up. So I compiled the 5.3.7 kernel and found out sound worked but wifi didn't work because I forgot to enable the rtl8723bs module. After I recompiled the kernel again with the rtl8723bs module included the sound starts doiing strange things again. I disabled the wifi in the dtb, but the sound stays behaving strange. I compiled just the same kernel with only the rtl8723bs module as difference.

    Any idea?

  • prabuselva can you give a link to your git repository? Or better yet, make PR to LE master and I'll make a review.

    Note, no H6 supported board runs at 1.8 GHz. There is no need fo that. Ideally, video is HW decoded and usually runs at lowest possible setting.

    Agreed regarding the 1.8Ghz.. So, I fixed the max CPU freq to 1.32 Ghz for now and tested.. Seems more stable and no heating issue..

    I have created a pull request at the LE master branch.. Please do review and let me know there if any is additional fix required.. Thanks

  • Hi, after installing armbian on an old sunvell r69 H2+ 1/8GB (V1.3 red pcb) i tried one nightly on micro-sd-card made for Beelink x2: LibreELEC-H3.arm-9.80-nightly-20191019-c9510d4-beelink-x2.img.gz

    It works pretty well on that box(for armbian I added a fan to keep it cooler) with unchanged dtb:

    what works out of the box:

    -HDMI 1080p (even the glitches often found on android & armbian using higher res than 720p didn't appear in 2 hours test!!!)

    -HDMI Sound

    -both USB ports working(used one for dongle from keyboard-mouse-combo and other for usb-wifi)

    -power LED is red (not perfect, but this way I see which os is booted: blue heartbeat=armbian, red=libreelec)

    -addons using widevine work flawless (did just a short test with joyn for maybe 1hour)

    -card reader (boots from that device.. ;) )

    -internal Memory (formatted ext4 for armbian)

    -ethernet working

    untested/not working:

    Ethernet = untested

    internal wifi = not working

    av-port = untested not working

    remote = not working (used remote conf working with that remote on s905w-box *eelecs)

    optical = untested

    software reboot = not working (device needs switching power supply to reboot)

    power off via gui = not working (get "system halted" message, but device stays powered somehow)

    I guess some problems are caused by using beelink-dtb (that one from kernel 4.14.xx Armbian doesn't work).

    Is there a way to convert the dtb from armbian build to work with libreelec too, or is there a way to edit the dtb/dts from the beelink-box to enhance support of sunvell r69 v 1.3 hardware?

    Edited once, last by turgus: Updated tests ().

    • Official Post

    turgus You won't be eable to fix much with editing dtb. There is no support for XR819, remote must be set manually (I will probably add default remote mapping for X2 in DT, but I don't know if R69 uses same remote), "system halted" message is normal - at this point you just plug out device. Only weird thing is that reboot doesn't work. However, that would indicate some kernel crash. You would need to edit extlinux.conf a bit and connect a serial adapter to figure out what's going on.