[S812] MIII Plus 2Gb\16Gb eMMC

  • OK, I formatted the SD card, then I used the downloaded .img.gz from 20170801, extracted the .img file and then burned that to the SD card. I did not remove or add any files to the card. Then I put the SD card into the box, used the toothpick method and nothing happened after 60 seconds. When I removed the toothpick the GoogleTV image comes up, then disappears after maybe 10 seconds and the 120 second/ automatic repair message appears on the top left of the box.

    When I remove the card and boot the box goes into Android successfully.

    I have attached a snip of the files that are on the card.

    Note that I did use the update&backup app to install the aml_autoscript files prior to trying your method.

    Thanks for your help.

    Try a USB stick as every time i get the 120 seconds message it will only work on USB and not SD card

  • Yeah, there is something weird with the script that sets up the multiboot for these boxes. Also, the one from the balbes150 image does not work with the demetris image and vice versa, so it looks like there is not a standard approach to applying the multi-boot ?

    On a positive note, the new image did work on a MXiii (S802 chip) by using toothpick method by SD but then inserting into USB to boot up. However, as I said, after doing this, the Demetris image would no longer boot from USB and the whole SD/Toothpick/Then_USB_Boot process had to be done again.

    So I am wondering if the multi-boot thing could be looked at to get the SD card booting up and perhaps at least the method could be standardised ?

  • Now record the same image on any USB flash drive. Turn off the TV box. Connect the USB flash drive and turn on the power of TV Boxing.

    I kept getting the 120 second error, so I did what you said here. I wrote the same image to a USB stick and did the toothpick install - GoogleTV logo comes up and after ~30 seconds the box goes into recovery with a message that E: Cannot Load Volume /misc!

    I tried turning off the box, inserting the USB stick and then turning on the box. Google TV logo comes up and the Android boots.

    OK, I exited from recovery (the original MXIII-G recovery) and the box booted into LE. I'm not all that confident yet, but so far so good.

    That didn't last very long. The box now reboots into Android no matter what method I use.

    Edited 2 times, last by doggyofone: Update (August 4, 2017 at 8:22 PM).

  • Hello, balbes150 i like to say thank you for making these roms.

    I can say that the LibreELEC-S812.MXIII_Plus.arm-8.0.2 and the LibreELEC-MXIII_Plus.arm-17.3_20170801 build are working on the minix neo8x-h.

    There is a wired and wireless connection.

    Only when booting up the device and the bootscreen comes up there is some text on the left side of the screen in the new version this is solved a bit with some less text is it possible to hide this so we have a nice clean bootscreen ?

    Also when you shutdown the device and and you want to power it on again you need to pull out the power cable and plug it in again and then push the power button, is it possible to fix this?

  • Tronsmart MXIII Plus:

    Unable to update from 07.07.2017 to 08.08.2017 using .tar file fails, error message about incompatible hardware. Forcing update using nocompat works and allows update to 08.08.2017 however bluetooth missing, "No Bluetooth adapter found"

    Downgrading to LibreELEC-MXIII_Plus.arm-17.3_20170801.tar also has no Bluetooth. I have not tried a clean install of 01.08.2017 or 08.08.2017 to determine if Bluetooth support would work.

    Attempting to downgrade from August 2017 builds to 07.07.2017 .tar file fails again with same message about incompatible hardware. Adding nocompat file to 07.07.2017 allows downgrade to successfully complete and bluetooth working again.

    balbes150 - Could you have a look into why Bluetooth is missing?

    Edited 4 times, last by 7up (August 13, 2017 at 9:01 PM).

  • Hi balbes150

    I have been using your builds for a while now on my MXiii-G, unfortunately none of the later builds will boot from an SD card, I get the file system corruption message that several people have reported, this is the same for an upgrade or a fresh install.. I tried again yesterday with LibreELEC-MXIII_Plus.arm-17.3_201708016 and that was the same, a fresh install did not work, file system corruption, upgrading a working SD card with this build also gave the corruption message.

    If I put the image on a USB stick I can boot the later builds however this is far from ideal for me or a lot of other people, most of my USB sticks are old and VERY slow (5Mb/Sec) making things unusable :(

    The last version to work correctly with an SD card was LibreELEC-S812.MXIII_Plus.arm-17.3_20170622 , is there any way you could look to see why this works and later builds do not, you would make a lot of us happy fixing this :)

    Best Regards !

  • Hi,

    Non booting from SD still (22/08), hopefully some info that will help, this is from an earlier balbes150 release, MXiii-G Plus (2/8)

    Edited 2 times, last by itsmeedoofer (August 23, 2017 at 9:23 PM).

  • Download Rufus and write LibreELEC-S812.arm-17.4_20170822-MXIII_Plus.img.gz file to SD card

    If only it were that easy :)

    For myself and others the later builds will not run from SD, something has changed in the Autoboot that causes a filesystem corruption error. For example a working installation of LibreELEC-S812.MXIII_Plus.arm-17.3_20170622 will break with the corruption error when I try to upgrade to LibreELEC-S812.arm-17.4_20170822-MXIII_Plus, a fresh installation also fails with the error.

    I have refreshed the Autoboot as advised, looking into the output of fw_printenv this looks to be installed, however still no boot....

    There was the comment made that it is the SD card at fault, if this is the case how come the previous installation works OK, AlexElec installs and runs fine, the Demetris builds boot ? I've also tried a dozen or so different cards all to the same effect :(

  • I confirm. AlexElec boots and installs fine on this boxalexelec-arm-2-3-0-amlogic-s805-s812-905-905x-905d

    Wired network works fine. Wireless I dunno cos I have not tried and I'm not interested. Media play fine. Too bad it's in Russian and it's a bit of a pain to set Kodi in English but hell, it's manageable.

  • I generally install to SD card but as I couldn't find adapter I used burned 201708018-MXIII_Plus.img.gz file to USB stick. Now that I think about it, the initial boot might have come up with a black screen or flashing video but after a hard reset and the MXIII Plus booted up normal. Not wanting to run off USB, I used the shut down menu to install to internal hard drive. If I can find my SD card adapter I'll try install to SD card but not sure why it would be any different.

  • I had no success booting with the balbes150 images on my MXIII-G 2g8g, so I went back to Demitris's build to see if I could get his image to boot. After some experimenting I was finally successful and now have a working image for version 8.2 RC2. The method I used for success was unusual, but was the only way I could get things to work. If you are looking for working images you should check Demitris's thread and you can refer to my instructions here:

    S802/S812-Libreelec images for 7/8/x

    Hope this helps.