[S812] MIII Plus 2Gb\16Gb eMMC

  • Assembled using corrected patch Demetris test image. Visitors can try (version Test_20170614)

    Hello balbes150,


    Many thanks for your efforts.


    I have tried your build of Demetris image on my M8S (clone) which I have tested before with your images (started with toothpick and SDram boot with your image).


    With your build of Demetris image, my M8S seems to boot and function but for some reason when I am trying to access LibreELEC addons repository, it pops a message that the box could not connect to the repository ! (ethernet works fine and the box can access other addon repositories)


    Do you have any idea of how ti fix this ? (I am trying to install and test tvheadend42)

  • Have you tried to use the image MXIII_Plus ?

    Balbes tested yesterday your latest MXIII_Plus image on my ENY M8S and it works like a charm (never thought to try de MXIII-plus version). No corrupted filesystem message, LAN and WIFI works great and it's fast also. So for the moment, nothing to complain.

  • Just tried the LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.tar on my Minix X8-H Plus. Good news: first build with 4K resolution working fine!

    That's one step ahead. LAN working, but no Wi-Fi with the BCM4335 of the X8-H Plus.

  • Hi balbes150 ,

    using your LibreElec for MXIII_Plus by several month on my tronsmart 2GB/16GB. Everythings works fine, but with the latest build "LibreELEC-S812.MXIII_Plus.arm-17.3_20170614" I can't browse file in Kodi file manager. Move pointer with mini-keyboard or with a mouse doesn't work.
    This bug appened only in the file manager. All the rest works like a charm.


  • Balbes tested yesterday your latest MXIII_Plus image on my ENY M8S and it works like a charm (never thought to try de MXIII-plus version). No corrupted filesystem message, LAN and WIFI works great and it's fast also. So for the moment, nothing to complain.

    I have two M8S boxes:

    1st is a clone which I could boot with balbes150 images (no wifi)

    2nd is an ENY M8S which I couldnt boot (corrupted file system... or hanging with M8S logo...)


    Could you boot your ENY M8S box and install LE to an SDcard or USB stick ?

    Can you give more details about the exact image you have used and the boot/install procedure ?

  • Could you boot your ENY M8S box and install LE to an SDcard or USB stick ?

    Can you give more details about the exact image you have used and the boot/install procedure ?

    I booted from SD. It was the image LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz

    I burned the image to SD with etcher.

    My m8s is multiboot enabled. So I just put in the sd-card and power on the device. Since the last lan1000 images I had the "filesystem corruption" error, but with the MXIII-plus image everything works fine. Didn't test it very well though, but remote, wifi and lan works OK.

  • I booted from SD. It was the image LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz

    I burned the image to SD with etcher.

    My m8s is multiboot enabled. So I just put in the sd-card and power on the device. Since the last lan1000 images I had the "filesystem corruption" error, but with the MXIII-plus image everything works fine. Didn't test it very well though, but remote, wifi and lan works OK.

    My ENY M8S box is an 8G/2G s812 box with 100M ethernet and ap6330 based wifi (M8 V8_1 20150418 board).


    I have attached a picture in Demetris LE thread S802/S812-Libreelec images for 7/8/x


    Do you think that we are talking on the same box ?


    I have also enabled multiboot with balbes150 images but could never successfully boot and install any of the images (burned with LE USB SD creator). All I am getting when trying to boot from an SDcard is either the "filesystem corruption" error or the box hangs with the M8S S812 logo.


    I have tried also to boot from an USB stick but the box skips to android.


    When booting with both SDcard and USB stick (burned with the same image and both plugged to the box !) , I could get some advance with LE first boot phase but the second boot phase fails with "couldn't mount LE file system..." .

  • nitnit


    When you try to boot from usb, do you put your stick in the usb port closest to hdmi port? You are sure you used the toothpick method with balbes images and not the one from Demetris? Although it shouldn't be a problem, cause the image from Demetris searches for a kernel.img and the one from Balbes searches for a S805_autoscript. So Balbes images should work on a 'Demetris-system'.


    I checked you picture. It isn't the same board, mine is labeled M9&M8_V1.0 2014/07/07, it's almost 3 years old, time fly.

  • I booted from SD. It was the image LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz

    I burned the image to SD with etcher.

    My m8s is multiboot enabled. So I just put in the sd-card and power on the device. Since the last lan1000 images I had the "filesystem corruption" error, but with the MXIII-plus image everything works fine. Didn't test it very well though, but remote, wifi and lan works OK.

    Hi roel,


    I have an M8S.AP6330.201509251800 (KK4.4.2) and would like to try balbes150 image LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz


    You said "My m8s is multiboot enabled" ....how do I do this on my box?


    I only want to test image...NOT write to nand.


    Is LibreElec USB-SD creator ok to use for writing image, or must I use "etcher" like you did?


    Thanks for your help.

  • I decided to burn "LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz" onto an SD card using Etcher.

    Not really sure what or how to do "multiboot enabled" or check for it??

    But I went ahed and placed the SD card in the M8S, pushed in toothpick & pressed power, I let go toothpick when M8S logo appeared, it continued to boot but soon got an error "not compatible" or something.

    Tried again with 3 more different images on SD, same result, no boot.


    Then tried "LibreELEC-S812.MXIII_Plus.arm-17.3_20170614.img.gz" on a USB stick, it worked...and booted into LibreElec (Krypton 17.3)

    However, too unstable for me, no wifi, no DD5.1 passthrough and unable to power off via remote.


    I have just finished testing "LibreELEC-S812.M8S.arm-8.0.2.img.gz 18/04/2017) on USB (Krypton 17.1 logo, but build says 17.2)

    Ethernet is good

    wifi does not connect.

    Audio passthrough DD5.1 is working

    Auto frame refresh rate works good - smooth video playback

    H265 works (8bit)

    IR remote works

    Menu power off via remote works

    could not play a small 4K demo video


    Not sure if it works on SD card - might try it later.

    I notice that there are no other "LibreELEC-S812.M8S.arm-8.0.2.img.gz" later than 18/4/2017

    Would like to try and update to Krypton 17.3 if possible...and also working wifi.

  • Yeah, these M8S devices are funny things. On mine the LibreElec-S812.M8S version does work but no lan and no wifi. The lan.100 version gets stuck on boot. The lan.1000 version did work, with lan and wifi, but now I have the corrupted filesystem error. So I tried the MXIII_PLUS image and this one boots fine and everything works, theonly thing I had to do is add my remote.config to the LIBREELEC partition on the sd-card.

  • Hello, I have a k2 quad core android box s812, anyone have some time to DM me and walk me through a couple things. Thanks in advanced

  • Just tried balbes150 latest "LibreELEC-S812.MXIII_Plus.arm-17.3_20170622.img.gz" on USB (not working on SD)

    - Ethernet good

    - wifi good

    - Auto frame refresh rate good

    - H265 works (8bit)

    - IR remote NOT working

    - Audio passthrough DD5.1 NOT working

    - HDMI-CEC remote working


    If only the build I tried previously "LibreELEC-S812.M8S.arm-8.0.2.img.gz 18/04/2017" could be combined with this one, it would be nearly perfect !!

    Thanks for your work balbes150.

  • A friend has the M8S.BCM4335.201509251818

    I have tried many of balbes150 builds, but none will boot

    I have done the toothpick method but still no luck with USB or SD.

    Any help please?

  • Hello balbes150,


    Some feedback for the LibreELEC-S812.LAN_100.arm-17.3_20170628 on an M8S S812 2G/8G. Updating from a working install of LibreELEC-S812.LAN_100.arm-17.3_20170614 using the .tar, the box performs the update process proceeds to reboot and display the boot logo as normal and then hangs on a black screen immediately at the point where it would normally display the LibreELEC splash screen. I am unable to connect to the device over ssh after the update so unfortunately I can't even provide you with a log.

    Looking at your Yanex Disk, I've noticed there is no LAN 1000 version. Is it possible that it was mislabeled as LAN100? That could explain why it hung on my box.


    That said, your S812.LAN_100.arm-17.3_20170614 build works extremely well.

    Thank you for your continued hard work and dedication to this scene!

    • Official Post

    Version LAN_100 now contains only a single dtb file to n200_2G with network card 100 MB. All other options dtb collected in the same way MXIII_Plus. I plan to update only these two images. To all who used other versions of the images (LAN1000 M8S, etc.) to test the operation of the image MXIII_Plus. For those who do not work the remote control for media there are three options files for multiple models (you need to choose your and to rename "remote.conf"). If these files are not suitable, please provide me the versions of the working files to include in the composition of the image.

  • Indeed on the 2 latest builds (also MXIII-plus) the libreelec splash screen is gone. I get a "no signal" message on the screen. But libreelec works. Wait a little bit and suddenly the kodi screen appears. I had the same issue yesterday and downgraded again to the 14/06 build.