Problem playing via NAS (9.0.1)

  • Hi everyone,


    I'm having a bizarre problem with LibreElec 19 (both releases) in that any video file played over the NAS suddenly buffers every few seconds and takes a while to even start playing. When rolling back to v18 everything works perfectly again. Have also tried playing via USB on v19 and it works perfectly, but if it's purely a network issue how is it working perfectly on v18? Videos are H264.


    Hardware:


    Gigabyte Brix (i5 -4200u with 8GB Ram)


    Log file:


    hastebin (hopefully this helps one of you).


    I've tried swapping from NFS to SAMBA with no difference.


    Any help appreciated.

  • Likely a borked Linux network driver, which is unfortunate.

    Or Gigabyte messed up a BIOS update?

  • Haven't updated the BIOS in a long while, doubt Gigabyte even put out firmware for this now.


    Does look like a driver issue and not something I'm familiar with sorting (even if possible). Works perfectly on Krypton but that limits choice of themes and new features. Currently trying an Amazon Fire Stick (the new 4K one) just to rule out any network issues but if my phone can access the NAS and playback perfectly I can't see it being the network or NAS at fault.


    EDIT: Tried the Fire Stick as mentioned. Network appears to be fine, must definitely be driver related which I assume will make the "Brix" machines end of life for future Kodi builds?

    Edited once, last by TermiCop ().

  • I am having the exact same problem with a 7th generation Intel NUC. I am attributing it to 9.0.0, and am hoping that 9.0.1 will cure this weird little bug. My network is also 100% wired and content is local. Sometimes it will buffer forward and sometimes it will buffer backwards up to three or four minutes. Very random.


    I am new to LibreELEC and would love to know what the best procedure is to update to 9.0.1.

    Thanks!

  • Yeah I thought the issue was resolved after doing a BIOS update and playback was normal until I restarted and the problem has returned. Guess I'm stuck on the Krypton build unless this mysterious issue is resolved.

  • I have a similar issue with slow SMB (Samba) browsing and random buffering issues since 9.0/9.01 on my 2 Intel HP Haswell based machines.(No Windows SMB shares, just between to Libreelec machines on a gigabit wired network)

    Accessing the same files and folders via UPNP shares works perfectly however with fast browsing and zero buffering, this problematic SMB behaviour was not present in previous Libreelec releases I have been using.

    I believe there is a kernel 4.19 regression issue which affects Ethernet performance on Haswell based machines (info via Chromebox - Official Kodi Wiki )

    I applied the fix suggested but this did not solve my SMB issues

    Using UPNP to share files is a workaround that works for me now but hopefully this SMB problem can be tracked down and fixed as otherwise the 9.01 release is running great.

  • I second this issue. First I thought that it was a problem with several addons, but on version 9.0.1 every single one has buffering issues. Impossible to watch even 5 minutes without stuttering/stopping. Tried a dozen of different versions of advancedsettings.xml, changed to a lower resolution etc. - nothing works.

  • Hi everyone. I updated to Kodi 9.0.1 last night on my HP i3 Haswell based machine and had exactly the same problem. Wireless is working fine, as is an Anker USB 3 to gigabit adapter (borrowed from my MiBox, which I want to put back). Has anyone had any success with resolving this issue?