Upgraded from 8.2.5 to 9 on Intel Nuc. Calibration resets after each reboot.

  • I have more than one issue. Please tell me if I can keep them all here or need a separate thread for each issue.


    After upgrading my Intel NUC from libreelec 8.2.5 to 9 the video calibration resets after each reboot and needs to be readjusted.

    Check the log for errors and warnings and I find over 540 pages of errors. scrolled through them and 95%+ are informing of the repositories using HTTP instead of HTTPS

    along with a generic message about addons and unknown variables.


    The PVR simple client attempts to update the channels and guide before the VPN has loaded even though the VPN setting is set to load first during boot up.


    The error log file is too long to upload but I will if you request it.


    Thanks for your time.

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum, use pastebin.com and post the link.
  • I am following the wiki for uploading the log. Using the instruction for libreelec I get an error that says Libreelec setting addon is not ready yet, please try again later.


    How should I proceed so I can upload the log?

  • I have same issue with two of my NUC ( NUC6cayh and NUC7i5bnk ), plus no audio when playing a video file. Gave up and went back to 8.2.5.Everything working fine.


    I'll wait for further LibreELEC updates before trying 9.0 again.

    Edited once, last by rrsportsc ().

  • I'm having the same calbratuon reset problem (amongst others) too. I'm using the generic build of 9 upgrading from 8.2.5


    I've gone back to 8.2.5 for now too and restored my backup

  • I've got the same issue. Running generic version on a HP 8100 Elite SFF PC (i3, 2100). Every time I reboot, the video calibration is reverted.

    I'll try to post a log but I've gone back to 8 for the time being.

  • I have the same issue running the generic x86 build on a intel i3 Shuttle machine.


    Change the video calibration once machine is rebooted/powered off and booted back into LibreELEC the video calibration is reverted.


    chewitt I have enabled debugging logging and restarted re-created the issue and uploaded the logs to pastebin.com as suggested a couple of post above, Here is the URL


    http://ix.io/1arr


    Hope this helps.

  • Hello,


    I have the exact same problem that the Video Calibration resets after each reboot. Intel NUC d34010wyk on a Samsung Series UE46C6200 running the generic x86 build 9.0.0 on 8.2.5 it was fine.

  • Long story short .. there's nothing in the logs. For the sake of experimenting please configure things then stop Kodi with "systemctl stop kodi" and then reboot. Is the calibration preserved? .. this should isolate whether it's the multi-year recurring issue of the OS hard-terminating Kodi (because it's taken far too long to shut-down) which can corrupt guisettings.xml and results in a new file on restart. Also useful to know .. do other settings get lost too?

  • Hi, I stoped Kodi with "systemctl stop kodi" and then reboot but its the same then bevor video calibration resets after reboot.

    No other Settings getting lost in my case

  • Running LibreELEC on an Asus CN60 machine, and an Asus CN65 machine.

    Did backup of existing via LibreELEC backup menu, then did clean install from USB to libreelec9, and then restored backup.


    I see this issue with video calibration reset after reboot on both my machines, not only that, it happens when I do a suspend to RAM also!

    Edited once, last by odinb ().

  • I'm having the same issue. Very annoying since the TV in use is slightly older and won't default to Just Scan :'(

    If there's anything at all I can do to assist with troubleshooting please do let me know.

  • After upgrading my Intel NUC from libreelec 8.2.5 to 9 the video calibration resets after each reboot and needs to be readjusted.

    Okay, just to get things clear. Is the video calibration really the only thing that gets reset after a reboot? Every other setting gets stored, video and/or music databases get updated?

    Also, why do you need video calibration anyway? Do have have some old CRT monitor attached? Current TVs shouldn't have a problem with a PC video signal.

  • Okay, just to get things clear. Is the video calibration really the only thing that gets reset after a reboot? Every other setting gets stored, video and/or music databases get updated?

    Also, why do you need video calibration anyway? Do have have some old CRT monitor attached? Current TVs shouldn't have a problem with a PC video signal.

    I have a LG HD TV connected via HDMI - it's about 5 years old. When set to 1080 60Hz (or 50 - no other options available), the screen always needs resizing via the video calibration. Resizing is required the for Libreelec 8/Kodi 17, too, only that remembers.


    It's not just a CRT issue.


    In terms of settings, I think it's just the video calibration.

  • I happen to have a LG TV from 2012, and it has an option to disable/circumvent the legacy overscan feature.


    Something like this:

    1344342467.jpeg

  • Why change/adjust TV settings to correct a KODI issue when there was none on the previous version.


    And what effect will changing TV settings have on other attached devices like a dvd player, dvr, or tivo. ?