LibreELEC (Leia) v8.95.1 BETA

  • Source: LibreELEC (Leia) v8.95.1 BETA – LibreELEC

  • Hey thx , but still unusable for me:

    on wetek play 2

    sounds are ok , then lauch a movie that trigger passthrough with my receiver , then stop the movie and no sound at all exept if it use passtrough

    I must reboot :(

    This bug doesn't exist on coreelec (If it helps)

  • Thank You for new release.

    Thank You for supporting Wetek Core!

    Works great with Wetek Core.

    Merry Christamas!!!

  • Maybe try coreelec , samebug for you @poweramour ?

    I Have another issue with both : pathsubsitution for sources.xml on nfs doesn't work.

  • Nice build. Everything is working excepts VAAPI at mpeg2 hardware acceleration. I must deactivate VAAPI for mpeg2 (Radeon HD 5450), because computer is hard-crashing or only falling to homescreen (better scenario with DVD playing).

  • Same for me on Wetek Play 2 (and LePotato) with any DTS passthrough playback, it's been a bug since the early Alpha's unfortunately.

    Thats sadly not easily fixable without heavy Kodi patching and starting fixing the known very broken kernel codebase for AMLogic 3.14.

    We have decided to not do that for K18 because the new kernel codebase is already at the corner and properly fixing the old one takes too much efforts that are basically wasted after K18 (the old way AML Kernel 3.14 is doing things is getting completely removed for K19). There is also a news article about it Development Update – LibreELEC .

  • I've loaded this release on my RPi2. Whenever I try to restore my backup from 8.2.5, it appears to go OK but when it reboots, the restore has not taken place and the initial setup screen appears.

    Also when it does run, the audio is out of sync with the video.

    Anyone know what's happening and can anyone suggest any work arounds for this problem?

    Edited 2 times, last by jmooremcc ().

  • Hi, I'm trying to install this version on my Odroid C2. I have tried from several computers and several SD cards but I can not get it started. It gives me kernel panics at the first start. I'm downloading the specific image for Odroid C2. Do we have to do something to install it? The version I currently have is 8.2.5 and I have tried to record it on one of the cards and it works perfectly. I have used both the Libreelec installer and Etcher without any success. A curiosity is that the version 8.2.5 is aarch and the 8.95.1 is arm ... Do you have to do something before starting for the first time once recorded the image on the SD card?


  • Hi, in first boot the show the logo and first time process, but always stop while checking partition or when resize it. If I reboot it show kernel panics.

    I try to use the same SD with 8.2.5 version and works fine. I try different SD cards.

    I don't know what can be the problem...

    Thanks for your interest CvH

  • Strange, we tested it and it worked.

    Could you fresh install 9.0 ? A workaround is to backup via LE Settings Addon, copy backup off the box. Install LE9.0, copy backup to the box and restore it.