LibreELEC (Leia) v8.90.006 ALPHA

  • Source: LibreELEC (Leia) v8.90.006 ALPHA – LibreELEC

  • DTS passthrough seems to cause an audio glitch for me on the Wetek Play 2, whereby once a play a file with DTS (which will work fine) and then return to the menu the audio is reverby and delayed, and sounds like it's in slow motion until the unit is restarted.

    Other than that all good, apart from having to get used to how the resolution Whitelists are supposed to work, not having much fun at seeing 3840 × 2160 50Hz selected by some of my test files, and then ended up with a blank screen... but hey, I know that's a Kodi thing now.

  • Hi,

    today I compiled the 01f20a4 github snapshot for my wetek play 1 and I got sound problems too. In case I start a tvheadend sat tv channel in my PVR client plugin a few seconds it's ok but then a noise remains that sounds a little like a metallic noise. Interestingly it not occures on every channel. So it maybe depends on sound properties of the selected channel?

    Best regards


  • Hello CvH

    I would like to test to confirm that the problem was solved, however whenever I try to update with the tar file it presents this error


  • Hi all,

    I got the error too. I wasn't abel to update per tar or img.gz file any more. Due to this I had to do a full NAND install (back to 8.2.5). Maybe it's an additional error?

    However, I succeeded. And I installed your pr3080 distribution. And ... taterata ... sound is fine. :) The noise is gone. I tested by playing a lot of tv channels and videos I had on my box and HD.

    But kodi crashes all the time. After at least two days I've a kodi safeboot screen. :(

    Also during my tests the whole box crashed and I had to reboot two times.

    Best regards


  • Is Wetek1 box with this latest LibreELEC compatible with external dvb-t2 usb yet? I have Mygica t230 that works with other Amlogic s905x box.

  • In addition to the constant crashes in kodi in version v8.90.006 when power off the box does not turn off.

  • Hi tnds82,

    I totally agree. In case I want to restart the box it shuts down and hangs. Due to this I have to power off the box to see the wetek play logo and to trigger a boot process.

    Regards Holger

  • Hi,

    I also tried the pr3080 file and the sound problem seems fixed.

    As I am running LibreElec on a SD card on my wetek Play 1, I did not install the whole image, but I only replaced the kernel and SYSTEM files and their corresponding md5 files on the SD card. I noticed that the kernel files on the SD card were named kernel.img, while they did not have the extension img in the pr3080 archive. I used a linux computer to rename and replace the files on the SD card.

    I can confirm the shutdown problem on my two wetek play 1 boxes. Thus, I pull the power plug to turn them completely off. One of the boxes restarts without problems after pulling the power plug; the other however, does not start anymore after pulling the power plug: I have to first put the SD card into my linux computer and run a fsck over it to make it work again. I suspect that it does not boot up without the fsck because the filesystem is not in a clean state after pulling the power plug; but I don't know yet how to change it (probably disabling journaling or something similar...).

    In any case, thanks for the sound fix.

  • @pawntheb

    As far as I know, the wetek play 1 box is not a s905 box; its SOC number starts with the digit 8. (I don't remember the exact number at the moment.

  • I forgot to point out, that the shutdown problem already occurred before the sound problem fix.

  • Hi,

    i'm getting a bug which restarts kodi. Black screen, mouse pointer in centre then kodi restarts and does its usual libary refresh which is how i know it did restart and not just a glitch with the video.

    My system: Host CPU: AMD Ryzen 3 2200G with Radeon Vega Graphics, 4 cores available. Which is why i need a 4.18 kernal and hence running the alpha, since i'm running the alpha i might as well be useful and report bugs but i don't normally so you may need to talk me through test you want me to run if its semi-complicated.

    Basic system setup:

    Freenas stores all media and mysql for library, access over LAN via wired switch and through separate pfsense box.

    I don't think its relevant to this problem as the system has no problem with paths or playing other files its just certain ones.

    Below is extracts from the crash log.

    1. ############## kodi CRASH LOG ###############
    2. ################ SYSTEM INFO ################
    3. Date: Sun Nov 11 09:35:19 AEST 2018
    4. kodi Options: --standalone -fs
    5. Arch: x86_64
    6. Kernel: Linux 4.18.11 #1 SMP Sat Oct 6 21:17:25 EDT 2018
    7. Release: LibreELEC 8.90.006
    8. ############## END SYSTEM INFO ##############
    1. [Thread debugging using libthread_db enabled]
    2. Using host libthread_db library "/usr/lib/".
    3. Core was generated by `/usr/lib/kodi/kodi.bin --standalone -fs'.
    4. Program terminated with signal SIGSEGV, Segmentation fault.
    5. #0 0x00007ff33f826d37 in ?? () from /usr/lib/dri/
    6. [Current thread is 1 (Thread 0x7ff2b7fff700 (LWP 1241))]

    The end of the log, last part of restart shows end of library scan then attempt to play file:

    The file is a x265 (once again reason i'm needing the new kernal in this alpha build)

    this is a 1080p, it also crashes with other files too.

    below is bottom of log from other files that crashed it.

    Let me know if you need a full crash log