Early community images for H3, H6 and A64

  • My Monitor does not have speakers, but connected via hdmi to my AVR i do not have sound or picture.

    Check if you have digital HDMI output selected in settings. It should be by default, but you never know. If you still have issues provide output of edid-decode /sys/class/drm/card0-HDMI-A-1/edid with AVR plugged in.

  • Here is the Output connected to the AVR (The output of HDMI analog) :



    The other available out put "HDMI allwinner":

    On both settings neither sound nor video.

  • Hi jernej !

    Thank you for your great work.


    Is it possible to have an image of Librelec for the OrangePi Lite2 (H6, 1GB ram) ? I use a USB dongle for ethernet so, I don't need wifi driver. My USB ethernet dongle work fine with the last WIP image of Armbian (kernel 5.0.6).


    I don't know if it's possible, but if I don't ask I will never know...


    Thank you !

    Libreelec : Odroid C1+ ; Odroid C2 ; Raspberry Pi 1, 2, 3 ; M8S-S812 ; A95X-S905X ; GT1-S912

    Divers : Xiaomi mi box ; Rock 64 ; RockPro64 ; Minix U9-H (x2); Orange pi pc ; Orange pi pc+ ; Orange pi one

  • Da Alchemist

    Second one looks good, so I'm not sure what is going on. Could you also show output of cat /sys/kernel/debug/clk/clk_summary?


    mike2002

    Not yet, because kernel has only basic DT and some HDMI related stuff is not yet in. I also don't have the board, so I can't prepare patches in advance.

  • Here is the output:

  • Hi guys! Has anyone already installed the image on Orange pi 3? Interested several moments. Is work audio on hdmi? What screen resolution is supported? Is there mali support? Has anyone transferred the image to eMMC ? Thx

  • Stumbled here and have a pine64a collecting dust and got exited to try! Its the pine64 2gb model and I get no network connection. Therefore I also cannot update over samba/ssh to get Ethernet working.. Steps:


    - Flashed LibreELEC-A64.arm-9.1-devel-20190324123655-b764cb6-pine64.img with Etcher on 32G card
    - boots fine, seems to work but Ethernet does not work (not video tested)
    - Tried to update manually by copying "target" folder containing kernel etc. from LibreELEC-A64.arm-9.1-devel-20190324161240-b764cb6

    still boots fine but no Ethernet (cabled)

    The LibreElec first boot wizard shows no networks available and in Settings->LibreElec->Network->Wired Networks i cannot activate. Screen flashes and returns to off position...

    Hope its a simple issue, didnt read it in this topic before :)


    edit: also my other pine64's running armbian, using a usb wifi.. Also doesnt work or respond to the OS.

    edit2: Im also running pi-hole on the network, never had any issues... Maybe a DHCP issue or similar? idk

  • boatfreak just do a warm reboot (without pulling the plug) and ethernet should work. I didn't find the reason for this issue yet.


    ilchenko currently there is only PineH64 image for H6 which is incompatible with OrangePi 3. You'll have to wait until it gets supported in kernel and U-Boot, but that should be soon (Google Groups). Of course GPU works or Kodi wouldn't run. HDMI audio works up to 8 channel, but no pass through. Currently maximum supported resolution is up to [email protected], but in the future will be [email protected]


    Da Alchemist currently I'm clueless what's wrong. But note that I'm still working on HDMI driver and it's possible that future improvement will fix the issue. I think I already added some HDMI related fixes after latest image was built.

  • ilchenko currently there is only PineH64 image for H6 which is incompatible with OrangePi 3. You'll have to wait until it gets supported in kernel and U-Boot, but that should be soon (Google Groups). Of course GPU works or Kodi wouldn't run. HDMI audio works up to 8 channel, but no pass through. Currently maximum supported resolution is up to [email protected], but in the future will be [email protected]

    thank you for your very detailed answer. we will look forward to the development!

  • I think I just fixed the issue. Can you try this update: libreelec-a64.arm-9.1-devel-20190409201638-f117832.tar ?

    Thanks for the update! But the problem persists. Steps taken:
    - flashed a different SD card with mentioned image
    - updated with your file

    - no internet, rebooted (all cables connected), still no internet

    Here is the log (boot -> network setting check -> shutdown)

    Cables etc should be good, they have been running my RPI kodi.
    Anyone else with the same issue on pine64 2gb?

  • I have just tested an image for the H3 (OrangePi Pc+), it is working with sound and video on the same AVR the PineH64 does not. The best, i can run speaker-test up to 8 channels pcm with 192kHz S32_LE! That is awesome, hope these patches will make it to mainline (could not find them on an Armbian Image build yesterday)

  • Hi there, I'm using the latest build for pine64 plus with the latest update provided.

    I can't seem to see the WiFi + BT module in libreelec: PINE64 WIFI 802.11BGN/BLUETOOTH 4.0 MODULE – PINE64

    It suggests that the chipset is RTL8723BS.

    Is it possible to have this driver included in one of your builds if it isn't already?

    I updated using LAN over samba share.

    The SSH login kept asking me to reset the SSH password as "it had expired" it would proceed to change the password, log out I'd log back in for it to repeat credentials had expired, did this 3 times before giving up on SSH login.

  • thefulla

    wifi driver is actually included, it's just not enabled in DT. Issue here is that board comes without wifi and thus it should not be enabled by default. Addon boards should be handled by DT overlays (something like it's done on RaspberryPi), but nobody took time to implement such mechanism yet.


    Bluetooth is low priority so it's not implemented for any board. IIUC, RTL8723BS bluetooth needs some patches which are not in mainline kernel yet, but it's being worked upon. However, even if they would be included, you still have same issue as before with DT overlays.

  • 2 questions:


    1- There is still no way to install it in the emmc no?

    2- Does the RTL8189ETV wifi work?


    Edit: I just reread, op. So the questions respond.


    Edit2: Is there the possibility of porting the "emmc_install.sh" script soon? I would like to test how it goes in emmc libreelec9. But there is no clear problem.


    My device is a beelink x2

    Edited once, last by mega-samu ().

  • Allwinner project has been recently merged in LibreELEC master repository.


    This brings following changes:

    1. Nightly builds will follow soon. They will overtake a role of images/updates linked in this topic.

    2. While nightly builds are not supported, I still appreciate a report for an unknown problem (I'll make a list of known issues soon)

    3. Images and updates linked here will not be updated anymore

    4. H3 nightly updates won't be compatible with builds linked here due to missing kernel feature (but A64 and H6 updates are fine)


    Now we have a chance for stable, officially supported Allwinner images when LE10 is released. Until then, there is a lot of work to do.