Early community images for H3, H6 and A64

  • Orange pi pc

    There is a lot of information search in google orange pi pc s/pdif output

    Sorry to disappoint you, but unless you edit DTB file yourself that won't be supported. DT overlays aren't supported currently, but maybe something can be done with configfs on linux if you want to play with it. DTB files are overwritten during LE update.

  • Thanks for your suggestion, unfortunately made it no bit better...


    If I connect a hauppauge dvb-t dongle to the raspi it works perfectly out of the box, but not with the beelink :(

  • lumpi Can you test this update: libreelec-h3.arm-9.1-devel-20181226132840-f58e089-beelink_x2.tar


    MAC shouldn't change anymore after reboots.

    Unfortunately it's still changing:

    wondering what will happen once the lease table of my router is full :-P


    Is there anything I could try for you? I suppose the MAC must be stored in some EEPROM, let me know if I should read it out or anything like this.

  • Still fiddling around with my remote


    I stopped Kodi and Eventlircd, then I startet Eventlircd in verbose mode by hand:

    Code
    1. LibreELEC:~ # /usr/sbin/eventlircd -f --evmap=/etc/eventlircd.d --socket=/run/lirc/lircd -vvv

    it throws a couple of messages at me:

    Code
    1. eventlircd[752]: /etc/eventlircd.d/default.evmap: using 0 valid keyboard shortcut mappings
    2. eventlircd[752]: input device /dev/input/event0: events of unsupported event type EV_MSC will be discarded
    3. eventlircd[752]: input device /dev/input/event0: event code 0x04 of unsupported event type EV_MSC will be discarded
    4. eventlircd[752]: input device /dev/input/event0: events of unsupported event type EV_REP will be discarded
    5. eventlircd[752]: input device /dev/input/event0: unable to open event device: No such file or directory

    which might lead to the onclusion, that the wrong event input has been chosen, but ir-keytable can work with it:

    Code
    1. LibreELEC:~ # ir-keytable
    2. Found /sys/class/rc/rc0/ (/dev/input/event0) with:
    3. Name: sunxi-ir
    4. Driver: sunxi-ir, table: rc-empty
    5. Supported protocols: other rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp
    6. Enabled protocols:
    7. bus: 25, vendor/product: 0001:0001, version: 0x0100
    8. Repeat delay = 500 ms, repeat period = 125 ms

    is anyone of you successfully using a remote with an H3 based device?

  • Ok, that is very strange. Can you burn clean image and do this before first boot? Just to rule out any issues with saved settings.

    inserted card to pc

    backup the storage and other files found on fat.

    burned 20.12.2018 file to card

    edited config file,

    ejected card (clicking the eject on windows to have it synced propelly)

    moved card to opi pc

    start up

    it started created initial config things

    restarted went into libreelec and done first startup thing

    restarted 6 times untill got 1080p resolution


    i have noticed however this odd error on startup "bad crc while load from fat" it anyways work the /storage without any problems from fat... ??!?! look picture

    EDIT: Tried other SD card to be sure is not card issue.. same thing, bad crc..

    Edited 2 times, last by riku ().

  • trying more stuff:


    plugged in dvb-t stick and thanks to jernej its now found and active, also as a IR receiver:

    The dib0700 looks exactly like in my laptop, where the hauppauge remote and the asus remote work, but still no luckon the H3


    Then in the debug log it says something weird:

    Code
    1. 19:11:34.485 T:3011515552 DEBUG: libinput: event1: device is ignored
    2. 19:11:34.486 T:3011515552 DEBUG: libinput: event0: device is ignored
  • i have noticed however this odd error on startup "bad crc while load from fat" it anyways work the /storage without any problems from fat... ??!?! look picture

    That's normal. That just means that U-Boot will use default settings which is exactly what is wanted. If you would save U-Boot environment, this message wouldn't appear. Granted, it's more scary than it should be. It should be something like "Using default envitonment"...


    Can you test with another H3 board?


    lumpi I tried another thing for IP address changes. Please update with this: libreelec-h3.arm-9.1-devel-20181226203321-a85ff24-beelink_x2.tar


    I'll check IR settings again, maybe I missed something.

  • jernej the mac is now stable at 02:81:C6:43:2F:67 - a big thanks!


    The original MACs are:

    ETH CE:EC:35:0A:81:BA

    WLAN A0:2C:36:4A:D0:1E --> belongs to FN-LINK TECHNOLOGY LIMITED

    The Ethernet, as well as the LE MAC are locally administered MACs, seems only the WIFI module manufacturer got his job done ;-P


    So this case is closed for me :)


    Dont ruin your christmas over the IR issue, for the moment a mouse on a too short wire has to solve the immediate need for control :)

  • Can you test with another H3 board?

    you know what, i just made myself very stupid, on other board there is no edid issues at least with 2 tv:s tested, other tv i even counted reboot 10x times without any issues. it seems you where right about static thing... very odd is the board is couple year old(been sitting around unopened) but i opened box just few days ago... it was like that from new so that it might be expected from boards like that price.. and the working opi pc is couple year old there been using. even has alot dirt on it because fan lol.

    tried also cec, and same issue with it so that was not any better, but it definitely resolved this edid crap.. very odd thing is forcing resolution was no able to fix it, so only way is keep opipc on or use it on other things where hdmi not needed.

    still going to test more tv:s, i guess it still will work.


    all of this started because i promised my 4y old daughter to install tv on room at the wall, i took precaution and started to see if cec worked on wanted tv, well no, so tested many tv:s and well here i am testing this.. (my daywork is install tv to clients, thats is because i have huge amouth old tv laying around) still im unsure with i going to install, as cec not work, maybe just use lirc :) but i keep testing, i want this to stable main/line. for sure i will replace my second tv usage with this testbuild and test it out for everyday usage.


    also need more sd cards :DDD one even broke on this process, and more boards hehe :) need to see whit one is best value with 1gig ram on this days.


    Also i have posted this post to facebook opi group, and asked ppl for test this build, it has been gathered some new ppl to test it with good results!

  • riku Don't worry, I'm just glad that we pinpointed the issue (hardware). Is your secondary H3 board also OrangePi PC? As I wrote before, I have plenty of different H3 boards (but no OPi PC) and CEC doesn't work on all of them (tested on same TV and kernel). I suspect that HW designers didn't test that and it may or may not work.

  • I just logged in to aliexpress to see date of the order it was Oct. 18 2015. both are orange pi pc and same batch ordered that date 2x of them. other has just been unboxing for 3 years? :DD other been on casual use with kodi16(older version libreelec)


    The cec work on that particular tv where i watch with kodi16, but this new release one wont work. this one is just that other board where edid is working, i swaped sd-cards from it. i wont stress this much, as the cec is pain of the ** for real.. of 10 tv:s one is like to work..

  • Don't worry, if I don't feel like solving problems I won't. But currently I want to tackle them

    hehehe same here... just got carried away thinking if I should get a NanoPi A64 or a Pine64 or maybe an Orange Pi PC SET2 to play :-P ut then there is also the RK3399 and rock64 i wanted to play with as some kind of a NAS... so many things to do and so little time throughout the year...

    But at least now my dusty X2 got some useful life :)

    Quote from jernej
    :) Please try this update: libreelec-h3.arm-9.1-devel-20181226213819-4693356.tar

    I enabled LIRC interface in kernel. Maybe this will solve it.

    same message in log, no luck with irw and Kodi GUI

  • jernej nightowl as am I ;-)


    ok tested it with mixed results:


    just the remote itself still doesn't work, *but* with the hauppauge stick it works pretty awesome


    the Terratec stick has the same problem as the built-in IR (also when plugged into my laptop) and slowly I think there is one problem when the table says: "table: rc-empty"


    for me the short term goal is clearly met, have just to investigate where this empty thing is coming from and how to fix it...


    just one short question, what was now the problem? how did you fix it?