Early community images for H3, H6 and A64

  • Test script for update nightly builds of LibreELEC via SSH, replace pc_plus.tar with your own value.

    If it doesn't reboot, the checksum is wrong.

    Code
    1. cd /storage/.update
    2. URL="https://test.libreelec.tv"
    3. FILES=$(curl $URL |grep 'pc_plus.tar' |cut -d '"' -f12)
    4. for FILE in $FILES
    5. do
    6. curl $URL'/'$FILE -o $FILE
    7. done
    8. sha256sum -cs *.sha256 && reboot
  • Test script for update nightly builds of LibreELEC via SSH, replace pc_plus.tar with your own value.

    If it doesn't reboot, the checksum is wrong.

    Code
    1. cd /storage/.update
    2. URL="https://test.libreelec.tv"
    3. FILES=$(curl $URL |grep 'pc_plus.tar' |cut -d '"' -f12)
    4. for FILE in $FILES
    5. do
    6. curl $URL'/'$FILE -o $FILE
    7. done
    8. sha256sum -cs *.sha256 && reboot

    Quite comfy but well, its a variation of this: Piping curl to s(hell)

  • BTW, if anyone wants to install to eMMC just dd image to it and it should work (works for me on Beelink X2).

  • Btw. did you also look into my toy project with the power button? /shameless hint

    No, not yet. I'm jumping around different tasks as you may noticed. There's a ton of work to do, but not much time. BTW, I wrote deinterlace driver but I couldn't force myself to test and debug it yet :)

  • RTL8188EU driver is already present, except if USB ID is missing. Please provide output of lsusb with dongle connected.


    Sometimes i must be connecting manually

    Edited once, last by hostkit ().

  • No, not yet. I'm jumping around different tasks as you may noticed. There's a ton of work to do, but not much time. BTW, I wrote deinterlace driver but I couldn't force myself to test and debug it yet :)

    I admire your persistence i wish i could invest as much time n energy.


    Is the deinterlacer already in any image? I felt there is much less tearing since my last update a while ago.

  • Bus 005 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.


    RTL8188EUS 802.11n Wireless Network Adapter

    Seems to be the standard VID:PID combination for this card, so if the driver is there it should work...


    Edit: didn't mean to give meaningless answers, just meant to cut the long output from above short :-)

    Edited 2 times, last by lumpi ().

  • Bus 005 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.

    I just checked and yes, it should be supported. Check if output of lsmod lists 8188eu. If not, run modprobe 8188eu and test again. After all that, please provide output of ifconfig

  • Is the deinterlacer already in any image? I felt there is much less tearing since my last update a while ago.

    No, driver sits untested in my local repo on laptop and awaits better times :). Seriously, there's a ton of work to do before this will work, including extending ffmpeg and Kodi.

  • I just checked and yes, it should be supported. Check if output of lsmod lists 8188eu. If not, run modprobe 8188eu and test again. After all that, please provide output of ifconfig

    lsmod 8188eu exist

    But i don't know, why its sometime not load (unable auto connect), maybe adaptor?


    Another device connect with same wifi

    Edited once, last by hostkit ().

  • Hi jernej , I just received an opi plus 2e and I want it to work on a monitor with dvi input. I had an opi pc connected to this monitor with libreelec 7 and I had to modify the script.bin to make it work. Now with your new images I don't know how to do it. By hdmi, on a tv works correctly.


    Thanks


    I'm sorry, it was my mistake with the cable. This message can be ignored.

  • mpeg4 ?

    No, while writing support for it shouldn't be hard, base is still in flux. A lot of work is going on to stabilize request api in kernel. Until this is more or less done and most bugs are fixed in existing codecs (H264, H265), I won't work on additional codecs. But maybe someone else will.

    If it is possible to improve without hardware acceleration h265 10 bit

    None that I'm aware of. H6 is already capable of decoding 10-bit H265, but for some reason top left corner is corrupted during each 10-bit H265 video playback.

  • lumpi ah, you are on old image... Actually I mentioned the issue, but yes, that's the one. Copy files manually in that file and repeat update again to update few missing things.


    BTW, new images use kodi 18.2-rc1 so some things like addons probably need to be updated