Netflix

  • Hello everyone !

    I tried to install the Netflix plugin by doing what follows :

    1. Add the Netflix Addon repository

    2. Install the Netflix plugin with dependencies

    3. Install the latest inputstream addon

    When I launch the Netflix Extension, I enter my email and Netflix password but then I have an error that it cannot log in (I am 100% sure that my login informations are correct).

    I am on X86_64. Can anyone help ?

    Thanks !!!

  • Provide more about the error message what is it and put your logs to be able to help you

  • Have a look here.
    Maybe you could try to enter your login info by getting into the add-on settings and see if it works

    Netflix Add-on [input-stream]

    Edited once, last by stark ().

  • Have a look here.
    Maybe you could try to enter your login info by getting into the add-on settings and see if it works

    Netflix Add-on [input-stream]

    Thanks ! That worked. At first launch if I enter login information that does not work but if I go into settings, set the login information then launch, it works. Thanks also spiderfish for your reply.

    It does not matter but just to let you know that the login name is not displayed in settings, probably a small bug.

    Have a nice day and congratulations to the developpers !

  • Okay i cant seem to get this to work propertly.


    1. I have a raspberry 2 with the latest libreelec build 18.1 leia.

    2. I have downloaded the latest netflix plugin 0.14.0-BETA23

    3. Ive installed the plugin and enabled inputstream v.2.3.15.0

    4. I have entered my login details and are able to login and view every netflix library


    This is where it gets tricky...


    5. When I select a movie to watch it popups (like it should) "Widivine CDMs required" so i press "install Widevine". Another popup about Widevine popups and i press "YES" followed by "Widevine CDM EULA" which i press "I accept" on.

    6. Then it starts to download the "chrome OS recovery image" which takes some time..when its finally done it fails the playback so i reboot and return to step 5.


    Now im in a loop allover again with the Widevine and I cant seem to get around it. Any suggestions?

  • i do get it to work on my desktop htpc, but cant figure out how to get that Widevine CDM to work on my rasp with libreelec..any tips?

    Edited once, last by optimizer: OK! Got to work, was the unpacking of the file taking alot of time! ().

  • Has anyone got Netflix working on libreelec at the moment?

    It used to work fine for me but I haven’t been able to find a working configuration for ages.

    I’m running libreelec 9.0.2 on an asus chromebox and am trying all manner of different Netflix builds but nothing is working.

    Anyone know?

  • Has anyone got Netflix working on libreelec at the moment?

    It used to work fine for me but I haven’t been able to find a working configuration for ages.

    I’m running libreelec 9.0.2 on an asus chromebox and am trying all manner of different Netflix builds but nothing is working.

    Anyone know?

    The version from this repository is the most current one and works for me without any issues: repository.castagnait-1.0.0.zip

  • may I know what widevine version should I manually download for s905x? when using the automated, it can't fully download so I'm looking to download widevine first on a pc.


    widevinecdm.json

  • Hi everyone,


    I have a Rpi 2 model B, I just installed Libreelec 9.1.

    And I added the netflix plugin.

    I entered my email address, my password. I now can see the users, and for each of them the latest programs seen, the selection,..

    But when I launched a program, I'm asked to install widevine, I accept and it fails quite quickly.

    I'm trying since yesterday. The first times I had to accept the EULA, but now I don't reach this step.


    The kodi.log file is in attachment.


    I have downloaded manually the 2 files that seem to be the problem:


    recovery.conf

    1.4.9.1088-mac-x64.zip


    and I got them without worry. So I don't understand why the plugin can't find them.


    Does someone knows what I could do to solve my problem?


    Best regards.


    Edit : in fact it seemed I had a not reliable internet connection, so the download was probably interrupted each time I tried to get the widevine.

    I tried again, and it worked. Everything's fine now, thanks a lot for all the solutions on this forum.

    Files

    • kodi.log

      (37.5 kB, downloaded 36 times, last: )

    Edited once, last by xav42: Solved problem ().