Netflix

  • Hi all,


    I just installed LibreELEC-RPi2.arm-8.90.004.img.gz, InputStream, Netflix Repository and at the end Netflix Addon.

    After logging in and seeing all of my profiles and movies I tried to play one of them and was asked to install widevine cdm module which is 2Gb and after downloading I saw that is will be extracted and eventually saw success message.


    The problem is that when I try to start then any movie it's showing me loading circle two times and then comes back to the addon without starting movie.


    What can I do to resolve this issue?


    Thanks in advance.

  • The latest widevine needs a newer version of inputstream.adaptive (2.2.27), we fixed this last night inputstream.adaptive: update to 2.2.27 · LibreELEC/[email protected] · GitHub) but it could take a bit until the addon is rebuilt for all architectures and available from the LibreELEC addon repository.


    In the meanwhile you can download inputstream.adaptive 2.2.27 for RPi2 from here inputstream.adaptive-2.2.27.0.zip and install it manually.


    so long,


    Hias

  • RPi2 and RPi3 use the same build - the addon I linked to will be fine for you.


    I tested it yesterday evening on my RPi3B+


    so long,


    Hias

  • Hi,


    since a few days, Maxdome and SkyGo addons both stopped playing content on my Pi 3B+, so I tried to install your new version of the inputstream adaptive addon. But I only get the following error message:

    ERROR: CAddonInstallJob[inputstream.adaptive]: The dependency on kodi.binary.global.filesystem version 1.0.2 could not be satisfied.


    I'm still on 8.2.5, fwiw.


    Thanks...


    Dirk

  • OK, after updating the system to 8.90.004, the addon update also worked. It then also automatically updated the widevine CDM and after another reboot both Maxdome and SkyGo are working fine again.


    Bye...


    Dirk

  • Hi

    Sorry for the noob question. how ever I am at my wits end over this netflix addon.
    I am on a pi 3b, add the repo, try to install the addon but no go

    dependency issue with crypo "something"....

    Any and all help would be much appreciated

  • Is it possible to install widevine manually? Or will it be installed via the inputstream.adaptive addon?


    I downloaded the following files and placed them under .kodi/cdm, but can't play anything (should I use 32 or 64bit?)

    1.4.9.1088-linux-ia32.zip

    1.4.9.1088-linux-x64.zip


    edit: I installed the netflix addon and let this deal with all widevine stuff. it's working now!

    Edited once, last by wardw ().

  • Hi,


    How did you install the netflix addon? I downloaded the plugin here:


    GitHub - asciidisco/plugin.video.netflix: Inputstream based Netflix plugin for Kodi


    Then I noticed that widevine and inputstream were included as well.


    Unfortunately I get this error when playing content:


    In /storage/.kodi/temp/kodi.log:


    14:52:46.857 T:1793033072 NOTICE: Creating InputStream

    14:52:46.884 T:1793033072 ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.adaptive/

    14:52:48.336 T:1793033072 ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/storage/.kodi/cdm/libwidevinecdm.so)

    14:52:48.336 T:1793033072 ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed

    14:52:48.338 T:1793033072 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/?action=play_video&info...


    Is the file there?


    raspberry:/usr/lib/kodi/addons # ls -lh

    total 0

    drwxrwxr-x 2 root root 116 Aug 31 12:50 peripheral.joystick


    Nope! Where is it?


    raspberry:/ # find / -name inputstream.adaptive

    /storage/.kodi/addons/inputstream.adaptive


    Can I create a symlink?


    raspberry:/ # ln -s /storage/.kodi/addons/inputstream.adaptive/ /usr/lib/kodi/addons/inputstream.adaptive

    ln: /usr/lib/kodi/addons/inputstream.adaptive: Read-only file system


    Nope!


    I don't know any way of mounting it read write and make the symlink, or how to tell kodi that the plugin is in a different location. Do you have a /usr/lib/kodi/addons/inputstream.adaptive?

  • Hi all, also installed latest alpha and Netflix addon. Works just fine on my RPI2 (at 480p). Keep being impressed with the power of this little device with LibreELEC and KODI. WoW. Thx all.

  • Hello everybody,


    I am experimenting the same error as mihailstacanov when trying to use Netflix:

    "The problem is that when I try to start then any movie it's showing me loading circle two times and then comes back to the addon without starting movie."


    I am running LibreELEC-Kodi on a 'dot s' netbook by Packard Bell. I installed the latest version of LibreELEC, inputstream.adaptive and the Netflix add-on.


    Could somebody, please, give me some hints about how to fix this problem?


    Thanks

  • I am looking for *banned* add-on on kodi app. The site is available here ** link deleted ** Is there another option better than this ??

  • I just want to add some information about "Netflix on Raspberry Pi" that had be perplexed for the last couple of days


    I had both "Allow hardware acceleration - OMXPlayer" and "Allow hardware acceleration - MMAL" enabled


    And that's enough to stop Netflix video - audio works, with no video


    Disabling "Allow hardware acceleration - OMXPlayer" and now Netflix works fine

  • Hey guys, how are you?


    Well, I'd like to know why the default language for both audio and subtitles is German, and what should I do to:


    1- Make the default language whatever is the original one and make it always 6 channels.


    2- Change subtitles default status to ON and its language to Brazilian Portuguese.


    I'm very thankful for the addon, and it mostly works pretty great. This isn't such a big deal, but it can become annoying having to change language and subtitles each time you start a new show, specially if you're binge watching.


    By the way, I'd like to report a minor bug too: Brazilian Portuguese, which is coded as pt-BR, is named as Portuguese-BRETON, in the subtitles choice menu.


    Thank you very much,


    M.


    PS: I'm using the latest LibreElec (9.0.0) and the latest Netflix add-on (from the default Netflix repository)

    Edited 2 times, last by Morguito: Additional info ().