Google Chrome addon no audio

  • Sorry had a copy paste error...

    it is meant to be

    chrome_OPTS="$chrome_OPTS --alsa-output-device=plughw:x,y"

    and not

    chrome_OPTS="$chrome_OPTS --alsa-output-device=--alsa-output-device=plughw:x,y"

    Hope you see that in time

    Lenovo M73 tiny
    8 Gig Ram
    650 gig snail slow hard drive
    LibreELEC v.9

  • Tried many suggestion, going into terminal and modifying chrome start script.

    Finally got the audio with Chrome by going back with all default and simply go into the Chrome Add-On Configuration page :

    1) Enabled "Use Custom Audio Device"

    2) -Audio Device : plughw:0,3

    Card0 and device 3 was my hdmi output from my NUC7CPYH...


    And no need to disable the "Keep audio alive" in Kodi Audio settings..


    Hoping that this config is kept when Chrome gets updated... ?

    Edited once, last by Ti-Paul ().

  • Nice...i always saw this field to put stuff in, but never found the correct wording/format that was expected in there...

    Lenovo M73 tiny
    8 Gig Ram
    650 gig snail slow hard drive
    LibreELEC v.9

  • I've run into the same issue using final LibreElec 9.0,

    no sound on 2 different devices, one NUC, one HP Mini.


    "Use Custom Audio Device = plughw:0,3" ... was the fix.


    The script was already stopping pulse audio:

    systemctl stop pulseaudio


    This worked just fine in 8.2.5 using Chromium instead of Chrome.


    Thanks!

  • i have same problem with alsa sony tv hdmi 1. How might i format it correctly? I take it these settings are located in Chromium add on configuration ?

  • I have this problem using Intel NUC but I don't know absoluty nothing about program codes.


    Can anyone tell me pass by pass to change the configs on System Tools?


    Thanks

  • Check out post #20 above as it has all you need there I think. If it's unclear maybe ya need a step by step or ?

  • Check out post #20 above as it has all you need there I think. If it's unclear maybe ya need a step by step or ?

    I dont know what happened. When I writed the last post I made what post #20 said but doesn't worked. I tried again now and the audio is working.


    Thanks you so much all!


    The soccer match I want to watch in this week only be transmitted on Facebook. I want to watch this in my living room but my TV is LG and don't have Facebook App and Facebook website don't open on native browser. The last alternative I have is use Chrome Addon on Kodi to open the Facebook.


  • sorry my english i am using google translate. I have the problem of the absence of audio. I did as in the post. But I don't understand what I should write for my configuration in "audio device" I'm using a usb dac on a normal pc. Thank you

  • To identify 'what' the device 'numbers' should be, see my post, but you'll need to know 'how to' log onto the device/PC using SSH (or be able to login directly if using a generic Linux installation): Sound problem in Chrome

  • i have had this issue on a couple of different laptops and the way i got it to

    work is go in to chrome add-on setting and turn on custom audio device

    use code default:CARD=Generic_3 change the number to your device number it will be _1,2,3 ect

  • hello

    keen to get this working on my NUC too.my devices are:


    **** List of PLAYBACK Hardware Devices ****

    card 0: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

    Subdevices: 0/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]

    Subdevices: 1/1

    Subdevice #0: subdevice #0


    None of these card\device combos work.


    In Audio settings

    ALSA:HDA Intel PCH, MJI marantz-AVR on display port#0


    Any ideas?


    cheers

  • The 'plughw' solution works instantly on some sites, but requires many refreshes on others - there must be one small thing I can do to make it work first time for most sites


    Hey champions, I've been meaning to ask this for ages...

    I got some luck out of the above method of turning on 'use custom audio device' and adding in the info 'plughw:'


    In this case 'plughw:0,3', which i found after great effort trying many combos.


    The thing is...IT WORKS, but to get it to work on many key sites, you have to refresh the page many times.


    I was hoping for some guidance on this - I reckon there must be a fix for this that makes it work every time.


    EXAMPLES:


    It works on this site almost every time, first go:

    Watch the latest international news top stories and headlines - France 24


    But on this site, you often have to refresh the page five times or so:

    Planet America : ABC iview


    There must be a way to make it work on the second site as well as the first site.


    Chrome 9.2.0.101


    (I know this addon is not updated but I actually use it EVERY SINGLE DAY, and prefer using Kodi and Chrome to watch online TV over my own Android TCL TV interface, which they have also tried to update with advertising.)


  • I've had the same experience. I found that Youtube usually works first try so I go there first then on to TV sites. Sometimes nothing gets the audio motor running and I have to close Chrome and start all over. I know it's hokey and frustrating but eventually it works. I'm hoping that LE10 will address the problem and fix once and for all.

    RD