Slow library

  • hi there
    After a couple of installations of OpenElec on Rpi and Rpi2 I moved to the LibreElec. First was an upgrade from OpenElec. Everything seemed to be OK. It ran smoothly and without crashes. Few weeks ago I tried to make my first clean install of Libre. I added some favorite add-ons and build the movie library, which is really huge (thousands of items). I noticed the big slowdown of moving in the library. The movie thumbnails load very slowly. When I release the arrow button, the movement in the library advances very slowly for a long time. Movie by movie. Currently I am working on the second attempt with another card (same type), but it looks similar. The second issue is, that I noticed speed (frequency) wavering (fluctuating) sound at the beginning of all the movies I tested. (it sounds like a stretched-out audio tape)
    I did not notice such issues on the older installations. The size of the library was very similar.
    BTW, I am still using the same type of micro SD cards (SanDisk 16GB, class 10, UHS-I from China - SDSQUNB-016-GN3MN)
    I have been searching the internet for a long time, but without success. Please help.
    Many thanks.

    Edited once, last by dvovla ().

  • hi,
    i have some problems as you.i was on openelec 6.0.3 (isengard) and everything was good: fast and all runing well.
    Then i discover Libreelec and install it on Rpi 3 with 32 gb scandisk extreme first alpha version and it was so slow but i tought because alpha build.
    After many fresh install on different micro sd card (bought 2 (16) (32) ) it stills the same even with the last alpha 4.Wondering if i have made something wrong but i think (i am sure) no! then i return on 6.0.3 version and miracle runing fast again. When i saw your message i decide finally to ask THE question in the forum wich is : is Libreelec enough for Raspberry users or is it just because the program is to heavy for the Pi?
    I have tried the Jarvis 16.1 (7.00.2) and it is the same , very slow.
    Is anybody can explain why for exemple it takes 20 sec.or more to download Yahoo wheater, more than 9 min. to have the full scan with Artwork downloader, no way to get something in You tube before 5-7 min., opensubtitles same..etc...

    I am running on Pi3 ( i have 2 and it is same ) ethernet wired. logitech k 400, usb hub powered 220/5V (dongle is on it) scandisk 32gb extreme pro (not a fake one), temperature between 36 and 50 C°, alimentation 220/5V 3000ma ,..... all good stuff
    I have also tried to use another skin but sorry.. it stills so slow.

    I don't want to be offensive or unpleasant but i look every day here in the forum what happend and see that no one has talk about this problem . Is the Libreelec "program" too "heavy" for the Raspberry?

    Thank you to answer and very sorry for my language i don t speek good english.


    Am i the only one, it doesn't seems so.

  • Same "problem" here. LibreELEC, both Jarvis and the Krypton alpha builds (even Milhouse's updates...08/12/2016 is the one I presently have in use), seem sluggish and slow compared to OpenELEC 6.0.3.

    This is on a Raspberry Pi 3.

    I wonder what is slowing it down so much?


  • Hi,
    Why is it no answer from DaVu or another person who can just explain if we have to set something special...

    • Official Post

    The differences between OE 6.x and LE 7.x are minor so there is no major reason why one should be faster/slower than the other, and as 80% of our installed base runs some form of Pi hardware we'd see a ton of posts if it was a major issue; it's not.

    You need to provide a debug logs via "cat /storage/.kodi/temp/kodi.log | paste" and share the URL after a clean boot and some exhibition of the problem, or from our perspective there's no problem.

  • Hi chewitt,
    I hate to disagree with you on this point but the difference is quite noticeable. Addons take a lot longer to open up. My setup, meaning addons installed, on both OpenELEC 6.0.3 and LibreELEC 7.90.004 (augmented by Milhouse's 08-12-2016 upgrade) are identical (though I did install the Confluence skin in 004). The same problem persists even running Jarvis 16.1 (7.0.2) on either Pi2 or Pi3.

    I'll have to learn how to provide a debug log via "cat /storage/.kodi/temp/kodi.log | paste" before I can post it, but I will get around to it when time permits so bear with me.

    Thank you for your time.


    Edited once, last by Trespasser ().

  • 1. Does database cleanup after update do any difference?
    (Built in or by using script.database.cleaner or similar)
    2. Do You have any possibilities to put Your DB in MySQL/SQL server?
    Just curious because I don't see any signs of slower system on any of my RPi2's or RPi3's...

    => Just my 5 cents...


  • hi,

    i have made a new fresh install yesterday with a new LibreELEC-RPi2.arm-7.90.004.img.gz and add only 4 movies imported from my PC with smb , updated the library , no settings in the conf.txt to let it clean as original set up (so 600-1200 mhz) and i have to inform both here in this trhead that it runs slow.
    If it is a question of no trust, take a chronograph and compare only ONE thing: - install Yahoo Weather with LE 7.00.4
    : - "" Opensubtitles "" "" """ ""

    Then do same with OE 6.0.3 ......and tell here the results.

    Also the fanarts do not appear fast when you go in the library ( Films or Vidéo Shows)
    As i know these 2 add ons are official.

    Hope to find something else than ( we'd see a ton of posts if it was a major issue; it's not. ) from  chewitt

    Thanks all ,have a good day.

  • Logfiles?

  • Same problem here, even after a fresh install. Local libraries are loaded in no time. As soon as libraries of online addons are about to get loaded it takes ages. Sometimes it even returns an error due to a timeout.

    Here is my Log link:

    • Official Post

    Here is my Log link:

    sorry no support possible