LE 8.2.5 with UHD 630 / Coffee Lake / Gemini Lake support and luks

  • If its just for Libreelec, do NOT buy a J5005 board

    The problem is NOT fixed, and it does not look like its gonna be fixed soon...

    I have been trying all sort of solutions mentioned here and in other forum topics, nothing works.

    Me, personally, i dont mind, BUT for most people this can be very annoying... And suggests a serious underlying issue...

    Avoid J5005...

    I am insane! My mother had me tested.

  • Hello again,


    So I investigated a little bit more regarding this issue in thread I linked before:


    108085 – Intel GeminiLake corruption at top of screen caused by fbc


    People helped my check that the drivers options I added by creating the i915.conf config file in:

    smb://libreelec.local/configfiles/modprobe.d

    with value "options i915 enable_fbc=0" inside were taken into account at startup of my NUC as the issue is still there...


    I ran the following command lines (see thread in link above):

    Code
    1. mount | grep debugfs
    Code
    1. cat /sys/kernel/debug/dri/0/i915_fbc_status


    And the result is:

    Code
    1. FBC enabled
    2. Compressing: yes


    This means that despite adding the option file: the option is not taken into account at init.


    So I guess we are close to a solution now...the question is...in libreelec...how can I force the init to take into account the drivers options for Intel drivers?


    Can somebody help me with that?


    I found some tutorials on the internet...but it's for ubuntu...not libreelec:


    16.04 - Setting kernel options for the i915 - Ask Ubuntu


    I'm not sure how to do it with libreelec...

  • 'm not sure how to do it with libreelec...

    The driver is compiled into the LibreELEC kernel. You have to add a kernel parameter.


    Make /flash writable: mount -o remount,rw /flash


    Edit /flash/EFI/BOOT/syslinux.cfg, /flash/syslinux.cfg or /flash/extlinux.conf (depends how your system was installed) and add i915.enable_fbc=0 after the quiet.


    Save and reboot. Check with cat /proc/cmdline that the parameter is set correctly.

    Edited once, last by mglae: extlinux.*conf* ().

  • Hello,


    I just had a look at /flash/EFI/BOOT/ on my NUC...


    Before updating any file I just did a ls on the folder and I don't have any of the files you listed above. I have the follwing files:


    Code
    1. bootia32.efi bootx64.efi grub.cfg ldlinux.e64

    I tried modifying the grub.cfg:

    Code
    1. set timeout="0"
    2. set default="LibreELEC"
    3. menuentry "LibreELEC" {
    4. search --set -f /KERNEL
    5. linux /KERNEL boot=UUID=5C5B-4325 disk=UUID=4053b926-d454-4517-8538-2183f4cd5058 i915.enable_fbc=0 quiet
    6. }

    But then when I rebooted I didn't have the "i915.enable_fbc=0" option when I checked with


    Code
    1. cat /proc/cmdline


    I also checked with other method and unfortunatly the result is still the same:


    Code
    1. FBC enabled
    2. Compressing: yes


    Edit: My bad...I only looked into /flash/EFI/BOOT/ and not into /flash/...


    I found the syslinux.cfg now and I modified the file...


    I let my wife watching her show then I will restart and I will keep you guys updated. :-)

    Edited once, last by Alucard ().

  • I can confirm that this time we have a fix.


    fbc is correctly desactivated and I didn't suceed in trying to reproduce the bug again. :-)

  • nice too see there is ar workaround. When there is a patch for that problem and i dont see it just give me a hint and i will build a version with that patch.

  • some updates ... what was done:


    now with new version numbers and custom update channels see post #155

    and tags on GitHub


    release #190401 download http://sky42.libreelec.tv/release/8.2/ 


    8.2.5-6.5-#190401

    - linux (Generic): update Kernel 4.19.32 (no CrasyCat version so far)

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-6.x


    8.2.5-7.5-#190401

    - linux (Generic): update Kernel 4.19.32 (no CrasyCat version so far)

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-7.x

  • For me ^^^ 7.5-#190401 fixed some trouble with Dolby Atmos Audio not working for all movies with my LSPCon PS176 and my Denon X4500H. Now i can go to use just 1x HDMI for Audio and Video through the Denon to the TV with my Coffe Lake i3-8100 on a ASRock B360 Board. Before i had 1x HDMI 1.4 to Denon for Audio and 1x HDMI 2.0 (DP 1.2 + LSPCOn PS176 firmware 7.85) to the LG TV for Video.


    Edit:

    Sadly not all problems are gone. Now some AC3 tracks won't play. Back to my 2x HDMI config.

  • some updates ... what was done:


    now with new version numbers and custom update channels see post #155

    and tags on GitHub


    release #190418 download http://sky42.libreelec.tv/release/8.2/ 


    8.2.5-1.5-#190418

    - clean build

    - update libpng-1.6.37 fix CVE-2019-7317

    - update openssl-1.0.2r

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-1.x


    8.2.5-3.5-#190418

    - clean build

    - update libpng-1.6.37 fix CVE-2019-7317

    - update openssl-1.0.2r

    - linux (Generic/RPi): update Kernel 4.14.112

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-3.x


    8.2.5-6.5-#190418

    - clean build

    - update libpng-1.6.37 fix CVE-2019-7317

    - update openssl-1.0.2r

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-6.x


    8.2.5-7.5-#190418

    - clean build

    - update libpng-1.6.37 fix CVE-2019-7317

    - update openssl-1.0.2r

    - source is on GitHub - sky42src/LibreELEC.tv at libreelec-8.2-7.x

  • It wasn't until I started upgrading all of the LibreElec units I have (and have distributed to friends/family) that I noticed that 'video acceleration' was enabled for the on-board graphic processors that never had it (and were reaching 99% CPU usage for 4K 'high quality' video streams).


    VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880 [Radeon HD 4200]


    I'm seeing approximately 25-33% less CPU usage (see images) with the VAAPI acceleration enabled.


    BUT, I have also found that the acceleration is DIS-abled after the unit(s) have 'gone to sleep' (suspend mode) and been re-awakened. Only a reboot of the system re-enables the acceleration abilities...


    The problem is sometimes more obvious, with a 'lockup' of the GUI when Kodi comes out of 'suspend mode', with a strange artifact in the middle of the display (see images), and then either a 'reset' of the desktop, or a restart of Kodi (without rebooting), with either action resulting in the disabling of video acceleration.

  • Hi Yubby,

    I see the same thing on my AMD_x64 box. I have a RS880 GPU as well.

    The artifact in the middle is your mouse pointer !

    I could solve some of the problems by using the LibreElec(RR) version form 5Schatten, the artifact is gone now...

    He uses a newer kernel and the newer openGL 19.0.2 Radeon video driver.

    You still have the GPU lockup for 10 seconds after resume, then the softreset kicks in, and the kodi screen is restored to normal.

    I do not know if Harware acceleration is restored too, i don't use it.

    See my post : 'AMD GPU lockup'

  • Hi again Yubby,

    Just tested with hardware acceleration VAAPI 'on'.

    After suspend/resume the acceleration is still EN-abled, but the video screen is black.

    Overlays and sound work like normal, but the video is black. Switching VAAPI 'off' in settings, and the video is O.K.

  • Intel have fixed the Gemini Lake framebuffer compression bug in kernel 5.1.9 - it's now turned off by default.


    changelog-5.1.9: