LE 8.2.5 with UHD 630 / Coffee Lake / Gemini Lake support and luks

  • +++ now with Custom Update Channels, new Download links and Version numbering changed +++

    see the explanation in post #155

    and here you can go direct to the download http://sky42.libreelec.tv/release/8.2/


    +++ these are fairly new and might not be stable +++

    8.2.5-6.x kernel 4.18 for UHD 630 / Coffee Lake / Gemini Lake


    +++ this one should be fairly stable +++

    8.2.5-3.x kernel 4.14 has (for me) working LSPCon/refresh rate fix


    +++ should be as stable as LE 8.2.5 +++

    8.2.5-1.x cryptsetup luks, WPA/WPA2 EAPOL fix


    +++ new testing only version +++

    8.2.5-7.x kernel 4.18



    mirror of download with a full set of files HiDrive

    all my LibreELEC old 8.2.5 files HiDrive



    There are 3 versions and each adds more features/changes and that doesent mean bigger is better just different.



    what was added:

    - 2 hooks for the boot process

    /flash/post-flash.sh (if exist) after flash mount

    /flash/mount-storage.sh (if exist) you can do /storage mount instead of the normal way

    - kernel config for cryptsetuponly for Generic/RPi/RPi2/Wetek_Play

    - package cryptsetup

    - kernel commandline parsing for ramlimit to get SYSTEM loadad to RAM on RPi2 with "ramlimit=680000" in /flash/cmdline.txt

    - for coffee lake many software updates are needed (see below)


    some of the cryptsetup, lvm2 and kernel config was taken from LE 8 Remix git and slightly changed.

    found here

    LE8 "Remix" (Generic/RPi) Emulationstation/Chrome/Spotify PROVIDE LOGS IF PROBLEMS

    I also use the git from 5schatten to get some updates here GitHub - 5schatten/LibreELEC.tv: A bit more OS for KODI



    features tested:

    - truecrypt with "cryptsetup open --type tcrypt /dev/sda6 tcrypt-sda6 ; mount /dev/mapper/tcrypt-sda6 <your mountpoint>" created on OE 5.0 with truecrypt

    - veracrypt with "cryptsetup open --veracrypt --type tcrypt /dev/sdb6 vcrypt-sdb6 ; mount.exfat /dev/mapper/vcrypt-sdb6 <your mountpoint>" created on Windows 10 with veracypt and formated as exfat

    - cryptsetup luks i used to create and mount encrypted userdata

    - i3-8100 Coffee Lake playback works for me with ASRock B360m itx


    features not testet:

    - cryptsetup with loopaes

    - lvm2 (removed)

    - mdadm (removed)



    8.2.5-1.3

    - changed as little as possible

    - kernel config for crypsetup luks

    - cryptsetup package

    - applied init: add sky42 enhancements/bug fixes by MilhouseVH · Pull Request #2689 · LibreELEC/LibreELEC.tv · GitHub

    - 2 boot hooks

    - ramlimit parameter

    - system partition size 1024 MB (need more space for more than 1 LE)

    - WPA/WPA2 EAPOL Fix for wpa_supplicant PR2874

    - Update Intel Microcodes to 20180807

    - build for Generic, RPi (not tested), RPi2, Wetek_Play

    - choose this version if your HW is supported by 8.2.5 and you just want encryption



    8.2.5-3.3

    - based on 8.2.5-1.42

    - kernel 4.14.x

    - kernel config and patches synced from LE master for 4.14.37

    - better LSPCon support

    - better frequency detection of 4k with LSPCon works for me on my LG 55E6D

    - disabled media_build

    - added extra build with CrasyCat dvb driver from 5schatten git as media_build replacement

    - added improve-ir-timeout patches from LE master

    - added Gemini Lake HDMI bug 105887 workarounds (to activate put i915.glkhdmi=2 in /flash/syslinux.cfg)

    - xf86-video-nvidia 390.77

    - xf86-video-nvidia-legacy 304.107

    - build for Generic, RPi2

    - choose this version if your HW is supported by 8.2.5 and you have a 4k TV



    8.2.5-6.3

    - based on 8.2.5-3.42

    - full changelog is in this post #123

    - kernel 4.18.x

    - Coffee Lake Support

    - Gemini Lake Support with v5 GLK HDMI bugfix

    - if you need more DVB drivers the Generic_CrasyCat version is for you

    - Mesa 3D 18.0.x (compile option from LE8 Remix)

    - libdrm 2.4.92

    - libva-intel-driver disabled and replaced by intel-vaapi-driver 2.1.0

    - libva 2.1.0

    - created/added libva1 for compatibility, so that tvheadend42 should work

    - xorg-server 1.19.6

    - created/added xorg-server-1.19.6-sync_pci_ids_1.20.0.patch

    - choose this version if you have Coffee Lake or Gemini Lake hardware (some AMD Vega and Rave APU might work)



    8.2.5-7.3 for testing only

    - based on 8.2.5-6.42

    - LLVM 6.0.0

    - Mesa 3D 18.1.x

    - this is for testing only




    You find all old used/created 8.2.5 patches here HiDrive



    ToDo / Wish List:

    Done: Build a Coffee Lake version with kernel 4.16 und not use i915 alpha features.

    Have a look at network bound disc encryption (NBDE) and enable tang/clevis for encrypted LE boxes with unattended booting.



    My challenging main setup (because my AVR is not capable of 4k and i dont want to buy a new one without HDMI 2.1):

    just upgraded my Streacom FC8 Evo with MH1 Heat Pipes, ASRock B360M itx, i3-8100, 8GB RAM

    HDMI 1.4 connected to AVR Onkyo only for audio

    DP 1.2 + Club 3D CAC-1070 Firmware 7.85 connected to TV LG 55E6D only for video



    Updates:

    2018-05-05-1 Update kernel to 4.14.39

    2018-05-05-2 create new direkt HiDrive links for all downloads (less confusing in finding files)

    2018-05-05-3 changed order of download links -5.42 for coffee lake is now first

    2018-05-05-4 1st confirmation for working Gemini Lake from tomtomclub for a J4105 with the Coffee Lake version

    2018-05-06-1 added the config of my main setup

    2018-05-06-2 added 2nd J4105 confirmation by NINjak in the Gemini Lake count for 8.2.5-5.42

    2018-05-09-1 added new version 8.2.5-6.42

    2018-05-10-1 update 8.2.5-5.42 and updated info for new /flash/mount-storage.sh and deleted /storage/.config/post-update.sh and the change for kernel paramter ramlimit

    2018-05-11-1 added Gemini Lake HDMI Bug Report

    2018-05-13-1 rebuild all images, restucture download folders, updated all descriptions and links

    2018-05-20-1 lots of updates for 3.42, 5.42, 6.42 and new version 7.42

    2018-05-20-2 added possible workaround info for Gemini Lake user with HDMI issues

    2018-05-31-1 update 5.42 and 6.42 with new kernel and added new Gemini Lake workarounds to normal 6.42 build

    2018-05-31-2 update 3.42 with new kernel, chagend README.txt at the download locations, added some info when to choose what version

    2018-06-02-1 added testing version 6.42 and 7.42 for AMD Vega and Raven APU in post #71

    2018-06-02-2 added Gemini Lake to the topic

    2018-06-03-1 updated for new .2 versions with more general descriptions (details are from now on in the posts for the updates) and hopefully less updates of the 1st post in the future

    2018-06-13-1 rollback PR2403, VAAPI with AMD is not possible with Kodi 17 (no support in kodi)

    2018-06-17-1 5.42 is dead, latest 6.42 has now GLK HDMI bug autofix

    2018-07-02-1 removed 5.42, removing lvm2/mdadm announced, 6.42 now with kernel 4.17, removed Xin1 versions

    2018-08-09-1 removed extra GLK HDMI Bug section

    2018-08-17-1 6.42 and 7.42 now with kernel 4.18

    2018-09-15-1 Changed version numbers and download links


    Have Fun

    sky42

    Edited 51 times, last by sky42 ().

  • CvH

    Approved the thread.
  • Hi, tx for contributing, do you have some git for this changes too ? Also might we "need" some of the change at the official LE ?

  • update kernel to 4.14.39 and some cleanup of my build tree for less chaos in my patches

  • I dont have any gemini lake hardware for testing.


    What file did you take to install/update?

    only these 2 are probably working

    LibreELEC-Generic.x86_64-8.2.5-5.42-kernel-4.14.39.tar

    LibreELEC-Generic.x86_64-8.2.5-5.42-kernel-4.14.39.img.gz


    take them from here HiDrive

  • updated all download links with new share links and they are pointing direct to the correct folder

    and

    changed order of download links, so that the coffee lake one is now frist

  • Code
    1. 4 hours of searching and what am I happy man zo manny thanks its workning now

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

  • Can somebody else confirm that Gemini Lake does work with my 8.2.5-5.42?


    When i can get confirmations for J5005, J4105 (already done by tomtomclub) and J4005 i would add Gemini Lake to the topic.



    @tomomclub: sorry for the 4 hour searching/testing, i should have made all the download links direct from the beginning


  • Problems to find hdmi signal after reboot . wen i reboot 10 time or more the tv is working . but its working fine on simple pc tablet bit not on tv



    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

  • Sorry i am not a developer. I just gather information, patches, new software versions and try to build them.


    If i had to guess i would say the plugin.video.quasar ist the problem, but i am just guessing. The other thing that looks probably problematic is the cec.


    You have a lot of plugins. For me it is just kodi + tvheadend client + unpause jumpback. That is pretty stable for me (so far).

  • thanks sky42

    Code
    1. solved, I turn off the TV and and turn on, then on again find that hdmi good again

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

  • sky42 the 8.2.5-5.42 version does work on my Asrock J4105-ITX (like tomtomclub , so no surprise here). To display Kodi on a 24" Dell monitor and and a 40" LED TV is/was no problem, with this/"your" version, but our new LG OLED65E7V (living room) has still no idea what for picture it had to display. ;) Sometimes I saw the upper left part of Kodi very very very big in a blue-ish, pink-ish and purple-ish color scheme... but not all the time the system was running.


    Because I bought this board to upgrade the HTPC for the living room so my quest was, and is, not finished.

    As a test I put windows 10 on the system and again nothing happens (no picture on the OLED, the same as "your" working version) until I installed the (Intel® UHD Graphics 600) video driver from intel (only in Windows, nothing before that).


    I hope I can fix this (timing?) problem and start using LibreELEC again but maybe someone else have or maybe had the same problem and already did find a solution.

  • If i find time next week i try todo the part of my wishlist and build a version 8.2.5-6.42 with kernel 4.16.

    Edited once, last by sky42 ().

  • Code
    1. can someone confirm or j5005 work, my other motherboard was sold to my brother-in-law that is why I am now thinking about the j5005

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

  • NINjak try this one HiDrive with kernel 4.16.8 build just now and still with a wrong version numnber 8.2.5-5.42. I am just doing a full rebuild and that takes about 90min. On my i3-8100 the testing version bootet just now, but no testing at all so far.


    The real 8.2.5-6.42 wil follow and here are the changes so far

    8.2.5-6.42 with kernel 4.16.8 and Coffee Lake support

    - based on 8.2.5-5.42

    - Coffee Lake Support without i915 alpha features

    - additional driver disabled bcm_sta RTL8192CU RTL8192DU RTL8192EU RTL8188EU RTL8812AU

    - kernel driver enabled RTL8XXXU RTL8192CU

    - removed kernel patch linux-051-ouya_controller_support.patch and linux-053-spinelplus-remote-0.2.patch