Test LibreELEC images with KODI-18 for S9xxx

  • Small upgrade for X96 Max on LibreELEC to see that the device is working. LED solder in a regular place. + plus in the center, - minus near clock

    I recommend turning the case upside down and using the X96max only in this position. In it, the main Board and the radiator of the cooling system are installed upside down. :)

  • Mr. Balbes, is it possible to create a device tree for the Beelink GT-King? I tied the ones included in your LibreELEC port, but none would boot.

  • Update images 20190608. Fixed sound operation via BT.

    Pay attention to the change in the composition of images. All images belong to two groups AMLG12 and AMLGX. In the name of the image specified how DTB is specified in this manner by default. For those models for which there is no image with the exact model name, you need to use an image with the same processor architecture (s905 s905x s905x2 s912 s922) and after recording the image, configure the used DTB as described earlier in the file (uEnv.ini).

  • is it possible to create a device tree for the Beelink GT-King? I tied the ones included in your LibreELEC port, but none would boot.

    Sorry, but none of the Le developers have this model, so we can't support it.

  • I have an untested device-tree for the GT-King in my repo .. I'll pick a couple of people to test it and give feedback. Once we have at least one "box" device-tree for S922X it should be a simply copy/paste exercise to create more - the only thing that's likely to be different is the Ethernet spec and the remote control keymap.

  • Sorry, but none of the Le developers have this model, so we can't support it.

    clarkss12

    Ask the Coreelec team for help because in some there are reports that they already have the box.

    More be aware that it will always be a cobai of the pampering of ray and adam.

    They complain that they do not have the stall for testing.

    More when they have the tests done by you and not by them.

    You will only be a number because so far there is no stable image for the Odroid N2.

  • WP2 "dts" is misspelled in the uEnv.ini file.It was booted when it was fixed to "dtb".Tuner drivers are not installed.

  • Tuner drivers are not installed.

    If you (and the persistent +1/me-too tuner-using collective) want tuner drivers in mainline kernel images please petition afl1 to reach-out to the linux-amlogic kernel maintainers and start upstreaming them. It's the only way forwards. There are people who are willing to help/assist this activity.. but it's his code and responsibilty to initiate the process. As the saying goes "the ball is in his hands" (not ours).

  • Update images 20190608. Fixed sound operation via BT.

    Pay attention to the change in the composition of images. All images belong to two groups AMLG12 and AMLGX. In the name of the image specified how DTB is specified in this manner by default. For those models for which there is no image with the exact model name, you need to use an image with the same processor architecture (s905 s905x s905x2 s912 s922) and after recording the image, configure the used DTB as described earlier in the file (uEnv.ini).

    balbes150

    For KI Pro I used the image khadas_vim

    Their change broke DTV? afl1 .

    No apparent tuner.

    If I'm wrong, please.

    Direct to the correct image.

    Where is the image with the processor architecture (S905D)?

    Edited 4 times, last by Fran ().

  • Hi,

    I have a A95X MAX 4GB/64GB, which I can not get to boot into Libreelec from SD or USB.

    I am guessing I am either using wrong DTB img or wrong build.

    Does anyone else have this TV box and managed to get it to work ? If so how ?


    I have tried both these images, and the various DTB files:

    LibreELEC-AMLG12.arm-9.1-devel-20190605165424-a41fdf1-box.img.gz

    LibreELEC-AMLG12.arm-9.1-devel-20190608151005-a41fdf1-x96-max.img.gz



    thanks

    Dave

  • X96 Max 2G/16G 100Mb/s NIC 20190608 Tested both aarch64 and arm images.


    I cannot view live TV streamed from tvheadend TV server.

    When I play ".ts" videos or live TV I get audio only ...... no video at all.


    So the problem I am meeting appears to relate to .ts files rather than live TV.


    It would be good to know if anyone else can duplicate this problem.

    Edited once, last by JohnBoyz ().

  • X96 Max test with new g12 build.


    - Vontar X96 Max

    - S905X2/u211 SOC

    - G12A chipset

    - 10/100mbit NIC

    - No bluetooth module

    - 2gb/16gb version

    - 2,4ghz wifi b/g/n


    Image: LibreELEC-AMLG12.arm-9.1-devel-20190608151005-a41fdf1-x96-max.img.gz


    DTB: meson-g12a-x96-max-rmii.dtb (the stock one, already present in the dtb folder)


    Results:

    - Boots just fine

    - Ethernet working, gets IP through DHCP

    - Stock remote works

    - HDMI audio output present / working 5.1 through spdif passthrough

    - Frequent GUI freezes

    - No mutichannel PCM

    - HEVC crahes (known issue)

    - No WiFi

    - Doesn't wake from power off or suspended mode from remote press

  • balbes150   chewitt Just one question!

    is there a developer here to help and answer questions?

    Thank God today there is a bridge called CoreELEC.

    For here they only respond and help what is of interest to you.

    More donation requests can be found throughout the forum.

    If all is well they are all here.

    As everything is wrong we will be hiding.

    It is useless knowledge if not shared the world.