@balbes150 LE images with Kodi-19 for S9xxx

    • Official Post

    illusi0n: In that case emmc is wiped or broken or both. LE does not ship and test images for box devices with signed firmware and u-boot (only for board devices we have FIP sources for) so whatever image you're using is probably for G12B or SM1 hardware not G12A, and the RAM timings in the signed firmware are not correct for your board so it faults between BL2 and BL3x and restarts. You're now at the same stage where you need to self-build an image using the FIP sources for the U200 device and hope they work. I'd also go hunting on freaktab for some kind of Android image for the box that you can load or maybe dump the first 2-4MB from as this will get you enough of the factory boot firmware to get u-boot installed. From that point an LE "box" image should boot.

    Commits · chewitt/LibreELEC.tv · GitHub <= branch is use for development and experimentation and is rebased freqently. I will publicly refuse support on anything built from it :)

  • miwenka ahh, that explains why boot fails, the u-boot.ext file is for G12 devices. It's odd that you have this behaviour though, as it's normally only seen with very recent u-boot on boxes. Anyway.. download u-boot.bin.wetek-play2 and rename to u-boot.exe and see if that works, it's mainline u-boot from another S905 device. No guarantees..

    Not booting also.

    Thank you very much for helping.

  • chewitt Things are moving fast towards linux.

    Perhaps linux 5.7-rc5 is an important tool for development!

    The bulk of the rc5 stuff is drivers (gpu, dma, sound, rdma, hyper-v,

    md, i2c, mmc) and filesystems (btrfs and nfs).

    According to the source: LKML: Linus Torvalds: Linux 5.7-rc4

    It is useless knowledge if not shared the world.

    • Official Post

    Linux 5.7 doesn't really fix anything - it's just another incremental step in the journey. I've been working with it for a month now and need to rework audio support as the upstream maintainers rejected yet-another idea that I had to simplify adding new devices - so I need to revert back to a previous approach (aka doing it the hard way). Once that's done I'll push some device support upstream and then think about making a general 5.7 update to LE master. There are still some known glitches for audio support on GX hardware and while there has been some effort with ffmpeg V4L2m2m we still have issues with draining which impacts end of stream and seeking. No public code for HEVC yet either. Apart from that, things are stable.

  • Thanks again for your efforts!

    We are grateful for the time and hard work dedicated to the community.

    It is useless knowledge if not shared the world.

    • Official Post

    Tronsmart Vega S95 Telos (Amlogic S905)

    Show a photo of the device. For s905, you need to use the "gxbb" version (after recording the image, you do not need to change anything in the settings). You may need to switch to the fixed option in the settings for the sound to work correctly.

    If the add-on compatibility is not needed, is there any actual advantage/hindrance in using arm or aarch64 images? I recall reading balbes150 mentioning temperature, but maybe I'm having a Mandela effect... Does one perform better than the other?

    aarch64 runs faster than arm by about 20-30% faster.

  • balbes150 I've tried latest aarch: LibreELEC-ARM-ALL.aarch64-9.80-devel-20200430125433-b18883b-amlgx.img.gz

    Using meson-gxm-khadas-vim2.dtb on a S912 starting from SD (USB doesn't work, gives an error "Could not mount LABEL=LIBREELEC")

    All I get is the logo and then:

    [   97.908314] kernel-overlays-setup: setup base modules
    [   98.053646] kernel-overlays-setup: added modules from /usr/lib/kernel-overlays/base/lib/modules/5.7.0-rc3
    [   98.115976] kernel-overlays-setup: added firmware from /usr/lib/kernel-overlays/base/lib/firmware
    [   98.131722] kernel-overlays-setup: adding overlays from /storage/.cache/kernel-overlays
    [   98.146622] kernel-overlays-setup: done
    [  102.173839] kernel-overlays-setup: setup base modules
    [  102.310614] kernel-overlays-setup: added modules from /usr/lib/kernel-overlays/base/lib/modules/5.7.0-rc3
    [  102.365419] kernel-overlays-setup: added firmware from /usr/lib/kernel-overlays/base/lib/firmware
    [  102.381177] kernel-overlays-setup: adding overlays from /storage/.cache/kernel-overlays
    [  102.396125] kernel-overlays-setup: done

    which repeats over and over.

    Edit: version 0200410154217-92efcc1 seems to work.

    Edited once, last by Zameero: update ().

  • balbes150 something changed here I spent a few days without testing its construction!

    I tested with 20200505, 20200505-aarch64.

    I tested both dtb in the file (uEnv.txt)



    No boot! kipro

    It is useless knowledge if not shared the world.

  • Thanks, what I meant was a source for the 30% speed increase for LE (as in any real comparison been done? or were does the 30% number comes from?)

    I am not sure if anyone has really done much comparing. I know i have been playing around with 64bit userland for a while and even tho it sounds good find there are still issues with some of the support packages and things that kinda make it not worth the effort at this time, but i quess i should also qualify that by it all comes down to what your wanting run as something are still locked into 32bit.

    The only thing that i can think of thats gone the 64bit way would be something like OSMC as i think i have seen others talk about it, personally tho i have never played or even tried OSMC and am repeating what others have said to me.

  • balbes150

    Hello. I am using the IMG from this topic to start X96Max with a corrupted nand flash. When downloading from an sd card via UART, I see the following:

    I think MBR is correctly located by the loader, but for some reason I don't like it. Maybe there is some different version of u-boot.bin.sd.bin to boot AML S902X2?

    p.s. I speak Russian