@balbes150 LE images with Kodi-19 for S9xxx

  • Coreelec are using an outdated and not compatible with other new systems technology run from external media. No matter what you have in eMMC. If you are running coreelec from external media, then your eMMC has an old version of multi-boot that is not compatible with the new systems. No new system can run properly on your device anymore.


    So actually in order to launch LE from the Amlogic boxes, I need to update the internal Uboot first?

  • balbes150 something weird going on with networks here :P

    s905x2 box, wired doesn't work, wireless works sporadically then totally drops off the network...

    s905x box, wireless doesn't work at all, wired looks like it works really well! ?(

    Edit: worked out why I couldn't connect to the boxes to use 'file sharing', need to go into 'LibreELEC services', minimum service needed is SMB1...sounds a bit backward but probably a linux thing, SMB=M$ cac, let's have NFS file sharing instead ;)

    Edited once, last by punter (August 23, 2019 at 11:28 AM).

  • I have a box S905D (GTC media) with internal CXD28xx tuner(please support this tuner).

    I tested all versions available in the first post of Kodi Leia for s905 But only the LibreELEC-AMLGX.arm-9.1-devel version of date 20190617 started from SD.

    when I put the version 9.1 boot files (aml_Autoscript, boot.ini, emmc_autoscript, s905_autoscript, uEnv.ini) into the latest version 9.80 it worked. If you can fix this problem for the next versions it would be great.

    Thank you.

  • Using a Khadas VIM3 here.

    I just flashed the latest s922x build (#20190823) but I could not boot up Libreelec via Keys Mode.

    I formatted my SD card and flashed build #20190724 onto the SD card and I was able to boot into Libreelec via Keys Mode again.

    Please take a look. Thanks.

    Edited once, last by cheungie (August 25, 2019 at 9:23 AM).

  • I was asked to update a friends older Libreelec running on an SD card on their Beelink GT 1 clone 2Gb/16Gb/1GB Lan(which runs GT1 Android perfectly).

    But I ran into some issues.

    Firstly in the initial post of this thread there is mention of a new activation of the universal multi-boot but no mention of what, where and how this part is achieved.

    So I soldiered on with the knowledge that I had from previous installation.

    Flashed the latest S912 image (LibreELEC-AMLGX.arm-9.80-devel-20190821140333-07b919f-s912.img)

    It was to clear which DTB should be used but as this was a q201 board (which the previous Libreelec version had a DTB for this setup) it seemed logical to start with the meson-gxm-q201.dtb, so I modified uEnv.ini and extlinux.conf as appropriate.

    Popped in the SD card and started up the box, which initially booted to Android, so I installed the Reboot to Libreelec app, ran it and it proceeded to boot from the SD card and I saw the Libreelec logo.

    But after waiting a little while, I noticed that a reboot had been automatically initiated, where it would go through the same process again and again, in some form of boot loop. It did this a number of times before just stopping with no activity and a blank screen.

    So I switched the box off and put the SD card into my PC to see what it;s state was. It seemed to be at the same state that it was in before placing it onto the Android box.

    I wondered whether the dtb was incompatible, so after a little searching it seemed that the extlinux.conf or meson-gxm-rbox-pro might potentially be compatible but after trying each, the same boot loop activity occurred.

    So I am stuck as to what direction to go in next and wonder whether this mysterious universal multi-boot thing holds the answer?

  • I got Fran 's message by mail before it was deleted. I understand it can be annoying to read messages that appear to be repetitive and inflammatory.

    I think it's more due to a non native speaker having problems expressing himself, but in any case it's not spam and removing it as such only reinforces the view expressed in said message.

  • When does legitimate observation become SPAM ?

    after repeating know issues x times, just because there is a new version out doesn't mean everything is working

    Incomplete test versions.

    This is a developement thread and not an "here is my finished product" thread. This version is under HEAVY development in dependency of a lot upstream projects (kernel, video drivers, ....) where a lot ppl are involved (directly or indirect) so don't expect an stable release here.

  • for any one interested i found the trick i had to change aml_autoscript to streambus_autoscript as i found in the uboot loads from streambus_autoscript no aml_autoscript in uboot.

    hello dear balbes150 , or any experienced

    i hope you can help me. i own chinese tv box with dvbs2 and amlogic S905 chip android 5.1 updated to 6 .. tried libreelec coreelec armbian no success to activate multiboot env and no booting

    if i use aml_autoscripte zip get error not signed. using tv box update app

    when i signed it got secure check failed. and normaly just dummy file to invoke recovery mode.

    using reset botton and powering or power on with menu from remote, both just get me to recovery

    with cannot load volume /misc

    used 3 sdcard and usb drive. libreeelec tool, rufus, win32tool, used fat and fat32, Burned img and img.gz

    used 2G part, 512mb, 32mb,

    i couldnt find my mistake or this box needs trick. three days of searching and testing no success.

    device and clones :

    qviart undro 4K | ott 1200 4K | echolink tornado V9 uhd | tiger ultimate K10 | SAMSAT VOGUE ONE | gotit gt2017 | Icosium A1

    Latest gn ott 1200 4k firmware zip.


    attachment files bootloader, sdcard burn uboot, build.prop

  • On s905x2 there are two wired network options, for proper operation you need to use the correct DTB.


    I tried different DTBs but the wired still wouldn't work.....F2 S905X2 box....

    Anyway I'm keen to get the wireless working! With your latest build it performs better than before but still drops off the network; appears to drop off quicker when 'under load'. Any way I can troubleshoot this?

    It's not a hardware issue cos it works fine under coreelec but I've got libreelec installed in the emmc now and I'd like to run with your system if possible


  • for any one interested i found the trick i had to change aml_autoscript to streambus_autoscript as i found in the uboot loads from streambus_autoscript no aml_autoscript in uboot.