@balbes150 LE images with Kodi-19 for S9xxx

  • device mounted in an awkward place that does not allow for easy ejection of the SD card.

    Maybe you could use usb pen drive and extension cable instead of card!?..
    ..or don't choose a testing branch for those devices and stick on older kernels where that patch was available..

  • Build LibreELEC-AMLGX.arm-9.80-devel-20190716100115-893dd58-s905x.img.gz tested on generic S905X device.

    I have some Kodi restarts but I can't find the root cause see logs

    All videos works fine except old ones using codec Windows Media Video 9 see logs. Sound works but I see a white screen.

    WiFi not works but I handle it compiling the RTL8189ES kernel module as addon.

  • Hello Balbes150,

    For Nanopi-K2 Building u-boot.bin (U-Boot? fip?) seems to be broken. LibreELEC does not boot from a freshly burned sd-card (Monitoring U-Boot via minicom: U-Boot bin loaded and halt)., but update from a working Card (from 26.05) will boot (branch amlogic-master).

    Now the bad News (build aarch64 amlogic-master):

    - TV (pvr.vdr.vnsi from branch amlogic master): leads to reboot (w/o HW-accerleration: playing with stutters)

    - Video Playback: leads to reboot (w/o HW-accerleration: ok)

    - Music Playback via UPNP: ok

    - installing addon (weather yahoo): ok

    All in all LibreELEC "feels" slower, maybe depending on LAN?

    • Official Post

    1. Download following file multi-boot fix.zip:-

    2. Extract the 2 files from this zip file - "aml_autoscript" and "aml_autoscript.zip"

    3. Format SD card (I used rufus) to FAT32.

    4. Copy "aml_autoscript" and "aml_autoscript.zip" to this SD card.

    Everything you need is part of the image of LE. You don't need to download or record anything else. The rest of the instructions are correct.

    hmmm when you state older versions of LibreELEC (how old?) and ref ukmark62 earlier post what is your recommendedmethod to check current status and correct?

    If you encounter any errors in starting the system from external media - the first step is to update the multi-boot.

    Understood, except this is what has been fully available in past via balbes150 builds, reboot into Android from LibreELEC and reboot into LibreELEC from Android without any need to regularily play around removing and re-inserting SD. (Well at least for kvim devices)

    Android launch mode from LE (without disabling external media Sd and USB) is possible. But I do not have enough time to test this mode.

    • Official Post

    tested on generic S905X device

    You need to specify the exact model and dtb with which you are testing.

    (Monitoring U-Boot via minicom: U-Boot bin loaded and halt)., but update from a working Card (from 26.05) will boot (branch amlogic-master).

    Can you show UART log ?

    (build aarch64 amlogic-master)

    I temporarily stopped building aarch64. What exact version of the image was used ?

    I have Mecool BB2 Pro S912 3G/16GB, which dtb do i have to choose?

    try all gxm*

  • Has anyone tried to flash the build to a95x f2 (S905x2) box?

    It boots, but without ethernet and a bunch of errors. Also elementum addon wouldn't start, which is vital for me.

    CoreELEC s905x2 build wouldn't boot at all on this box.

    Would be thankful for advice or solution

  • How do you configure the DTB ?

    By changing the line in a /extlinux file.

    Tried all of them

    Situation is similar :

    WiFi, cec -OK

    Ethernet, elementum launch - nope

    During reboot there's an error something like "cannot configure ethernet mac"

  • Need to edit (env.ini). You can ignore the Mac address error.

    Where it's at? What edits do I have to perform ?

    Upd. Solved the problem with ethernet by changing the dtb line to x96maxrmii in both extlinux and uenv.ini also.

    The latest version of Elementum still crashes. The previous one OK.

    I'm fine for now.

    Upd.2 Goes to bootloop if installed to emmc with this dtb

    Edited 3 times, last by Patkino ().

  • Hello,
    I've booted the latest image on my A95X F2 (s905x2) with 4Gb of RAM / 64 Gb of emmc.The first issue is the amount of RAM: only 3Gb are available.

    Worst, Kodi crashed when I try to play a x265 video with hardware acceleration activated. I've tried all g12a dtb with no success.

    Could you please tell if it is possible to change the hardware acceleration driver?