[] LibreELEC Kodi Krypton - S905 & S912 devices

  • Grab the last working kszaq LE C2 .tar release and uncompressed it on a PC / Mac.

    Then overwrite the SYSTEM and KERNEL files on the SD / eMMC.

    That should hopefully restore a working setup.

    Not at home base at the moment, will do a 32bit compatible C2 release when I'm back.

    Otherwise do a complete reflash of a LE C2 standard release and then upgrade with my aarch.tar update.

    Not working. its struck at libreelec logo forever.

    any solution ? is this version or 8.2.5 from libreelec website latest one ?

  • Nexbox A95X (s905x).

    ERROR: LibreELEC-S905.arm- is not compatible with S905.arm hardware - update cancelled.

    Current system: S905.arm

    Update system: S912.arm

  • Thanks. And clean installation and recovery settings from backup can solve the problem?

    I don't quite understand the code "touch /storage/.update/.nocompat"

    Yes, clean installation will be fine.

    Login SSH and type touch /storage/.update/.nocompat

  • Yes, clean installation will be fine.

    Login SSH and type touch /storage/.update/.nocompat

    First I enter the code via SSH. Then I copy the *.tar and *.dtb files into the "Update" folder and restart. All right?

    Forgive me for stupid questions, I don't want to break down what works :)

  • Ive been using libre for ages on a raspberry. However I wanted hevc support, so after reading the forums, I bought a Mecool M8S pro + (S905x) as this was recommened. This one does not have a reset button in the AV hole.

    Whilst this box does have a sort of kodi it’s not to my liking, so I wanted to boot libre of the sd card.

    I used LibreELEC-S905.arm- and tried LibreELEC-S905.arm-8.2-

    But all I got was the Mecool banner and then it just stayed there.

    I’m sure it should run as other people have it running on M8S boxes, so I must be doing something wrong.

    Can anyone point me in the right direction.

    Thank you.

  • This will help you.

    [HOWTO + FAQ] Install community builds on S905/S905D/S905W/S905X/S912 device

  • Look towards the device tree. It must match your box.

  • Thank you all - Yes that web page was what I was following

    acording to that web page S905X does not need a device tree. "S905X: You can leave a tree that is already present on SD card"

    I'll try a 2G one and see if that works.

    I try gxl_p212_2g.dtb and gxl_p212_2g_nand.dtb and gxl_p212_2g_slowemmc.dtb but same - Stops at mecool banner.

    I must be doing something stupid as others have got it to work.

    Sucess, I used This and it booted first time. Few things dont work (keyboard/mouse) but at least it boot - and I know this is alpha.

    Ok. now i see where I was going wrong. I didn't rename gxl_p212_2g.dtb to dtb.img (it was not ovious from the install instructions). Now it is working properly even keyboard/mouse & wifi works.

    Edited 3 times, last by hAZAR: Added dtb tried (June 22, 2018 at 1:19 PM).

  • What is the difference between q200_k3 and q200_3g dtb? I had been using q200_3g with gigabit for my h96 pro plus. But today i was looking at the mega.nz folder and there wasnt any g200_3g under the gigabit folder, so i tried q200_k3 and it worked. Do i NEED to have the "correct" dtb, or its fine as long as it boots?

    Edit: Also wanted to ask: I have an Air Mouse js6, it has some buttons (such as the internet explorer button) which are not read by LibreELEC, im unable to map them in Keymap Editor. However, i tried 8.90.3 CoreELEC and there the buttons work, i can remap them using Keymap editor. Is there any way i can bring that functionality to LibreELEC?

    Edited once, last by punkid (June 23, 2018 at 7:02 PM).