[8.2.4.1] LibreELEC Kodi Krypton - S905 & S912 devices

  • just updated from the 444 build to 420 and now when i play any 4k hdr content i get a black screen. was working perfectly on the 444 build and tv recognised 4k hdr(pq).. gone back to the 444 build for now.
    im using a premium certified hdmi cable and a mecool m8s pro s912

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • I also wouldnt recommend enabling GPU overclocking. My Minix U9 with an external 2.5" HDD sitting on top of it, gets quite warm, not far away from "hot" esp. with summer temperatures. And Minix U9 is a media player with better cooling than most other AmlogiC media players, which most likely get hotter.


    Im still a bit confused about this soc. Nvidia Shield has like 5x better GPU and like 3x better cpu and it still barely gets warm wHhen watching movies. Now I know it has a larger heatsiNk and a fan, but still, I think NV Tech is way more efficient than amlogics.

    You are placing your boxes wrong way. Place your Minix on top of your HDD, and solve your heating problem ;)

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • Another .tar test update this time testing 2160p 420,10bit video output.

    The main aim of this release is to use 420,10bit for all 2160p video modes if...

    YCbCr 4;2:0 mode applies only to 4K 50/60Hz. When it switches to 4K 24/25/30Hz, you will get YCbCr 4:4:4.

  • Hi,


    is there a way to add DVB drivers to these builds? Like they did to the generic builds here? LibreELEC 8.x images for additional dvb drivers


    Or is there another way to get DVB drivers to work?

    So is there any way to add dvb drivers to LibreElec 8.x images? I know the latest LIbreElec Leia images have them build in but I really don't want to be running alpha builds and happy with current version.


    Any way I could build image myself and use drivers or are there compatibility issues between versions?

  • Hi, any news on the external subtitles bug via smb share on Minix U9?

    This Bug exists on any of mine boxes (H96, Beelink GT1,...) ...thinks its a bug in the build at the moment ... i made a workaround til its solved. Change the path for Subtitles from "with video" to a folder on your SD Card on "storage" e.g. "SUBS". Then its works again. Its not the final solution, but i can watch my tv-series from the US with subtitles again.

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:


    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver



  • Hi ....I have several movies where kodi freeze and restart ..no way to played ..but the rest of files play just beautifully ..... ?

  • Hi ....I have several movies where kodi freeze and restart ..no way to played ..but the rest of files play just beautifully ..... ?

    Can you check the folder where the movie is located, if there ist any folder called "subs" or so. Or if there is a .srt file beneath the .mkv movie file. I had that too on several movies and always was a SUBS Folder within the movie folder. If i delete them, the movie plays like charm.

    Based in GERMANY — working in cigar business — part time freelance webdesigner — PS4 Console Gamer and TV Show Junkie :cool:


    S912 with CE on NAND — S905x with CE on SD-Card (with EmulationStation&KODI shanti‘s build) - Odroid N2 with CE on emmc and EmuELEC on SD-Cad — 4K 65“ Sony — 4K Onkyo DD/DTSHD/ATMOS Receiver



  • I posted this already in the Kodi forum but maybe somebody can help me here since this thread is more HW related :-)


    Sooo Big Grin I received my U9 today, the setup was very easy and got LE running within 5 min.
    @wrxtasy I can't get Dolby Atmos running, passthrough is enabled but my AVR shows just DTSHD or DD+ but no Dolby Atmos any Idea?


    I Got it working i messed the AVR settings up...

    Edited once, last by Netleader: Mods you can delete if you want ().

  • I am running wrxtasy ´s LibreELEC-S912.arm-8.2.4.1.force.444.10bit on a Minix 9U-H.


    All works perfectly for me but not Samba.


    Its not possible to copy over a file from another Linux Machine bigger than 2GB. If I copy the same file onto a Nuc with Samba there is no problem at all. I´ve searched everywhere for a solution but not avail.

    However, if I use SFTP I can transfer files 2GB+ without problems. But SFTP is not an option because its too slow.

  • Can you check the folder where the movie is located, if there ist any folder called "subs" or so. Or if there is a .srt file beneath the .mkv movie file. I had that too on several movies and always was a SUBS Folder within the movie folder. If i delete them, the movie plays like charm.

    I think you right ....some of them working now...thnx

  • I am running wrxtasy ´s LibreELEC-S912.arm-8.2.4.1.force.444.10bit on a Minix 9U-H.


    All works perfectly for me but not Samba.


    Its not possible to copy over a file from another Linux Machine bigger than 2GB. If I copy the same file onto a Nuc with Samba there is no problem at all. I´ve searched everywhere for a solution but not avail.

    However, if I use SFTP I can transfer files 2GB+ without problems. But SFTP is not an option because its too slow.

    Have you tried with NFS? If not, you should as NFS is faster and much less load-demanding than SMB. And it might help you with your problem as well.


    Otherwise, have you tried to mound SMB via OS and not in Kodi?

  • I have M8S Pro L Android TV version and Libreelec is running but the bluetooth voice remote keeps disconnecting and none of the buttons work.

  • Have you tried with NFS? If not, you should as NFS is faster and much less load-demanding than SMB. And it might help you with your problem as well.


    Otherwise, have you tried to mound SMB via OS and not in Kodi?

    I get about 8.5-8.9MB/s transfer speeds with Samba because I only have a 100MBit Switch. So its good enough. Point is that there is something wrong with the Samba version of wrxtasy libreelec allowing only transfers of < 2GB files.

    If I would have mounted the Sambashares in Kodi and and not in Libreelec I wouldnt have been able to transfer anything.

  • I get about 8.5-8.9MB/s transfer speeds with Samba because I only have a 100MBit Switch. So its good enough. Point is that there is something wrong with the Samba version of wrxtasy libreelec allowing only transfers of < 2GB files.

    If I would have mounted the Sambashares in Kodi and and not in Libreelec I wouldnt have been able to transfer anything.

    I can't understand why you would use SMB regardless of the transfer speeds you get as it gives a performance loss for both your server and the Amlogic box compared to NFS... It should be illegal to use SMB for transfering between unix systems if you ask me!


    So, you should definitely setup NFS and use it instead. Especially if you think the SMB version in the build is the problem... You'll get a performance increase for both the server and the Minux box, and hopefully your problem is solved. SMB should only be used if you are so unfortunate and have a windows system - yet it doesn't change the fact that you should use NFS in addition between unix systems.


    Here is a great guide which should help you to setup NFS correctly - https://kodi.wiki/view/nfs

    I bet there are plenty of guides and threads about this in the forum if you need any assistance :)

    PS: I've a cheap Amlogic box with 100 mbit connection and I've an average throughput of 11.5-12 MB/s with NFS, which is a huge difference compared to 8.5-8.9 MB/s if you ask me... And with a Gbit adapter I can play 300 Mbit clips (Jellyfish as an example) without stuttering, which I probably wouldn't if I used SMB.

    Edited once, last by CI6N0Z ().

  • Your understanding is wrong, so I´ll tell you about my setup.

    Before I was running the same on an Intel NUC without any problems whatsoever. Now I got this Minix Box to replace the NUC.

    So into this Minix Box there is a 10 Port Powered USB HUB plugged in. Into this HUB there a 10 2.5" Hard drives plugged in,, all between 2 and 4 TB each. That makes a total Storage for me of 32TB.

    On my other machine (Linux), I rip the Movies and Music from Bluyray and CD respectively.

    After ripping I just want to move them over to the Hard drives plugged into the Minix Box.

    That works fine with Samba and the speed is acceptable but not for files bigger than 2GB which ALL the Bluray Movies are. Its a pain in the ass to tranfer a 50GB file over with SFTP. It takes 1 day.

    SO basically I told you that I like Audi and I want to buy an Audi but the Navigation is broken and how to fix it. Then you come and tell me to buy an BMW on which the Nagivation works..... :dodgy:

  • Well, it doesn't change the fact that discarding SMB and using NFS to transfer files between your Linux machine and your Minix most likely will fix your issue. So why would you still stay with SMB as it doesn't work and has poorer performance compared to NFS? Regarding the the test you referred to above, it might not be as small difference for your case as one of the bottlenecks in your setup is the low-powered Minix. From my experience and from reading at LE/CE/OSMC forums, the difference is greater with low-powered devices as Amlogic.

    So, if you still want to use SMB in your setup I suggest that you wait for a replay from someone who know more about SMB configuration as they might help you;)