LibreELEC 8.x images for additional dvb drivers

  • LibreELEC (additional dvb drivers) v8.2.0

    (Kodi Krypton v17.5)


    Unofficial LibreELEC 8.2 images to support additional DVB cards.

    What image to choose ?


    for TBS cards
    DVB Drivers for TBS (open source TBS drivers) > CrazyCat (oss additions + proprietary TBS drivers)


    for DigitalDevices

    DVB Drivers from latest Kernel (open source DD drivers) > DVB Drivers for Digital Devices (proprietary DD drivers)


    for any other not supported DVB card
    DVB Drivers from latest Kernel (bleeding edge + testing drivers from latest Kernel) > CrazyCat (supports some old cards)


    are you unsure ? just ask


    download:


    here



    If you like, buy me a Beer



    Source code for the Addons are here, do you have an improvement ? Pls create a PR !

  • Just update, If you have updated from OE 5.0->6.0 it is likely to fail because your partitions are too small (you could try of course).


    Solution: make an backup, install LE fresh and restore backup (so you have the bigger partitions).
    OE 6.0.3 was the first Version who starts with 512mb Boot partition. 6 and 5 are smaller. (this is a bigger problem for LE8/OE8)

  • The new way implementing the different drivers seems neat! Will leave OE and do a fresh install of LE tomorrow.
    Thank you for the outstanding work LE-crew! And CvH, you are a hero to us TBS owners

  • CvH
    metzner55Will the tvheadend 4.2 addon be coming soon?



    Tvheadend 4.2 with transcoding support is already at the official LibreELEC addon repository



    It doesnt show up me for me, just 4.0.

  • The new way implementing the different drivers seems neat! Will leave OE and do a fresh install of LE tomorrow.


    I have no TBS dvb card so i can only hope it works :) (looks good at least)


    TVH server and DVB driver config aren't working for me. :(


    Tvh 4.2 is running I guess ?
    No adapters get found ?
    Did you choose an driver in the configuration addon (click at an driver -> automatically reboot ?)
    If yes pls upload a log, maybe some firmware is missing.

  • Tvh 4.2 is running I guess ?
    No adapters get found ?
    Did you choose an driver in the configuration addon (click at an driver -> automatically reboot ?)
    If yes pls upload a log, maybe some firmware is missing.


    I tried to install LE directly over my OE install. It looked ok at first, but I got repeated TVH server cannot connect warnings. Uninstalling and reinstalling TVh didn't help.


    I then tried to open the install dvb driver application and I get a warning and it doesn't open.


    Restoring your last OE ljalves build lost all my settings, and TVH wasn't working at first, but uninstalling and reinstalling fixed that.


    Also, I created an OE backup before all this, but it doesn't work. :( I moved it onto another HDD to free up space as I had a warning about lack of space when initially trying to restore, and then am trying to run it from there. Could that be the problem?


  • I then tried to open the install dvb driver application and I get a warning and it doesn't open.


    You need to open the DVB Configuration Addon via Configuration and not via open (or use the short cut in the default confluence skin) - pls have a look at the screenshots.
    If you didn't set your choosen driver it stays at the LE default one. I'm sadly to stupid to make the addon also work if you just open it :/ (if someone knows how to do it pls tell me)


    If you use my Tvh 4.1 builds and want to use now the "official" Tvh 4.2 you have to change you folder in
    /storage/.kodi/userdata/addon_data/service.multimedia.tvheadend -> /storage/.kodi/userdata/addon_data/service.tvheadend42
    Tvheadend 4.0 uses service.multimedia.tvheadend
    Tvheadend 4.2 uses service.tvheadend42

  • Tx to vpeter, addon was fixed and could now be run from programs like every other program :)
    Updated version is uploaded (1.0.1).

  • Good news!


    It's going to be a fun evening :)


    ps. any idea why my OE backup won't restore OE to how it was? I lost all my settings last night. I have moved the tar to another HDD and am trying to restore it from there.



    EDIT: LE now up and running!! :D

  • I assume that TVH 4.2 disappeared from the LE official addons because I selected the ljalves version instead of default?



    Ooh, these forums show new posts when a new page starts!!! :D

  • Testing a LiveUSB of LE I found this in the log




    I was unable to get anything except an error in Kodi when I selected any of the TBS drivers, and this seems to relate.


    What might I have done wrong?


    Thanks.