Intel NUC Gemini Lake (NUC7CJYH) - HTPC

  • Is this recommandable as a HTPC? Which build should one install? Milhouse builds (Leia)?

    Will it work out of the box? IR remote, reboot issues etc.?

    KODI Leia 18.0, LIBREELEC v8.90.003 Alpha

    Intel NUC 4250U in Abel H2 chassis, 40PFL9704

  • There doesn’t seem to be much love on this forum for Generic x32 x64 processors. There’s not a sub forum for some reason, maybe visit Kodi forum.


    You’ll need to use Milhouse builds for Leia with these new NUCs. I suspect it will support same remotes as official Krypton release.

  • Plenty of us on this forum using x86. It's just that we don't have as much to complain about as some other platforms' users. ;)


    For the new Gemini Lake hardware the only way to go at present is with test builds, such as the Millhouse Leia builds. And since CPUs such as the J5005 are still very new, there is plenty of scope for things to not go 100%. I can't speak from experience - I've not yet jumped to Gemini Lake (I'm still on Braswell) but I have read one or two people havve had good results with those builds.

  • Sorry - I misread the NUC number - Yes, the J5005 would be my preference, although since there's a fair bit of acceleration in the GPU you really don't need much in the way of CPU power. For example, I currently run a Celeron N3060 - two cores, Passmark rating 996 - so less power in the CPU and less in the graphics as well. Full HD is never a problem. 4K at 30 Hz is no problem when playing H264 encoded material. Where the Gemini Lake parts score is the support for HDMI 2.0 (and hence 4k up to 60Hz) but watch the system specs, don't just rely on the chip specs, since some J4005 mother boards are only claiming 4k 30Hz. As far as I know the Intel NUCs using j4005 and J5005 are both OK in this respect. The only snag for me is I think they may have fans, and I really want a fanless solution, so I'm looking to ITX boards at present.

  • Is this recommandable as a HTPC? Which build should one install? Milhouse builds (Leia)?

    Will it work out of the box? IR remote, reboot issues etc.?

    Got myself a new NUC7CJYH last week. Official LE 8.2.4 build does not work due to missing GPU support. Guess the same applies for the latest 8.2.5 release, given that kernel remains the same.


    However, unofficial 9.0 Milhouse alpha builds - I'm currently on #0405 #0429 #0707 - work OK.


    Given that - in my perception - little information on LE with Gemini Lake is available right now, I'll try to briefly summarize the things I've found so far:


    + Live booting / installing LE from USB pen drive

    + Installing to and booting LE from SD card

    + IR (tested w/ Harmony 350 remote)

    - IR (tested w/ Harmony 350 remote) magically disconnects a short time after each reboot (appears like a major BIOS problem -> NUC7 generation f*ck-up???; details over at Kodi forums)

    0 Integrated IR (tested w/ Harmony 350 remote) appears to work fine with BIOS version 0027; later BIOS versions appear to be broken (see post over at Kodi forum; detailed discussion on the issue found in that thread as well)

    + HD audio passthrough (major f*ck-up in previous NUC6 generation)

    + AVC HW-decoding up to 4K

    + HEVC HW-decoding, both 8 and 10 bit, up to FHD / 60 Mbps Full-HD Jellyfish demo

    + Video playback at 20-30% CPU load, which results in the fan being inaudible, at least from 3 m / 10 ft distance

    0 Few hiccups / reboot issues, specifically when using Simple IPTV Client

    0 Kodi UI seems a bit sluggish (probably due to alpha build, not a general NUC performance issue, judging from past experience with a NUC2)

    - Booting LE from USB pen drive (probably a BIOS issue, hopefully fixed in the near future)

    [edit] + Installing to and booting LE from USB pen drive (at least with 0027 BIOS)

    [edit] - Frame rate switching seems broken (likely an alpha build specific problem)

    + Frame rate switching works (just me being to stupid to understand the new whitelist approach)


    Given the alpha nature of the Milhouse builds, things work suprisingly well.


    Nevertheless, if you aim for a super-stable, hassle free HTPC experience, I would suggest to wait a few more months until support for Gemini Lake within an official build is available.


    Hope this helps. Any specific questions, let me know.

    Edited 5 times, last by TheKraut: Update LE alpha version; confirmed USB pen drive installation and booting to be OK ().

  • Useful, thanks. I am looking at J5005 (so NUC7PJYH if an Intel) or else on a mini-ITX board if I can find one I like.

  • Wise choice to go for the J5005, I think, considering the slightly higher price tag that gets you a lot of additional multi-thread horsepower. Specifically with new codecs such as AV1 down the road, which will likely require software or hybrid decoding.


    Last time I check, J5005 still had very limited availability though, at least in (continental) Europe. For the J4005, availability is much better, and it should do pretty well as HTPC for the time being with HEVC hardware support.


    In any case, you likely need some patience until all the issues with Gemini Lake have been sorted out (both with respect to LE and BIOS)... the usual fate of early adoption, I guess :(

  • Hi guys, I just got my NUC7CJYH today and im having real problems. I cant get the istallation to start.

    See this thread here where somebody has the same problem:

    NUC7CJYH cannot boot LibreELEC from USB or SD


    With the Latest Milhouse Build on the Stick i cant install libre elec from my usb stick or SD Card. It keeps getting stuck at the installer is loading screen. On my Main PC the stick boots into the installer and i can install. Ive tried severall builds of milhouse aswell as different usb sticks.


    After trying everthing possible to get the stick to boot i went ahead and built the ssd drive into my main computer and installed libre elec on the drive. After that i build the drive back into the nuc. But the Nuc wont load libre elec from that. All i get is a Black screen then.


    Can someone please help me. What else can i try? Is it a Bios setting?


    Edit: I am returning the NUC... so i dont need help but maybe someone else needs help sometime

    Edited 4 times, last by Wordstar ().

  • Here guys special build for gemini lake - based on latest kernel 4.17 drm-tip (intel)

    bumped xorg, mesa, vaapi, and couple of other packages framerate switch working fine ;)


    Sendspace.com Mobile File

    Installer working also fine ;)


    PS. for better GPU experience/speed of GUI etc. use custom xorg.conf

    just put file xorg.conf to /storage/.config/


    PS. for them what are expecting HDR working , is still long way for get working on Linux (but in progress)

    for now what works for me ...in kodi -> settings enable DLNA/UPNP after that all media will be visible on TV and you will get possibility

    play this files with HDR (subtitles also working)

  • So beside the issue with loosing the hdmi output which can be luckily fixed also by restarting tv instead of pulling cables I still have another issue with this build.


    Under Milhouse build I could enable 25Hz mode. With your Build piotrasd I don't have to work with the whitelist but the 25Hz mode is not available. This leeds to stuttering playback when the display mode is set to 50Hz I don't know why this is, because it should just display a frame two times, but it is very noticeable and not possible to enjoy.


    Edit: I tried to get everything as much as to default as possible. So I deleted my autotstart.sh, I created the xorg.conf like you suggested, run getedid delete, and later getedid create.

    Now I have output on start, the 25Hz movies are still displayed with 50Hz but now the stuttering is gone. If the driver patch comes, it is nearly perfect, beside one bug.

    But on one movie I have a new bug that during playback a mouse cursor appears in the center of the screen.

    Edited once, last by tuep ().

  • You don't have a Panasonic OLED TV do you? There have been known issues with some models in 50Hz mode - enabling GAME mode removes them (but then displays 24p at 3:2 60p)


    There's also a known issue with the Sony XE900 series in 50 and 59.94Hz modes where pairs of frames are dropped, then different pairs are repeated (as a pair - so you get a motion judder on native 50Hz stuff) It usually happens on cuts. GAME mode removes it... (Sony are about to swap out me XE9005 for an XF9005 because of this)

  • It's a Samsung LE40C750.

    I am assuming the TV is just fine. With raspberry there have been never issues like that.

  • Is the driver selection for DVB cards I had under Milhouse Build not included in this one? I can't find it.