LibreELEC 9.X / Kodi 18.X for Minix X8,X8H,X8H+

  • Ok replaced "dtb.img" from 18.2 with the one from 18.1, Packed it back in with 7zip and updated and still no cigar, fixed IP goes back to DHCP after a reboot. Am I replacing the right file as there is also a "meson8m2_n200_2G_old.dtb" .. ?

  • Ok replaced "dtb.img" from 18.2 with the one from 18.1, Packed it back in with 7zip and updated and still no cigar, fixed IP goes back to DHCP after a reboot. Am I replacing the right file as there is also a "meson8m2_n200_2G_old.dtb" .. ?

    yep meson8m2_n200_2G_old.dtb = dtb.img .... so this behaviour comes from something else than just a change in the dtb file.

    :cry:

    datrh · GitHub

    my github :

    LE9-Kodi18.3 => this is the one to use

    Edited once, last by datrh ().

  • At X8HP = As I recall, in the Kodi 18 Final version I set the IP address manually on the LAN in the libreelec settings and this version 18 kept the IP address but changed the MAC address after restart or shutdown.

    And as I wrote in version 18.2, Wi-Fi keeps both IP and MAC and can be permanently reserved in the router.

    Versions 18.1 and 18.2 on LAN with DHCP do not hold IP or MAC and cannot be reserved on the router.

    I'll try to help with X8HP:)

  • yep meson8m2_n200_2G_old.dtb = dtb.img .... so this behaviour comes from something else than just a change in the dtb file.

    :cry:


    At X8HP = As I recall, in the Kodi 18 Final version I set the IP address manually on the LAN in the libreelec settings and this version 18 kept the IP address but changed the MAC address after restart or shutdown.

    And as I wrote in version 18.2, Wi-Fi keeps both IP and MAC and can be permanently reserved in the router.

    Versions 18.1 and 18.2 on LAN with DHCP do not hold IP or MAC and cannot be reserved on the router.

    I'll try to help with X8HP:)

    Next release ,i will revert to the kodi 18 image x8hp dtb's

    wrong feedbacks or i've misunderstand some, i've made a change which has broken the "fixed lan ip" .

    Fix: Lan utp static ip · datrh/[email protected] · GitHub


    meantime, x8hp users, if you want to be able to use a fixed LAN ip, replace the dtb.img on your SD (or in the gz/tar) by the kodi18 image one.


    it will not fix the "mac address behaviour"

  • I hate to break the news but either way still reverts back to DHCP after a reboot... Got the "x8h plus with "X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img"(true shutdown) and I even tried a fresh install 18.2 from SD with the dtb.img replaced from 18.0(final) and still goes back to DHCP after reboot/shutdown. Lets wait to see for more feedback as I might have an "Odd Box". When I ran Kodi 17.6, the first image listed = one that booted and worked if that helps.

  • For me it is different. Using also Darth's Lollipop image. I don't have fix IP but MAC address don't change anymore and could reserve IP on the router.

    So this is okay for me.

    Never got any fixed IP from any of the kodi 18 images.

  • I hate to break the news but either way still reverts back to DHCP after a reboot... Got the "x8h plus with "X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img"(true shutdown) and I even tried a fresh install 18.2 from SD with the dtb.img replaced from 18.0(final) and still goes back to DHCP after reboot/shutdown. Lets wait to see for more feedback as I might have an "Odd Box". When I ran Kodi 17.6, the first image listed = one that booted and worked if that helps.

    if you dare , you may also try the dtb from the kodi 17.6 image.

    use a spare SD 'cause it may not boot at all.

  • For me it is different. Using also Darth's Lollipop image. I don't have fix IP but MAC address don't change anymore and could reserve IP on the router.

    So this is okay for me.

    Never got any fixed IP from any of the kodi 18 images.

    in my case, i got X8-H also running the mod Finless firmware.

    fix IP is ok but MAC Address changes


    trying to get something 100% functional from these chinese boxes is like the holy grail quest ^^

  • if you dare , you may also try the dtb from the kodi 17.6 image.

    use a spare SD 'cause it may not boot at all.

    Tried it, boots up fine, worx but IP is random with every boot, fixed IP after reboot reverts back to DHCP .... Grrrrr.. anybody else ?
    btw. for a Chinese box I thought we had the Elite with Minix compared to other garbage out there that are still supported with CoreElec (got a cheap x96"clone", build a fan for it and it runs like a devil with CoreElec 9.0.2.... Will never figure that out LOL

  • I have been quite active with my Minix a few years back but retired the device a while ago. Actually, I still own two X8HP's and recently decided to re-use at least one of them.


    I managed to put the Kodi 17.6 in a while back (running on internal) and today I tried the latest 18.2.


    I've always used the .tar method simply uploading the new firmware onto the update folder (on internal) and always adding the .nocompat just to be sure.


    So I did that for 18.2 from early May and then rebooted. Installation went fine, all OK and the device rebooted.


    But then, where normally I'd expect the splash screen, now I get this:


    ***Error in mount_flash: mount_part: Unknown filesystem ***

    ### Starting debugging shell for boot step: mount_flash... type exit to quit ###

    #_


    A flashing cursor so I'm in some kind of shell I guess.

    What should I do to get it back working?


    Addition:

    When I type exit in the shell, the LibreElec splash screen does come up.

    But a new error message appears:


    *** Error in prepare_sysroot: mount_common: could not mount /dev/SYSTEM ***

    ### Starting debugging shell for boot step: prepare_sysroot... type exit to quit ###



    Note that I've never used Libreelec from a flash card, always from internal.

    Edited once, last by Arcee ().

  • Hi,


    i had to mod the boot script to be able to boot from internal with LE9.0 Kodi 18.x.

    just toothpick the device again and it should be ok.


    see #1

  • Hi all,

    I just re-flashed my x8h plus with X8H_PLUS_LOLLIPOP_RC2_NEWBOOT.img, but I can see only black screen after switch on.

    is this behaviour OK?

    Same here.
    It starts (toslink led turns one), then toslink led turns off and that's all.
    Keept it on for 30 minutes, no changes.

    :(

  • Thank you so much datrh ! The toothpick method worked, followed by an INSTALLTOINTERNAL from SSH and now it is working fine. It was a matter of minutes to get my Minix back alive.


    And... I am blown away. Everything works! Wifi works instantly, 4K works instantly, playing x265 at low CPU with hardware decoding works (even smooth in 4K), DTS pass through works, this is the most I've ever got out of my X8-H Plus. It is like having bought a new device!


    Thumbs up and thank you thank you thank you for your continued efforts to keep the Minix up to date!

  • I could just make one request- an earlier Kodi build was able to boot up without HDMI cables connected.


    One of my Minix units I use as a audio player with only spdif connected (no TV nearby) but this 18.2 won't boot with no TV connected. If that last thing would be possible, this would be the ultimate perfect build.

  • Has anyone managed to solve the static ip problem with the minix neo x8h plus and latest version of lbreelec?

    I use the Yatse app as a controller and the ip change is frustrating

  • Hi,


    My Wetek Core just died and i got a Minix X8H from a friend, updated it to lollipop and then installed 18.2 to SDCARD and now nand.

    Works great i just have 1 issue and 1 question.


    1. My issue is that i can't get the box to connect to PC, PC can connect to the box but not the other way around, tried NFS SMB HTTPS both on Windows and Linux OS running on my PC.


    2. I was wonder if it's possible to configure remote.conf to make the wetek remote work on the minix since the minix remote kinda sucks


    *note: haven't experienced any issues with 18.2 but the final version has the wifi crashing all the time.


    UPDATE:

    1. I manged to get a connection with DLNA but anything else failed... very strange and i didn't get any errors or ip\mac\connection issues


    2. i tried making a remote.conf file but only after setting the factory code only the power button appeared in dmsg so other buttons didn't work no matter what i did


    UPDATE 2:


    1. Tried Kodi 18 AKA final version it wasn't crashing this time but same issue exactly, moreover the DLNA only works until reboot after reboot i need to restart the DLNA service to make it work again.... very bad solution which i'm assuming is a Kodi issue based on comments i've seen around.

    I think v17 is also bad but i haven't found a libre build for minix with 17 to test it out, the comments i remember said 17 is also bad the their solution was to downgrade to 16 then upgrade over it to make it stick.


    2. Regarding this i wasn't able to make the other buttons work or appear in debug nor did i find something useful on the Wetek side for this..

    Edited 2 times, last by Yorker ().

  • Hi,


    i use smb. (shares on windows 10 64bit latest patches-updates)


    to get it working , i've mod :


    • hosts.conf
    • sources.xml
    • passwords.xml


    regards