feedback for test build LibreELEC-RK3328

  • It's based an older (pre Krypton) version of Kodi .. you can tell by the ancient 'codecinfo' screen.

  • Here is a Rock64 image.

    MEGA

    Not usable with TVHeadend yet... SD content plays fine with HW acceleration, but HD content really struggles, and the device reboots itself after a couple of seconds.

    A user of Rock64 boards and Tvheadend

  • boudicca99

    wibble...is this conversation entirely chalk v's cheese then ? hey ho...


    I can’t get libreelec to be close to functional as an HDR platform.


    The pictures I posted are from RKMC (Android 7.1 for Rock64) to show that 4k HEVC + HDR not only plays, but also outputs HDR to my Vizio M

  • Here is a Rock64 image.

    Thank you for making this image.


    Reporting Black Screen when leaving box powered on and turning TV off.

    When i turn TV Back on after a long time l have a Black Screen and no response from remote commands.

    Does not happen if i turn off TV and then turn TV back on in a short time.

    Leave box on overnight with TV off and it definitely will happen.

    I disabled CEC in case that was the issue but it is not.

    The previous black screen issue is FIXED in this image :)

    Not usable with TVHeadend yet... SD content plays fine with HW acceleration, but HD content really struggles, and the device reboots itself after a couple of seconds.

    Make sure you have updated client from repository.

    I'm not having issues as serious as yours.

    All SD channels play fine. Damn SD Channels Suddenly Don't Work At All.

    I have no idea what happened today. I can't get a picture at all on SD Channels. Won't open. It looks like it has opened but no picture or sound. Pressing OK button once after choosing SD Channel Nothing. Pressing it a second time and a Black screen appears with OSD visible. Press "o" on remote and i can see Software decoding at work. No audio or video.

    Gui sound is heard whilst moving through GUI menu . Choose stop and returns back to channels home screen.

    HD channels sometimes start with Audio/Video BUT Audio drops out within 5 seconds and picture freezes.

    I can see the AV Sync runs out of sync when that happens.

    I stop stream restart and it works. The Deinterlace issue and 25fps is known issue so will wait for next build.

    Everything else seems to be fine. No SD Movies open from my home media network. Just a spinning wheel . HD Movies open first shot.

    Need more time to run it. Fixed all struck out lines above with this image update.

    Again thanks to everyone involved in making images available.

    Edited 2 times, last by kostaman: Updated results ().

  • mo123

    Would you do a new build for mvr9 with latest kwiboo changes please?

    No new video changes, only addon changes for the last 4 days that no one will notice.

    If there are big improvements, I'll make a new image.

  • I thought the rkbin update has a relevance.

    rkbin: update to 3c721bd · Kwiboo/[email protected] · GitHub

    Most video changes are from kernel, mpp.

    Part7 branch doesn't have hdr changes and it will cause problems if you manually add the patches since they have to be adjusted again to be compatible with new code in the rest of LE. So it will be too much work for no added benefits for now.

    In a few weeks more RK changes should be merged into Kodi code and LE code then it should work much better, we just have to wait.

    Here is the latest image based on LibreELEC code of 30/08/2018(Commits · LibreELEC/LibreELEC.tv · GitHub) but without hdr, rkbin latest changes not merged yet into LE if you want to test.

    libreelec-rk3328.arm-8.90.004-box-trn9.img.gz


  • RK3328 Rock64 img, cool... HDR fine, same issues as MO123 img. Rock64 24/25/30/50 and the odd 60fps 2160p HDR play well.


    For Rock64, Most 2160 60fps HDR or non-HDR lose audio sync / buffer and generally merde.


    RK3399 Rockpro64 img. wow first time HDR on the RockPro again 24/25/30 (not 50 had Mont Blanc 4k HDR blanking/buffer possibly occasionally) and ironically the first issue I have had with 24fps HDR but was a Rip...which played fine on the Rock64...


    The difference with the RockPro here that more 60fps HDR worked better. Especially LG Chess 4K HDR which buffered before on the Rock64, but not this time...so we are on the right track....still and issue for Sony Swordsmith (audio sync)


    But this is the first time I've seen 4K HDR content autodetect on the RockPro64....

  • CvH Greatly appreciate the test image.

    Solved most issues from my previous post #242

    Thanking Kwiboo for his great work as well. :thumbup:


  • Using real world files NOT demo files.


    Device = Rock64 2gb

    This build plays nothing, absolutely nothing past 20 seconds.


    I do not test .ts files.


    All files tested are .mkv

    Tested h264 and h265

    HDR and non HDR

    Nothing plays past 20 seconds.

    ALL videos freeze permanently


    I would greatly suggest that other people testing this platform get ahold of real world files to test with. Aka mkv encodes of popular movies.

    It’s great if demo files play, but it means nothing if that’s all that plays.

    It can’t be expected that one would remux an entire catalog in order to have it playable.

  • Using real world files NOT demo files.

    It’s great if demo files play, but it means nothing if that’s all that plays.

    It can’t be expected that one would remux an entire catalog in order to have it playable.

    m2002briguy I apologize that for some reason you are unable to test with demo files. I can appreciate that you do wish to test by converting an entire catalogue to ts content.

    Let me state for the record. I have tested mkv mp4 ts at 720p 1080p 2160p 24/30/60 and 2160p HDR 24/30/50/60 and with x264/x265/HEVC on a fresh clean Sandisk 10 microSD loaded with CVH's and MO123's LibreElec 9.0 for Rock64 e.g LibreELEC-RK3328.arm-9.0-devel-20180901131938-4cd857c-rock64.img with the default skin/setting with many full HD files and HDR "sample" files ( not just Industry Demos!) from a Buffalo NAS over 1Gbit ethernet on both NFS and SMB shares.


    The only issues I am experiencing are mostly with 60fps files which the Rock64 is struggling with in all 4K flavours.


    The TV used is a Philips 43PUS7303 (2018 model) with very ordinary HDMI cables into the HDR supported port of my TV, connected to a standard Rock64 2Gb (with a heatsink covering both memory and RK3328) using the PSU purchased from Pine for the Rock64.


    I don't know your configuration but please by all means compare this to mine and we can see if we are all just....missing something as I am not experiencing any issues with the latest build as posted by you above.


    I hope this helps. I can understand the frustration, and I am sure we can work! though it :)




    edit: actually have found an issue with one, investigating atm.....freezed after 21mins and then repeated freezes at the same point more or less. the file is 52Gbytes so..hmmmm pausing and will try to resume again shortly. Will get back to you.


    1. 52Gb 21min35Sec File A.I.W 2018 2160p 24fps HDR Freezes (stopping any file then gets the Timer icon, reboot and the causes a further reboot of Libreelec if I attempt to resume beyond 21.35...and now if I fast forward...it also crashes and jumping chapters... hmmm Big files...possibly I/O related. Its interesting I was having fun with this file also on RockPro...wont play at all.


    2. 19Gb File R.P.O 2018 2160 24fps HDR - Plays fine, 46 mins in.


    So not a consistent issue...will try some more and get back to you.

    Edited 7 times, last by boudicca99 ().