Raspberry Pi 3 B+ reboot problems

  • Hi,

    this is my first thread here and first I want to thank the devs for the freat work!

    I've upgraded my Pi3 B to Pi3 B+ (with the same SD card and LE 8.2.4 on it) and everything works fine except reboots.

    System does not boot on reboot (run from SSH or inside KODI). But cold start works well.

    Is it possible that there is a problem when upgrading from B to B+, or a corrupt SD card (but cold start and everything else works fine), or is there maybe a bug?

    Anyone else got this problems?


  • Corrupt SD cards is always an option, but other than that we didn't receive mentions of similar reboot issues.

    Submit your kodi.log via pastebinit.com , and perhaps we can see a cause in one way or another.

  • I've seen this happen 2 or 3 times as well but it was rather hard to reproduce - most of the time reboot worked just fine.

    I just managed to reproduce it and capture the kernel output - it seems to be a bug in the RPi3B+'s ethernet driver which let's the kernel crash.

    I'll try to dig into that a bit and see if it's a general problem with the RPI3B+'s ethernet driver or something specific to LibreELEC.

    so long,


  • Thanks for the reply.

    Well as I said it was not happening each time, I would say 6 of 7, which is quite a lot ;)

    I am using another Pi3 B+ with raspbian stretch (all updates done) and having the same issue there!

    I don't know where to post the issue, but I think this should be known by Raspberry devs anyway, because it's simple to find, or am I wrong?

  • I've tried several things now:

    Fresh install of Libreelec => first reboot failed and then 10 of 10 reboots worked well

    Fresh install of raspbian => all reboots (10 of 10) worked

    So maybe it's a problem on just updating from Pi3 B to Pi3 B+ without fesh install?

    Are there some (config) files that are different on these installs? It's the same image, isn't it?

  • OK, now I've no ideas:

    After testing fresh installation of raspbian and libreelec on the new Rpi3 B+ I've reinserted the old SD-Card with the (upgraded) image of libreelec and this happened:

    first boot was fine => reboot failed once => and then all reboots worked without problem?!

    How could that be? Is there something done with the hard- or firmware on first boot or on first dist-upgrade that is not done when upgrading the hardware and using the old image?!

  • The issue seems to be a race condition in the ethernet driver when shutting down the network interface. This class of issues is one of the nastiest as it depends on exact timing if you hit the issue or not - and for that reason they can be extremely hard to reproduce.

    Simply speaking: it's rather random of the issue shows up or not.

    You don't need to spend more time on that, I managed to find out what's happening and why.

    A possible solution for the issue is already on the horizon, but it could take a bit until the fix is finished and added to the driver.

    Details of my analysis are in this RPi kernel issue: oops in lan78xx_delayedwork on kernel 4.9 when rebooting · Issue #2467 · raspberrypi/linux · GitHub

    so long,


    • Official Post

    I've had a play with my new RPI3 B+ on LE 8.2.5 and rebooted (SSH and Kodi) about 7 times without an issue. However as @HiassofT mentioned, it's rather random.

    As the RPi3 B+ is fairly new, it's unfortunate that the timings didn't arrive in time for 8.2.5, so it's better to use a LE9 test build.

  • The initial 8.2.4 reboot issues were fixed with 8.2.5. After jumping through versions with the 3B+ including 8.2.4, 8.2.5, and various 9.0 nightlies, I've gone back to 8.2.4.

    It's the only build for a 3B+ that seems stable with the NextPVR addon and watching CableCard broadcast through an HDHomeRun Prime.

    Everything else either crashes during playback or in the case of 9.0 nightlies, has issues with interlaced video and black/flickering screens.

    I'm sticking with failed reboots once in a while and have disabled updates...

  • I'm not aware of any reported issues with interlacing or black/flickering screens in 9.0 (there's a dedicated 9.0 testing thread on the Kodi forum) and without any bug reports there isn't likely to be a fix.