Does this dvb s2 tuner work?

  • No, it does NOT !!!


    Tested the above device ~2 weeks ago on last LE release and on some vanilla/distro kernels on Fedora 27 (x64_86)


    ID 0b48:3011 TechnoTrend AG TT-connect S2-4600


    => BUG: unable to handle kernel NULL pointer dereference


    see => BUG: unable to handle kernel NULL pointer dereference


    same Bugs in

    - DVBSky S960

    - TerraTec Cinergy S2 Rev.4 (ID 0ccd:0105)

    Technotrend and TerraTec was tested by me


    esp. Technotrend I got an additional error message sort of "overcurrent on usb port xyz"

    not so on TerraTec ...


    If they would work I would go for a TerraTec again

  • Hello,


    So I have a Raspberry Pi 3 now connected to the TT Connect s2-4600 with the official power supply and a 16GB microSD Card with latest Noobs installed on it and I have now a dual boot with Raspbian and Librelec.


    On Libreelec I have managed to Install Tvheadend 4.2 and Tvheadend HTSP Client and then Rebooted the system.

    After that I made sure the the PSU of the tuner is working by checking it using voltmeter. and I have checked /lib/firmware and I have found the three files that are related to the device installed already

    1- dvb-fe-ds300x.fw

    2- dvb-fe-ds3103.fw

    3- dvb-demod-m88ds3103.fw




    And the result is : The device "does not" work, it has not been detected by tvheadend when I accessed it using mozilla Firefox from windows. Tvheadend worked but I did not find the device listed under DVB Inputs. Same case with Raspbian+tvheadend


    So I have tried to install the drivers myself (I have installed linux headers and found build essentials already installed)


    Code
    1. sudo apt-get install raspberrypi-kernel-headers


    but: "s2-TT4600-linux-20120815" and "liplianin-s2-liplianin-v37-67ce08afdbe7" and "liplianin-s2-liplianin-v39-4c01a16b6237" did not work. I am not an expert in Linux but I think these Drivers have been made for older Kernels.



    worked for me O_o

    not saying there is no bug, but no problems so far

    How did you install the driver. Was it plug and play?



    Here are some INFO using PuTTY during SSH with the Pi. Any ideas. Thanks to everyone.


  • @Softlander


    please do a


    dmesg|grep -iEw 'bug|conflict|corrupted|error|fail|fault|fatal|Lock|NULL|segfault|stack|trace|warn'


    or attach the lines between [ 4.588994] and [ 5.068200]

    or the whole dmesg output

  • Btw pls test a milhouse build if it works there, if there is a kernel bug it won't get fixed anymore as LE9 is already at the "corner".

    'can't test against above driver related bugs cause the devices were send back to the seller.


    But I can test - and actually do - with another x86_64 box with an DVB PCI card !

  • Btw pls test a milhouse build if it works there, if there is a kernel bug it won't get fixed anymore as LE9 is already at the "corner".

    Same result. It "did not work". I have downloaded the latest OpenELEC Img file, installed it, copied the milhouse build to the update folder, rebooted, installed tvheadend, and checked DVB Inputs in Tvheadend. It was not detected before and after installing milhouse build.


    So please can you tell me how did you get the s2-4600 to work? what does dmesg tells you?



    Here is the output:

  • yea the driver crashs, could you pls disable the hauppauge DVB driver addon (choose LE standard driver) and try again ? (and post dmesg | paste )

  • It's a bug. The driver crashes in tt_s2_4600_frontend_attach() when there is no external 12V attached or the fuse is blown on the PCB.


    As you did check the PSU I'm afraid it is the latter case.