S905x support, what is needed?

  • Mini M8SII is S905X device. Install guide:


    S905X: You don't need to provide a device tree.


    So far, I cannot even boot dev build from 25/09 on my Mini M8S II - S905X from SDcard. Ends with: "could not mount /dev/mmcblk0p1"

    Edited once, last by lama0900 ().

  • lama0900 Have you tried running a "fresh" SD card image?


    Keep in mind that I still haven't received my S905X, this image is untested.

    Edited once, last by kszaq ().


  • lama0900 Have you tried running a "fresh" SD card image?


    Keep in mind that I still haven't received my S905X, this image is untested.


    Yep tried exactly that and got the error from above :)
    No complain. Just a notice.
    Can take some time to get a cheap S905X box :D it took me more than 2 weeks.


  • lama0900 Have you tried running a "fresh" SD card image?


    Keep in mind that I still haven't received my S905X, this image is untested.


    I also tried to test this new build but my device did not manage to boot.Tested on 3 different uSD (Tanix TX5pro 2GB RAM 16GB eMMC).
    5 consecutive boot ends with: could not mount /dev/mmcblk0p1 not even LibreELEC splash only black screen
    Older test build boot normally.
    Tested with dtb.img as suggested also without dtb.img also with some custom edited dtb.img.

  • Hi, i have a old kszaq buil on SD card of my mini m8s II. I'd like to update with latest kszaq build.
    I read 905 topic.


    Is it enough to put LibreELEC-S905.aarch64-7.0-devel-20160925032632-r23354-g31edb11.img in update folder (SD card) and reboot ?
    Have to do other ?
    Thanks

  • I also tried to test this new build but my device did not manage to boot.Tested on 3 different uSD (Tanix TX5pro 2GB RAM 16GB eMMC).
    5 consecutive boot ends with: could not mount /dev/mmcblk0p1 not even LibreELEC splash only black screen
    Older test build boot normally.
    Tested with dtb.img as suggested also without dtb.img also with some custom edited dtb.img.


    I tried on my Beelink MXIII II (S905X 2G/16G boot to SD Card) - same issue as pm_mickey (halts with 'could not mount device') - this was deleting the dtb.img as per opening post instruction (and how I had tested the previous build,which booted fine)
    Now there are contradicting (maybe confusing is better word) for S905X as to whether to
    a) delete the dtb.img
    b) leave the dtb.img
    c) use device tree from 7.0.2.007 build folder


    This was with fresh image of latest build on a re-formatted SD card;
    I have only tried a) and got same 'could not mount (etc)' - when I checked the thread for updates and found pm-mickey was observing the same; but also the confusion about how to configure the SD card?

    Edited once, last by DEcosse ().


  • Second test build: I reverted some kernel config changes I made that may have influenced ability to boot on S905X. Please have a look:
    2016-09-25-devel-2


    Thanks for your prompt response and hard work. But sorry, still doesn't work on my Mini M8S II, LibreELEC logo didn't even shown.


    I used a fresh SD card installation.


  • Second test build: I reverted some kernel config changes I made that may have influenced ability to boot on S905X. Please have a look:
    2016-09-25-devel-2


    Just tried this build but got audio problem with Live TV. (No problem with video files.) But I can see Live TV in other tvheadend client on other machine with no problem.


    (My box is Nexbox A95X, S905X 2/16gb, LE installed on NAND)


    Here is the log file

    Edited once, last by pawnthep ().


  • MPeartnoy Can you please test channel mapping with the latest dev build?


    Channel mapping appears to still be an open question.


    I had some time today, so I tested channel mapping on S905 (not S905X) with a Denon X1200W avr with 7.1 speakers. The latest dev build (2016-09-25-devel-2) has all channels correctly mapped when using multichannel PCM output (tested with 5.1 AC3, 5.1 DTS, 7.1 DTS-MA, 7.1 Dolby TrueHD), and all these sound formats were also sent correctly using hdmi passthrough.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • I found the reason for sdcard booting issue. The sdcard detection is not synchronized with emmc detection. Sometimes sdcard is detected as a /dev/mmcblk0

    Code
    [    [email protected]] sd: new high speed SDHC card at address aaaa
    [    [email protected]] sd: clock 50000000, 4-bit-bus-width
     
    [    2.55[email protected]] ge2d: ge2d clock is 400 MHZ
    [    [email protected]] ge2d: ge2d: pdev=ffffffc023c61c00, irq=182, rstc=0xffffffc023049bc0, clk=ffffffc01037ac00
    [    [email protected]] ge2d: mapped phy: 0xd0160000
    [    [email protected]] ge2d: ge2d start monitor
    [    [email protected]] mmcblk0: sd:aaaa SL16G 14.8 GiB


    or as a /dev/mmcblk1

    Code
    [    [email protected]] sd: new high speed SDHC card at address aaaa
    [    [email protected]] sd: clock 50000000, 4-bit-bus-width
    [    [email protected]]  
    [    [email protected]] mmcblk1: sd:aaaa SL16G 14.8 GiB 
    [    [email protected]]  mmcblk1: p1 p2
    [



    In mmcblk.zip are both logs. First one is for successful sdcard booting for T95X tv box.


    kszaq: Try to this fix issue to mount /flash and /storage for correct /dev/mmcblkX.

    Edited once, last by afl1 ().


  • kszaq wasn't there a attempt to fix this issue by trying to mount by LABEL already?
    (As I remember, this approach didn't work either).

  • Yes, this fix is included in all development builds. I think there is an issue with delayed detection of SD card. Or no detection at all.


  • Yes, this fix is included in all development builds. I think there is an issue with delayed detection of SD card. Or no detection at all.


    Same guess. It seems that it's not clear which one is detected first. eMMC or SD.
    And this changes from boot to boot.


    But how to fix detection order or detection itself :D that's something related to u-boot, isn't it?

    Edited once, last by lama0900 ().