[SOLVED] Dropped frames caused by subtitle rendering

  • Great wrxtasy . Thank you for all your hard work and thank you for fixing this.


    Thank you kszaq for a patch.


    I was about to pack and send my U9 back to Amazon, as the return window was going to end next week.


    Thank you Pinki for not giving up and providing some more examples. I totally gave up after seeing some replies from some veterans on this forum.


    It is really difficult to stay motivated when people accuse you of lying or just ignore you, because they do not experience the same thing or just don't care, or tell some weird theories, that do not make any sense - I do not want to cite all nonsense I saw.


    So thank God we have you wrxtasy  :)

    Edited 2 times, last by atilaks ().

  • Great wrxtasy plz do something for S905x boxes because first line of srt subtitles are also stuttering in S905X and I notice some specific movies are also have stuttering.

  • wrxtasy does this build with the fixed subtitles also have the community features like your other builds with overclock, chroma setting and deinterlacing setting?

    Mecool m8s pro S912 3/16gb 8.2.2.4oc installed to internal

  • wrxtasy , plz made build for s905x. I m eagerly waiting for your build for S905X ( subtitles fixes and overclocking deinterlecing, chroma setting etc) most important subtitles fixes.

  • Can I use this patch om the 8.2.2.3 build, or do I need to update to 8.2.4?


    Edit: updated to 8.2.4, and then applied the fix, seems to work! Maybe I misinterpreted what you said about VSYNC wrxtasy , but VSYNC doesn't seem to be enabled in the interface and not when a video is playing?


    Thanks!

    Edited 2 times, last by e2zippo ().


  • YES, it works for me on my X92 box. Tested it for several hours with my colection of problematic subtitled material, and it works like charm. Finaly i can use HW decoding (on your 8.2.4 OC image) for ALL my video material, no more need to switch to SW decoding.


    One minor thinng that I observed is that on some material video stutters when displaying the first subtitle, but after that all is running smooth.

    X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2,

    Mocool KM8 2/16 0.1GB Ethernet Box_Android 8.0


  • Can confirm that GUI is snappier and GUI overlay stutter is gone. Only minor downside is that there is some tearing in the GUI because of wrong vsync.

  • Maybe I misinterpreted what you said about VSYNC wrxtasy , but VSYNC doesn't seem to be enabled in the interface not when a video is playing?

    Maybe VSYNC is completely broken in this build, due to an old version of Mali driver.

    Quote

    Warning: this breaks vsync for Mali r5p1 and earlier

  • Maybe VSYNC is completely broken in this build, due to an old version of Mali driver.

    You would have really bad Kodi user interface tearing if there were no Vsync - exactly like we used to see in the early days of LE on the S912's before kszaq worked his hybrid GPU driver magic.


    The regular Linux r5p1 Mali driver is not used at all on S912's - in the words of kszaq :


    Quote

    These builds (S912) use libhybris and Android gralloc Mali driver to provide OpenGL for Kodi


    LibreELEC.tv/package.mk at 4218dfcb69eaf6d189fd13c5af1cc4e93c1a2938 · kszaq/LibreELEC.tv · GitHub

  • Can confirm that GUI is snappier and GUI overlay stutter is gone. Only minor downside is that there is some tearing in the GUI because of wrong vsync.

    Yes tearing in the gui is very present in this build.

    I installed this build on my mecool M8S PRO L.


    wrxtasy is it maybe possible to get rid of tearing in gui?

  • Yes tearing in the gui is very present in this build.

    I installed this build on my mecool M8S PRO L.

    I'm not seeing any completely obvious GUI tearing at 1080p50Hz on the U9.


    Q. Have you overclocked the S912 GPU and verified it's running at 792MHz ?

    Code
    1. cat /sys/class/mpgpu/cur_freq


    EDIT: There may be a tiny bit if I look very closely at the bottom of the screen with some Kodi icons. It is no where near the really obvious tearing we had in early versions of LE for the S912.


    Am I going to fix it - maybe.

  • wrxtasy There is minor tearing in the GUI with the new build but nothing major at all. I only notice it if there is some animation in the GUI.


    For example I only see it if I enable "Use slide animations" in Estuary skin. If I disable it, I can barely see any tearing. All in all, a very minor thing compared to the fix for the stuttering issue.