[SOLVED] Dropped frames caused by subtitle rendering

  • By the way.. this problem i have seen before on the Raspberry Pi... Helix.

    So far i can remember it was: OMX/MMal or Resample audio/drop du

  • These settings reduced dropped frames issue to minimum.


    Settings for S905X box with Krypton build and 50/60 Hz panel TV.

    No audio passthrough.

    It should also work with future Leia builds.

    I assume all TVs have regular 24p mode (so called Cinema Mode).


    Method 1


    System settings -> Display

    - Resolution: 1080p

    - Refresh rate: 50 Hz / 60 Hz


    Player settings -> Videos

    - Adjust display refresh rate to match video: always or Start/stop (LibreELEC will automatically switch TV to 24p mode)

    - Sync playback to display: yes (compensates the FPS/Hz differences). Enable it only if you're experiencing subtitles frame drops.


    Method 2


    System settings -> Display

    - Resolution: 1080p

    - Refresh rate: 50 Hz (why 50 and not 60 is explained later)


    Player settings -> Videos

    - Adjust display refresh rate to match video: never

    - Sync playback to display: yes (mandatory)


    The reason for judder is framerate most movies are shot. It's precisely 23.976 fps (24 fps in round figures).

    For judder free playback the 24 fps must divide into refresh rate of your TV.

    60 Hz panels are problematic in this regard because 2x24=48 and 3x24=72. Not even close to 60.

    Closest to 48 is 50 Hz setting. That is why we set 50 Hz in LibreELEC display settings.

    Disable Adjust display refresh rate to match video. Set it to never.

    Sync playback to display will help to compensate the 48≠50 difference. Playback will be smooth but 4% faster than normal. It looks kinda funny at first.

    You need to adjust audio delay after that.


    If you own true and properly set 120 Hz panel TV there will no dropped frames or 4% faster playback. Just TRUE cinema experience. 120Hz/24fps=5. Perfect. It can't be any better.

    Many companies are advertising their TVs as 120 Hz but this crucial parameter is often misleading and may mean that in reality the panel is 60 Hz and the 120 Hz is achieved with enhancement method.

    You can check what panel your TV really has on manufacturer specification page. You can be surprised...


    Those who own 60 Hz or kind of 120 Hz false panel can:

    a) turn TVs motion enhancement off and use Method 1 or 2

    b) disable Adjust display refresh rate to match video and sync playback to display in LibreELEC and enable motion enhancement in TV.

    Sometimes they are doing good job and sometimes they can make it worse (soap opera effect).

    Anyway, best results in LibreELEC will be achieved with 50 Hz setting.

    TX5 PRO S905X

    Edited 13 times, last by yatoya ().

  • But you loose audio passthrough when enabling "Sync playback to display:"...

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Quote

    But you loose audio passthrough when enabling "Sync playback to display:"...

    And display refresh rate.

    Well, yes. Sync playback to display will not work using passtrough.

    Adjust display refresh rate to match should work.

    To have super smooth playback and passtrough you need 120 Hz TV.

    TX5 PRO S905X

  • Those who own 60 Hz or kind of 120 Hz false panel can:

    a) turn TVs motion enhancement off and use Method 1 or 2

    b) disable Adjust display refresh rate to match video and sync playback to display in LibreELEC and enable motion enhancement in TV.

    Sometimes they are doing good job and sometimes they can make it worse (soap opera effect).

    Anyway, best results in LibreELEC will be achieved with 50 Hz setting.

    I (think) i have this issue, I'm expierincing a microstutter when subtitles are enabled. Very annoying once you see it, it cannot be unseen :(


    I'm using a Minix u9 withc LE8.9.0.4 on it connected to a Samsung ue75mu8000 which should be a 120Hz panel as seen here. The same issue is also in the LE Kryption release, i've tested this a while back.


    yatoya : I've tested both your methods but the microstutter is still there. As a reference i'm using the Terminator 2 movie in 4K, chapter 9/12, 1h30m mark. In this scene which is shot from a moving car you can see the stutter clearly in the stripes on the road and in the stop sign. The stutter seems to take place at the same moment every time i play this scene, therefore i use it as a reference.


    Does anybody have any other suggestions? Is someone even working on this issue, is it recognised as a bug? I don't see anybody else with a U9 complaining about this, i assume they are all running LE and not Android (i don't want to run Android due to refresh rate and color space issues). Maybe it's just my setup/configuration or most other people don't use subtitles (i'm from Belgium, it's common to use subs here).


    Many thanks in advance.


    Ps. wrxtasy : to me you are an authority regarding the u9, LE and configuration of this setup :) If you don't mind me asking, are you aware with any microstutter issues as detailed above on the u9? Many, many, many thanks :)

    Edited once, last by MichelLoyen: tag wrxtasy asking for help... ().

  • I (think) i have this issue, I'm expierincing a microstutter when subtitles are enabled. Very annoying once you see it, it cannot be unseen :(


    Does anybody have any other suggestions? Is someone even working on this issue, is it recognised as a bug? I don't see anybody else with a U9 complaining about this, i assume they are all running LE and not Android (i don't want to run Android due to refresh rate and color space issues). Maybe it's just my setup/configuration or most other people don't use subtitles (i'm from Belgium, it's common to use subs here).


    On my x92 box I have this "subtitle micro stutter" on some movies running LE8.9.0.4. To avoid it I turn off Hardware Acceleration for those videos. There is enough juice in S912 to handle software decoding...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • On my x92 box I have this "subtitle micro stutter" on some movies running LE8.9.0.4. To avoid it I turn off Hardware Acceleration for those videos. There is enough juice in S912 to handle software decoding...

    I tried this although i was pretty sure it wouldn't work. It doesn't. My box just crashes on starting a movie to the point i have to unplug the power just to get it to boot again. Perhaps you only use <1080P content? I think you really need hardware acceleration for 4K/HDR content.


    Thanks for the tip anyways, at this point i'm willing to try (almost) anything ;)

  • Perhaps you only use <1080P content?

    Yes, I use SoftwDecoding only on 1080p...

    ODROID N2_S922 4G - 1GB Ethernet, X92_S912_q201 3/32G - 1GB Ethernet Box_Android 7.1.2, Mocool KM8_S905X 2/16 0.1GB Ethernet Box_Android 8.0, X96Mini_S905W 2/16G 0.1GB Ethernet Box_Android 7.1.2

  • I've tested both your methods but the microstutter is still there.

    Both methods are for 60 Hz panel TV's.

    I don't own a 120 Hz TV but in theory you should disable Adjust display refresh rate to match video and you can try turn on and off the Sync playback to display and check the results.

    There could be problem with particularly Terminator 2 subtitles. Does it have some untypical subtitles (font)? Did you try different subtitles in different format like srt?

    How many stutters do you see by the way? Are there more more stutters after the 1h30m mark or just this one and after that movie plays smooth?

    If you go directly to chapter where to this scene to check the stutter it will always be there because Kodi 17 and 18 needs to buffer subtitles in order to view it. At least in Kodi for Amlogic devices.

    Try to play this scene one more time, then rewind the movie 10 second back or more and wait for the scene one more time. There should be no dropped frame this time.

    It's definitely a bug. For some reason Amlogic hardware has problem with it in new Kodi versions.

    If the problem persists try LibreELEC Jarvis [here]. It's free from this bug but Krypton handles the HDR videos and Jarvis not.

    TX5 PRO S905X


  • Hi. I've tried with adjust refresh rate on disabled and sync playback to display on/off. All of these combinations still produce stutter, especially in panning scenes. This is not confined to Terminator 2, it's in all movies when external subtitles are enabled. I just use T2 as a reference movie and the 1h30m mark as a reference scene because the stutter will always occur (multiple times), therefore i can reproduce the issue quite easilly. The stutter will occur throughout the whole movie, in any movie for that matter. To be certain i also tested by rewinding the movie more, for example by starting T2 at the 1h29m mark. In the panning scene at 1h30m the stutter will still occur, it makes no difference.


    I think this is a bug for sure, i saw a post in the Kodi forum from user atilaks mentioning the exact same problem (MINIX NEO U9-H (64-bit Octa Core Amlogic S912-H/ 4K UHD HEVC, HDR, Dolby Audio)).

    wrxtasy replied he cannot reproduce the problem using a minix u9. I'm running LE 8.9.0.4 via internal memory and not an USB stick. This is the only difference i know of between our setups, but i don't see how this should matter.


    One last thing: when i try to adjust the color of the font to grey for example, the subtitles in a movie will always be white. Also adjusting the size has no effect at all. Maybe this is somehow related to the stutter issue? Something wrong with configuration of external subtitles? Any other users experiencing this issue?

  • This is not confined to Terminator 2, it's in all movies when external subtitles are enabled.

    Reinstall LibreELEC by pushing .tar and the right dtb files into Update folder and restart the box.

    This inability to change subs color and size is weird. Running it from internal makes no difference besides speed.

    I was struggling with subtitles stuttering for weeks so I really understand how annoying that is. No one knows why some users have it and some don't.

    If your problem won't be solved change box for something that has manufacturer support like Wetek or Xtreamer. They use Kodi as well.

    All those cheap Chinese boxes are hit-or-miss devices. They work OK if you're lucky. And let's not forget they'd be complete trash without support of developers on this forum so a BIG thanks to them!

    One more thing... Have you tried different HDMI cable? There were cases where low quality HDMI cable was causing a number of problems with playback.

    Do the reinstallation anyway to fix color/size of the subs. It might fix the rest of problems as well.

    TX5 PRO S905X

  • yatoya : the good news is the issue of not being able to change the color/size of subs is fixed by the manual update. Thanks for that one! :)


    The bad news is the stutter is still there. Somehow it even feels it's gotten a bit worse because now it happens in a panning scene (like the T2 one) every time a subtitle appears on screen (or just before it). At first i had a feeling it didn't happen with all subtitles. Although i must admit this could just be me being paranoia, i've looked into this issue so many times im beginning to see stutters everywhere :P


    I've used a different hdmi cable (from the xbox one x, i assume that one should be ok) but this doesn't help, the stutter is still there.


    EDIT: one more question: I've been wondering if it would help if i switched back (temporarily) to Android instead of LE? I've switched to LE because i don't care about Android (just Kod) and there were some frame rate switching and or color space issues, but i don't remember the details anymore. I mostly wacht 4K/HDR movies, if that works without stutters then it would be fine as a temp solution.

  • MichelLoyen

    From what I remember Kodi for Android shipped with my box (Marshmallow) was unable to switch refresh rate to match video. I'm sure it was Android's fault but Android for your box can be better optimized. It's worth giving a try.

    You have 120 Hz TV so this option might not be important for you. And I'm pretty sure it's free form subtitles stutter issue.

    Developers said that it will be fixed in Kodi Leia but at the moment it's still there and I have a feeling it will stay that way.

    The other problem is the chip of your box. S912 is problematic. Most people experiencing subtitles stutter have S912 box. Mine is S905X and I had this problem too.

    There are occasionally frame drops every now and then but only when displaying first line of subtitles. After that it plays smooth as butter.

    I will test Kodi Leia when the beta is out. Even now at alpha stage the GUI is much more responsive.

    Android supposedly handles HDR quite well. Test it :)

    TX5 PRO S905X

  • I have a big problem with subtitles stutters with kszaq 8.2.2.3 and wrxtasy chroma 422 with enabled new features and 8.90.5

    Look at this video Libreelec subtitles stutters - YouTube

    Without amcodec acceleration everything is OK! but cpu is to slow for software 4k decoding


    I`m using

    echo '422,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

    echo 0 > /sys/module/di/parameters/nr2_en

    echo 1 > /sys/module/di/parameters/bypass_all


    Player > Video >

    Adjust display refresh rate > Start/stop

    Sync Playback to Display > Off

    Edited once, last by Pinki ().