SD creator failing with Windows 10

  • I see a few reports listed here on problems with creating SD bootable with the SD Libreelec creator. Had same problem myself. Used three different SD cards, and two different DELL laptops, kept getting resizing errors, sometimes received error on writing the img. I then tried an older PC I have running Windows 7. Worked like a charm with no errors. Checked Microsoft website but couldn't find any issues reported.

    • Official Post

    It's hard to comment. The Windows download is the most popular for the app and these days the majority of users will be using Win10, so quite why you've seen issues is not known. Overall we see very few issues reported.

  • I can confirm my experiences that the app stalls at 93% everytime on Win10 over multiple devices, cards, etc.

    I'm gonna have to install Win7 on an old PC just to make this image. doh. oh well I think it will be worth it :)

  • Yes I have this exact problem too:


    Windows 10, latest service pack.

    Are there any log files I might be able to provide to help diagnose what is happening?

  • I have the same problem. @4 sec remaining it has the same error message.

    I've tried an earlier version of libreelec but it's the same. I have no clue what to do next.

  • Exactly the same result here. Running W10 Ver. 1709. Trying to write LibreElec Version 8.2.1 ( for Wetek Hub) to 32GB SD card. Fails at 93%. Uninstalled Bitdefender firewall and antivirus, but made no difference.

  • Just ran into the freeze at 93% disk creation problem on a new Acer Aspire laptop, and formatting the USB stick didn't help. So I used my partition manager (MiniTool Partition Wizard) to check the 8GB USB stick I was using (and had used with other transfers between Windows and Linux), and sure enough there were three partitions on it with the primary one being too small for the image.

    So I deleted the 3 partitions, created one big one, formatted it to FAT32, and the image was created with no issues. 8) (I checked it out, and Kiwi Tim's Sandisk SD Formatter does the same thing - restores full capacity.)

    I was a Microsoft Certified Professional back when I retired from IT in the days of Windows 2000, but even at age 76, I still like to play with technology, including Windows, Android and Linux. Since I started playing with Linux a couple of years ago, I have found spurious partitions being created on USB sticks - and the FAT32 formatted partition made unreadable - when I go back to my Windows 10 laptop from my Intel NUC-based dual-boot Linux Mint/LibreElec HTPC.

    Windows on my laptop finds read errors and asks to fix the USB stick, but all it does is fix the format on the small primary partition, leaving most of the space on the stick unusable. Probably confusing for non-techies, but an unfortunate incompatibility issue that can pop up when taking a USB device back-and-forth between different operating systems.

  • I had the same issue and it kept crashing at 93%, not responding. Or it would say there was a write error. I checked the SD card and saw a lot of folders, I decided to see what would happened if I put it into my rpi, and it loaded up perfectly. Very odd!

  • Changed my O/S from USB to SSD

    When I did LibreELEC USB/SD Creator is still a hit & miss situation with the 93% error

    It's funny that it worked 1st time on LE 8.2.5 but when I changed to LE 9.0.2 93% error showed up

    Rufus seems to be far more reliable

    intel i3-7100 / Gigabyte H270M-D3H / GTX1050 / STX Essence

  • I tried something that worked in Windows 10. Sometimes windows programs with an exe extension don't work because the path is too long. I moved LibreELEC.USB-SD.Creator.Win32.exe and LibreELEC-RPi4.arm-9.1.001.img.gz to the root directory, C: . Then, the program completed.

  • I have only done this on my Windows 10 computer,burned and made a bootable disc (A 16GB USB),and the computer was successfully booted up,for Windows 7 and SD,i don't know much about them,maybe the burner you used doesn't work for Windows 7.

    I got them that they are compatible with Windows 7 and Windows 10.

    UUbyte - The Best Provider of ISO and DMG Toolkit

    Cain & Abel Download Free for Windows 10, 7, 8/8.1 (64 bit / 32 bit)

    Edited once, last by GExplorer ().